summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-08 07:47:01 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:46:36 +0100
commitfb07dedeee8c4298b3a74364cf0af872b93e7a81 (patch)
treec429742db1ef3cbf567db5e714ccad28e800ab94 /net-analyzer
parentnet-analyzer/fail2ban: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-fb07dedeee8c4298b3a74364cf0af872b93e7a81.tar.gz
gentoo-fb07dedeee8c4298b3a74364cf0af872b93e7a81.tar.bz2
gentoo-fb07dedeee8c4298b3a74364cf0af872b93e7a81.zip
net-analyzer/net-snmp: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.8-r3.ebuild (renamed from net-analyzer/net-snmp/net-snmp-5.8-r1.ebuild)6
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.8-r4.ebuild (renamed from net-analyzer/net-snmp/net-snmp-5.8-r2.ebuild)6
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.8-r5.ebuild6
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.8.1_pre1-r1.ebuild (renamed from net-analyzer/net-snmp/net-snmp-5.8.1_pre1.ebuild)6
-rw-r--r--net-analyzer/net-snmp/net-snmp-99999999.ebuild6
5 files changed, 20 insertions, 10 deletions
diff --git a/net-analyzer/net-snmp/net-snmp-5.8-r1.ebuild b/net-analyzer/net-snmp/net-snmp-5.8-r3.ebuild
index 8c4fab7b6892..4906c15987c3 100644
--- a/net-analyzer/net-snmp/net-snmp-5.8-r1.ebuild
+++ b/net-analyzer/net-snmp/net-snmp-5.8-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -40,7 +40,9 @@ COMMON_DEPEND="
zlib? ( >=sys-libs/zlib-1.1.4 )
elf? ( dev-libs/elfutils )
python? (
- dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_MULTI_USEDEP}]
+ ')
${PYTHON_DEPS}
)
pci? ( sys-apps/pciutils )
diff --git a/net-analyzer/net-snmp/net-snmp-5.8-r2.ebuild b/net-analyzer/net-snmp/net-snmp-5.8-r4.ebuild
index 119ec81687a2..2470f8472276 100644
--- a/net-analyzer/net-snmp/net-snmp-5.8-r2.ebuild
+++ b/net-analyzer/net-snmp/net-snmp-5.8-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -40,7 +40,9 @@ COMMON_DEPEND="
zlib? ( >=sys-libs/zlib-1.1.4 )
elf? ( dev-libs/elfutils )
python? (
- dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_MULTI_USEDEP}]
+ ')
${PYTHON_DEPS}
)
pci? ( sys-apps/pciutils )
diff --git a/net-analyzer/net-snmp/net-snmp-5.8-r5.ebuild b/net-analyzer/net-snmp/net-snmp-5.8-r5.ebuild
index 2b3f66b5294d..e1fa13504cfd 100644
--- a/net-analyzer/net-snmp/net-snmp-5.8-r5.ebuild
+++ b/net-analyzer/net-snmp/net-snmp-5.8-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -39,7 +39,9 @@ COMMON_DEPEND="
pci? ( sys-apps/pciutils )
perl? ( dev-lang/perl:= )
python? (
- dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_MULTI_USEDEP}]
+ ')
${PYTHON_DEPS}
)
rpm? (
diff --git a/net-analyzer/net-snmp/net-snmp-5.8.1_pre1.ebuild b/net-analyzer/net-snmp/net-snmp-5.8.1_pre1-r1.ebuild
index 0704a753212a..d853e1f035cd 100644
--- a/net-analyzer/net-snmp/net-snmp-5.8.1_pre1.ebuild
+++ b/net-analyzer/net-snmp/net-snmp-5.8.1_pre1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -43,7 +43,9 @@ COMMON_DEPEND="
pci? ( sys-apps/pciutils )
perl? ( dev-lang/perl:= )
python? (
- dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_MULTI_USEDEP}]
+ ')
${PYTHON_DEPS}
)
rpm? (
diff --git a/net-analyzer/net-snmp/net-snmp-99999999.ebuild b/net-analyzer/net-snmp/net-snmp-99999999.ebuild
index 901356c5a939..12ca0cc534b3 100644
--- a/net-analyzer/net-snmp/net-snmp-99999999.ebuild
+++ b/net-analyzer/net-snmp/net-snmp-99999999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -41,7 +41,9 @@ COMMON_DEPEND="
pci? ( sys-apps/pciutils )
perl? ( dev-lang/perl:= )
python? (
- dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_MULTI_USEDEP}]
+ ')
${PYTHON_DEPS}
)
rpm? (