summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-dialup/drdsl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-dialup/drdsl')
-rw-r--r--net-dialup/drdsl/Manifest2
-rw-r--r--net-dialup/drdsl/drdsl-1.2.0.ebuild45
-rw-r--r--net-dialup/drdsl/files/README87
-rw-r--r--net-dialup/drdsl/metadata.xml5
4 files changed, 139 insertions, 0 deletions
diff --git a/net-dialup/drdsl/Manifest b/net-dialup/drdsl/Manifest
new file mode 100644
index 000000000000..6bdd1d25106c
--- /dev/null
+++ b/net-dialup/drdsl/Manifest
@@ -0,0 +1,2 @@
+DIST drdsl-1.0-1.i586.rpm 25869 RMD160 61234b7a325bb0633b02837fef1923137ca5e05f SHA1 1b435450d4658e2733e8761ad8a1953569298303 SHA256 e4c4e1e246521b080ff61d08de9c6b584897c7d952c956e13803a6f8f905b750
+DIST drdsl-1.0-1.x86_64.rpm 30406 RMD160 7d8baa6dbf19a60e6ed1b76e9196901a2f3eafc7 SHA1 5ea5ee52cfb8d69544649fe52919cdfb4dc6b73b SHA256 7690a76942efa7f0218faeb8f6d59b4c9c4df04a73abcc900834e7ba273ce960
diff --git a/net-dialup/drdsl/drdsl-1.2.0.ebuild b/net-dialup/drdsl/drdsl-1.2.0.ebuild
new file mode 100644
index 000000000000..208eedf3b7a1
--- /dev/null
+++ b/net-dialup/drdsl/drdsl-1.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils rpm
+
+REL="10_3/2.6.22.13_0.3"
+
+DESCRIPTION="AVM DSL Assistant for autodetecting DSL values (VPI, VCI, VPP) for 'fcdsl' based cards"
+HOMEPAGE="http://opensuse.foehr-it.de/"
+SRC_URI="x86? ( http://opensuse.foehr-it.de/rpms/${REL}/32bit/${PN}-1.0-1.i586.rpm )
+ amd64? ( http://opensuse.foehr-it.de/rpms/${REL}/64bit/${PN}-1.0-1.x86_64.rpm )"
+
+LICENSE="AVM-FC"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE="unicode"
+
+DEPEND="unicode? ( virtual/libiconv )"
+RDEPEND="net-dialup/capi4k-utils"
+
+RESTRICT="mirror strip test"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ rpm_src_unpack ${A}
+ cd "${S}"
+
+ # convert 'latin1' to 'utf8'
+ if use unicode; then
+ for i in etc/drdsl/drdsl.ini; do
+ echo ">>> Converting '${i##*/}' to UTF-8"
+ iconv -f LATIN1 -t UTF8 -o "${i}~" "${i}" && mv -f "${i}~" "${i}" || rm -f "${i}~"
+ done
+ fi
+}
+
+src_install() {
+ into /
+ dosbin sbin/drdsl
+ insinto /etc/drdsl
+ doins etc/drdsl/drdsl.ini
+ dodoc "${FILESDIR}"/README
+}
diff --git a/net-dialup/drdsl/files/README b/net-dialup/drdsl/files/README
new file mode 100644
index 000000000000..6ef005040ef8
--- /dev/null
+++ b/net-dialup/drdsl/files/README
@@ -0,0 +1,87 @@
+
+------------------------------------------------------------------------------
+
+WHAT IS DRDSL
+For a DSL internet connection to work, the DSL values (VPI, VCI, VPP) of
+the DSLAM are required. The DSLAM is the counterpart of the DSL modem on
+the access provider end. The values thus are generally
+provided by your Internet Service Provider (ISP).
+
+It is possible to enter the requested values from the ISP manually, but
+it is much more convenient to detect them automatically with drdsl. drdsl tests
+different values taken from the file drdsl.ini. Once the working
+values and the corresponding controller number are found, they are written
+to the adsl.conf, located in the file /etc/drdsl/adsl.conf.
+
+Each time the pppd capi plugin is started with the "avmadsl" parameter,
+the adsl.conf supplies the driver with all of the values detected and a
+successfull dsl connection can be established.
+
+
+REQUIREMENTS
+drdsl requires an AVM DSL controller with a CAPI driver running, plus the
+drdsl.ini file located at /etc/drdsl. The drdsl.ini is also
+included in every DSL-Controller driver package.
+
+
+COMMAND LINE OPTIONS
+-c path of the drdsl.ini file
+-q quiet mode
+-r remove the files generated by drdsl
+-h short help
+
+
+UPDATES AND PACKAGES
+Updates and packages are available at ftp.in-berlin.de/pub/capi4linux/drdsl
+drdsl is included in every linux driver package for DSL-Controllers at
+ftp.avm.de/cardware
+
+FURTHER INFORMATION
+For more details on CAPI4Linux, visit AVM at www.avm.de/linux
+
+
+Copyright (C) 2005, AVM GmbH. All rights reserved.
+
+------------------------------------------------------------------------------
+
+COPYRIGHT NOTICE
+This Software is object of a license agreement. You may only use the Software
+in accordance with the license conditions mentioned therein. As licensee you
+bear all risk in regard to hazards and impairments of quality which may arise
+in connection with the use of this Software.
+
+You may not transmit, reproduce or alter this Software in whole or in part,
+in any form, by any means, nor may you translate the Software into any other
+natural or computer language. The creation of a backup copy for personal use
+is excepted. The information hereby made available to you may be communicated
+to third parties only with the written permission of AVM GmbH.
+
+This Software has been produced with due care and checked for correctness in
+accordance with available technology. The information in this Software is
+subject to change without notice for the purpose of technical improvement.
+
+THERE IS NO WARRANTY FOR THE SOFTWARE, TO THE EXTENT PERMITTED BY APPLICABLE
+LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR
+OTHER PARTIES PROVIDE THE SOFTWARE "AS IS" WITHOUT WARRANTY OF ANY KIND,
+EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE
+ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE SOFTWARE IS WITH YOU.
+SHOULD THE SOFTWARE PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY
+SERVICING, REPAIR OR CORRECTION.
+
+IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL
+ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE
+THE SOFTWARE AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY
+GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE
+OR INABILITY TO USE THE SOFTWARE (INCLUDING BUT NOT LIMITED TO LOSS OF DATA
+OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES
+OR A FAILURE OF THE SOFTWARE TO OPERATE WITH ANY OTHER SOFTWARE), EVEN IF SUCH
+HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
+
+
+CONTACT
+AVM GmbH
+Alt-Moabit 95
+10559 Berlin
+Germany
+Email: info@avm.de
diff --git a/net-dialup/drdsl/metadata.xml b/net-dialup/drdsl/metadata.xml
new file mode 100644
index 000000000000..1e11e7bbd01b
--- /dev/null
+++ b/net-dialup/drdsl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-dialup</herd>
+</pkgmetadata>