summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-03-17 19:49:03 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-03-18 21:00:02 +0100
commit3e4fe8d2cfff021bc8ab557985bf67ff61866965 (patch)
treed640eb2d3befce6af69e44048c1770de33b86115 /net-dialup
parentnet-news/liferea: drop 1.14.5-r1 (diff)
downloadgentoo-3e4fe8d2cfff021bc8ab557985bf67ff61866965.tar.gz
gentoo-3e4fe8d2cfff021bc8ab557985bf67ff61866965.tar.bz2
gentoo-3e4fe8d2cfff021bc8ab557985bf67ff61866965.zip
net-dialup/wvdial: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/35804 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/wvdial/wvdial-1.61-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-dialup/wvdial/wvdial-1.61-r1.ebuild b/net-dialup/wvdial/wvdial-1.61-r1.ebuild
new file mode 100644
index 000000000000..1184b267e853
--- /dev/null
+++ b/net-dialup/wvdial/wvdial-1.61-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="Excellent program to automatically configure PPP sessions"
+HOMEPAGE="https://code.google.com/archive/p/wvstreams/"
+SRC_URI="https://wvstreams.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+
+DEPEND=">=net-libs/wvstreams-4.4"
+RDEPEND="${DEPEND}
+ net-dialup/ppp:=
+"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-destdir.patch"
+ "${FILESDIR}/${P}-as-needed.patch"
+ "${FILESDIR}/${P}-parallel-make.patch"
+)
+
+DOC_CONTENTS="
+ Use wvdialconf to automagically generate a configuration file.
+ Users have to be member of the dialout AND the uucp group to use
+ wvdial
+"
+
+src_configure() {
+ # Hand made configure...
+ ./configure || die
+}
+
+src_install() {
+ default
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}