summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbgo <bgo@9dt.de>2017-09-02 18:44:59 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-10-28 11:52:07 +0200
commit1c50a5d191b47143338b15a86ce6e36fd1b7abca (patch)
tree11b1c99c5d71bb51a1fa8ebbaa4bffa7ac794a98 /net-dns/dnsdist
parentnet-dns/dnsdist: remove vulnerable version. (diff)
downloadgentoo-1c50a5d191b47143338b15a86ce6e36fd1b7abca.tar.gz
gentoo-1c50a5d191b47143338b15a86ce6e36fd1b7abca.tar.bz2
gentoo-1c50a5d191b47143338b15a86ce6e36fd1b7abca.zip
net-dns/dnsdist: version bump to 1.2.0.
Bug: https://bugs.gentoo.org/628534 Bug: https://bugs.gentoo.org/628578 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'net-dns/dnsdist')
-rw-r--r--net-dns/dnsdist/Manifest2
-rw-r--r--net-dns/dnsdist/dnsdist-1.2.0.ebuild86
2 files changed, 87 insertions, 1 deletions
diff --git a/net-dns/dnsdist/Manifest b/net-dns/dnsdist/Manifest
index 83b82a38f363..e064a7a1c5f2 100644
--- a/net-dns/dnsdist/Manifest
+++ b/net-dns/dnsdist/Manifest
@@ -1 +1 @@
-DIST dnsdist-1.1.0.tar.bz2 874837 SHA256 b4a1e8931b6d05a24494f54224211c0de0eeb1f5ff170f6b9f5665219bfeafc2 SHA512 91da716997c2440e153944f510a39dd86c9cf8ba8093a7f51a9a5d58ab0a1c230bd99ec57fe8ff0721279c8c4429ad576fe797c1fbe4cde2b9fb8f0405025320 WHIRLPOOL 6d88f4159b8155c9600af94e6e8401c426f183102a18b3f35fc066b8a19d781f5800a2aa64d306ab4ee0daadbaaab1d29b2df05c10058a9b99b9d9cf1abf071e
+DIST dnsdist-1.2.0.tar.bz2 876104 SHA256 9885c9ee8ac7076aede586ea58d4642eb877e7b2d76c902254494e2a5a5faa78 SHA512 93f8c5f18462d3291c973a690f6ac2b3c5791d9947bee83d9250b503b7526de365bdcb530f3b082e51ae168a9129e77d5558af7cc3b9d2e98a585af53783c237 WHIRLPOOL bec3f7a5174dc7dec71724bb274b3cd02261b666c853bee3a8cce7695fb082cdd09bf28545b7c54355c5d3e15bea33c49ff2f7c0821324e46435efc2ecaba615
diff --git a/net-dns/dnsdist/dnsdist-1.2.0.ebuild b/net-dns/dnsdist/dnsdist-1.2.0.ebuild
new file mode 100644
index 000000000000..75b3d1113da0
--- /dev/null
+++ b/net-dns/dnsdist/dnsdist-1.2.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/PowerDNS/pdns.git"
+
+if [[ ${PV} = 9999 ]]; then
+ ADDITIONAL_ECLASSES="autotools git-r3"
+fi
+
+inherit eutils flag-o-matic user ${ADDITIONAL_ECLASSES}
+
+DESCRIPTION="A highly DNS-, DoS- and abuse-aware loadbalancer"
+HOMEPAGE="http://dnsdist.org"
+
+if [[ ${PV} == 9999 ]]; then
+ SRC_URI=""
+ S="${WORKDIR}/${P}/pdns/dnsdistdist"
+else
+ SRC_URI="https://downloads.powerdns.com/releases/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="dnscrypt luajit regex remote-logging snmp +ssl test"
+REQUIRED_USE="dnscrypt? ( ssl )"
+
+DEPEND="
+ >=dev-libs/boost-1.35:=
+ dev-libs/libedit:=
+ luajit? ( dev-lang/luajit:= )
+ !luajit? ( >=dev-lang/lua-5.1:= )
+ remote-logging? ( dev-libs/protobuf:= )
+ regex? ( dev-libs/re2:= )
+ snmp? ( net-analyzer/net-snmp:= )
+ ssl? ( dev-libs/libsodium:= )
+"
+
+RDEPEND="${DEPEND}"
+
+[[ ${PV} == 9999 ]] && DEPEND+="
+ app-text/pandoc
+ dev-util/ragel
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/dnsdist \
+ $(use_enable ssl libsodium) \
+ $(use_with remote-logging protobuf) \
+ $(use_enable regex re2) \
+ $(use_enable dnscrypt) \
+ $(use_with luajit) \
+ $(use_enable test unit-tests) \
+ $(use_with snmp net-snmp)
+}
+
+src_install() {
+ default
+
+ insinto /etc/dnsdist
+ doins "${FILESDIR}"/dnsdist.conf.example
+
+ newconfd "${FILESDIR}"/dnsdist.confd ${PN}
+ newinitd "${FILESDIR}"/dnsdist.initd ${PN}
+}
+
+pkg_preinst() {
+ enewgroup dnsdist
+ enewuser dnsdist -1 -1 -1 dnsdist
+}
+
+pkg_postinst() {
+ elog "dnsdist provides multiple instances support. You can create more instances"
+ elog "by symlinking the dnsdist init script to another name."
+ elog
+ elog "The name must be in the format dnsdist.<suffix> and dnsdist will use the"
+ elog "/etc/dnsdist/dnsdist-<suffix>.conf configuration file instead of the default."
+}