summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2017-09-07 17:25:38 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-09-15 00:14:40 +0200
commit5ba638ac882134fcdc1b5fed1df0e2e2bdebf04d (patch)
tree6540fbeb2411b5f7ddb21020c2db02ea46899982 /net-firewall/ferm/ferm-2.4.1.ebuild
parentapp-misc/neofetch: version bump to 3.3.0. (diff)
downloadgentoo-5ba638ac882134fcdc1b5fed1df0e2e2bdebf04d.tar.gz
gentoo-5ba638ac882134fcdc1b5fed1df0e2e2bdebf04d.tar.bz2
gentoo-5ba638ac882134fcdc1b5fed1df0e2e2bdebf04d.zip
net-firewall/ferm: version bump to 2.4.1.
Package-Manager: Portage-2.3.8, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/5653
Diffstat (limited to 'net-firewall/ferm/ferm-2.4.1.ebuild')
-rw-r--r--net-firewall/ferm/ferm-2.4.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-firewall/ferm/ferm-2.4.1.ebuild b/net-firewall/ferm/ferm-2.4.1.ebuild
new file mode 100644
index 000000000000..339938cb9200
--- /dev/null
+++ b/net-firewall/ferm/ferm-2.4.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd versionator
+
+MY_PV=$(get_version_component_range 1-2)
+
+DESCRIPTION="Command line util for managing firewall rules"
+HOMEPAGE="http://ferm.foo-projects.org/"
+SRC_URI="http://ferm.foo-projects.org/download/${MY_PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+# does not install any perl libs
+RDEPEND="dev-lang/perl:*
+ net-firewall/iptables
+ virtual/perl-File-Spec"
+
+DOCS=( AUTHORS NEWS README.rst TODO doc/ferm.txt examples/ )
+HTML_DOCS=( doc/ferm.html )
+
+src_install() {
+ dosbin src/{,import-}ferm
+ systemd_dounit ferm.service
+
+ einstalldocs
+ doman doc/*.1
+}
+
+pkg_postinst() {
+ elog "See ${EROOT}usr/share/doc/${PF}/examples for sample configs"
+}