summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-29 04:28:33 +0000
committerSam James <sam@gentoo.org>2024-02-29 04:28:33 +0000
commit35598dd1ddcf605613c727dd38e017f4a67e40dd (patch)
treec0d177bc68b23e7bb007b9045413542278540229 /net-fs/libnfs
parentsys-block/thin-provisioning-tools: drop 0.9.0-r3 (diff)
downloadgentoo-35598dd1ddcf605613c727dd38e017f4a67e40dd.tar.gz
gentoo-35598dd1ddcf605613c727dd38e017f4a67e40dd.tar.bz2
gentoo-35598dd1ddcf605613c727dd38e017f4a67e40dd.zip
net-fs/libnfs: add 5.0.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-fs/libnfs')
-rw-r--r--net-fs/libnfs/Manifest1
-rw-r--r--net-fs/libnfs/libnfs-5.0.3.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/net-fs/libnfs/Manifest b/net-fs/libnfs/Manifest
index a49346135177..d846fae3408c 100644
--- a/net-fs/libnfs/Manifest
+++ b/net-fs/libnfs/Manifest
@@ -1 +1,2 @@
DIST libnfs-5.0.2.tar.gz 281154 BLAKE2B 9de3d02e5ae4d41eacda152678e6552708b33d4e88cc6fc5f7b16c887f911fc5a5e834952505438220c961f71a8b70540be3254d5889a4336200d5633dce313e SHA512 6dcf4ea8a01b35beb53694625d20fbebd858a88725c2742671878ad6fe7877999f93d262fb58a435b00c283c3e6fb6fa7222d04bb4540bf674b7ce196e9424f5
+DIST libnfs-5.0.3.tar.gz 291079 BLAKE2B 4ce19c317bfd47110d9f42bb2dfb27bfba90bb9a11d1c3c5d63ce1188db3a08a97ffa82a31b0de04e59f41c570eef1eff96e80390ee78b0267e2a89d032c9c9c SHA512 1581c4a599e7b2a837553df2a4e1e4255a726907cd54ce3e82b0b725c79e2fd15d7ed921dbe9519d73204f5ca735d27b347888d3f1162c4c2144e9d72e327ff1
diff --git a/net-fs/libnfs/libnfs-5.0.3.ebuild b/net-fs/libnfs/libnfs-5.0.3.ebuild
new file mode 100644
index 000000000000..4d724238c890
--- /dev/null
+++ b/net-fs/libnfs/libnfs-5.0.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/sahlberg/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/sahlberg/${PN}/archive/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~x86"
+ S="${WORKDIR}"/${PN}-${P}
+fi
+
+DESCRIPTION="Client library for accessing NFS shares over a network"
+HOMEPAGE="https://github.com/sahlberg/libnfs"
+
+LICENSE="LGPL-2.1 GPL-3"
+SLOT="0/14" # sub-slot matches SONAME major
+IUSE="examples static-libs utils"
+
+# net-libs/rpcsvc-proto for rpcgen called in build system
+BDEPEND="
+ net-libs/rpcsvc-proto
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-werror
+ $(use_enable static-libs static)
+ $(use_enable utils)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ # --enable-examples configure switch just compiles them
+ # better install sources instead
+ exeinto /usr/share/doc/${PF}/examples/
+ for program in $(grep PROGRAMS examples/Makefile.am | cut -d= -f2); do
+ doexe examples/${program}.c
+ done
+ fi
+
+ find "${ED}" -name "*.la" -delete || die
+}