summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-07-26 23:18:08 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-08-02 21:14:42 +0300
commitf7e529155909025558089340c0f828c4c22977b6 (patch)
treefa34b3fb9d6126ff803e2739cba86e0b9869b8d5 /net-im/yowsup
parentdev-python/transitions: New package (diff)
downloadgentoo-f7e529155909025558089340c0f828c4c22977b6.tar.gz
gentoo-f7e529155909025558089340c0f828c4c22977b6.tar.bz2
gentoo-f7e529155909025558089340c0f828c4c22977b6.zip
net-im/yowsup: bump to version 3.2.3
This is a new major release of net-im/yowsup, which needs new dependencies: dev-python/consonance dev-python/dissononce dev-python/transitions Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Closes: https://github.com/gentoo/gentoo/pull/12550 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-im/yowsup')
-rw-r--r--net-im/yowsup/Manifest1
-rw-r--r--net-im/yowsup/files/yowsup-3.2.3-fix-install-path.patch21
-rw-r--r--net-im/yowsup/yowsup-3.2.3.ebuild40
3 files changed, 62 insertions, 0 deletions
diff --git a/net-im/yowsup/Manifest b/net-im/yowsup/Manifest
index e767fd6b5198..e46ebc8f7b32 100644
--- a/net-im/yowsup/Manifest
+++ b/net-im/yowsup/Manifest
@@ -1 +1,2 @@
DIST yowsup-2.5.7.tar.gz 125732 BLAKE2B 31896cfef601bfe4b65df3518ce6812ad66a98902ec7c8ca5b2ffda15c48c9390010fce58e1158f6ddc325911fd78d1be2bc708d499ab11b725835c5cd5ea246 SHA512 e64e119e8301d6cd9244a24ce960fdd00a5372a7766cf2f52dfd7610828358086e6c4f77fba6f962c1b84f6b28fa6b6d4d708bbb50c281e5a6563b99634b9495
+DIST yowsup-3.2.3.tar.gz 140038 BLAKE2B 45df9151e897eea4f2997246d8c66409bc58160e01a84ee632f3e834058efcaed1d03047ddc6e8e7acbaa566d5fab2451fb21b30daf477bc83dfdd0bee7e6b59 SHA512 a1be36df5dc632071385cf0e252a208efb8982df98966d2c5a7b7558c626112e1ac2688be25fb6de1db9e9e04d36ab96784e589aeb90fcc6c6770edac791e568
diff --git a/net-im/yowsup/files/yowsup-3.2.3-fix-install-path.patch b/net-im/yowsup/files/yowsup-3.2.3-fix-install-path.patch
new file mode 100644
index 000000000000..eba10fbced59
--- /dev/null
+++ b/net-im/yowsup/files/yowsup-3.2.3-fix-install-path.patch
@@ -0,0 +1,21 @@
+--- a/setup.py 2019-05-07 18:52:38.000000000 +0200
++++ b/setup.py 2019-07-26 23:05:18.000000000 +0200
+@@ -33,7 +33,6 @@
+ #long_description=long_description,
+ packages= find_packages(),
+ include_package_data=True,
+- data_files = [('yowsup/common', ['yowsup/common/mime.types'])],
+ platforms='any',
+ #test_suite='',
+ classifiers = [
+--- a/yowsup/common/tools.py 2019-05-07 18:52:38.000000000 +0200
++++ b/yowsup/common/tools.py 2019-07-26 23:05:38.000000000 +0200
+@@ -173,7 +173,7 @@
+ return preview
+
+ class MimeTools:
+- MIME_FILE = os.path.join(os.path.dirname(__file__), 'mime.types')
++ MIME_FILE = os.path.join('/usr/share/yowsup/common', 'mime.types')
+ mimetypes.init() # Load default mime.types
+ try:
+ mimetypes.init([MIME_FILE]) # Append whatsapp mime.types
diff --git a/net-im/yowsup/yowsup-3.2.3.ebuild b/net-im/yowsup/yowsup-3.2.3.ebuild
new file mode 100644
index 000000000000..69b80264ed28
--- /dev/null
+++ b/net-im/yowsup/yowsup-3.2.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_REQ_USE="readline"
+
+inherit distutils-r1
+
+DESCRIPTION="A library that enables you to build applications which use the WhatsApp service"
+HOMEPAGE="https://github.com/tgalal/yowsup"
+SRC_URI="https://github.com/tgalal/yowsup/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/configargparse[${PYTHON_USEDEP}]
+ dev-python/consonance[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/python-axolotl[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/${P}-fix-install-path.patch" )
+
+pkg_postinst() {
+ einfo "Warning: It seems that recently yowsup gets detected during registration"
+ einfo "resulting in an instant ban for your number right after registering"
+ einfo "with the code you receive by sms/voice."
+ einfo "See https://github.com/tgalal/yowsup/issues/2829 for more information."
+}