summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony Ryan <anthonyryan1@gmail.com>2016-10-06 16:59:11 -0400
committerLars Wendler <polynomial-c@gentoo.org>2016-10-14 10:00:12 +0200
commit6f7cab7b12ddc568b0aa0a9239905517e61478cb (patch)
tree2cd9fcee0a3c489ed28551d5d836d902253931da /net-irc/hexchat/hexchat-9999.ebuild
parentnet-dns/c-ares: version bump to 1.12.0 (diff)
downloadgentoo-6f7cab7b12ddc568b0aa0a9239905517e61478cb.tar.gz
gentoo-6f7cab7b12ddc568b0aa0a9239905517e61478cb.tar.bz2
gentoo-6f7cab7b12ddc568b0aa0a9239905517e61478cb.zip
net-irc/hexchat: version bump 2.12.2
Gentoo-bug: 582952, 528052, 592568 * EAPI 6 * Removed USE=ipv6 (required by upstream) * Added USE=debug * Removed USE=ntlm (removed by upstream) * Removed USE=plugins (required for simplicity) * Removed eutils & multilib Closes: https://github.com/gentoo/gentoo/pull/2498 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-irc/hexchat/hexchat-9999.ebuild')
-rw-r--r--net-irc/hexchat/hexchat-9999.ebuild142
1 files changed, 47 insertions, 95 deletions
diff --git a/net-irc/hexchat/hexchat-9999.ebuild b/net-irc/hexchat/hexchat-9999.ebuild
index 3e1070314a25..530b1572184d 100644
--- a/net-irc/hexchat/hexchat-9999.ebuild
+++ b/net-irc/hexchat/hexchat-9999.ebuild
@@ -1,132 +1,89 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
-inherit autotools eutils fdo-mime gnome2-utils mono-env multilib python-single-r1 git-2
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit autotools fdo-mime gnome2-utils mono-env python-single-r1
DESCRIPTION="Graphical IRC client based on XChat"
-HOMEPAGE="http://hexchat.github.io/"
-SRC_URI=""
-EGIT_REPO_URI="git://github.com/hexchat/hexchat.git"
+HOMEPAGE="https://hexchat.github.io/"
+
+if [[ "${PV}" == "9999" ]] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="git://github.com/hexchat/hexchat.git"
+else
+ SRC_URI="https://dl.hexchat.net/hexchat/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+fi
LICENSE="GPL-2 plugin-fishlim? ( MIT )"
SLOT="0"
-KEYWORDS=""
-IUSE="dbus +gtk ipv6 libcanberra libnotify libproxy libressl nls ntlm perl +plugins plugin-checksum plugin-doat plugin-fishlim plugin-sysinfo python spell ssl theme-manager"
-REQUIRED_USE="plugins? ( python? ( ${PYTHON_REQUIRED_USE} ) )"
+IUSE="dbus debug +gtk libcanberra libnotify libproxy libressl lua nls perl plugin-checksum plugin-doat plugin-fishlim plugin-sysinfo python spell ssl theme-manager"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-DEPEND="dev-libs/glib:2
- dbus? ( >=dev-libs/dbus-glib-0.98 )
+COMMON_DEPEND="dev-libs/glib:2
+ dbus? ( sys-apps/dbus )
gtk? ( x11-libs/gtk+:2 )
libcanberra? ( media-libs/libcanberra )
libproxy? ( net-libs/libproxy )
libnotify? ( x11-libs/libnotify )
+ lua? ( dev-lang/lua:= )
nls? ( virtual/libintl )
- ntlm? ( net-libs/libntlm )
- plugins? (
- perl? ( >=dev-lang/perl-5.8.0 )
- plugin-sysinfo? ( sys-apps/pciutils )
- python? ( ${PYTHON_DEPS} )
- )
+ perl? ( dev-lang/perl )
+ plugin-sysinfo? ( sys-apps/pciutils )
+ python? ( ${PYTHON_DEPS} )
spell? ( app-text/iso-codes )
ssl? (
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
)
theme-manager? ( dev-lang/mono )"
-RDEPEND="${DEPEND}
+RDEPEND="${COMMON_DEPEND}
spell? ( app-text/enchant )"
-DEPEND="${DEPEND}
+DEPEND="${COMMON_DEPEND}
app-arch/xz-utils
virtual/pkgconfig
- nls? ( dev-util/intltool )
+ dev-util/intltool
theme-manager? ( dev-util/monodevelop )"
+src_prepare() {
+ if [[ ${PV} == "9999" ]]; then
+ eautoreconf
+ fi
+ default
+}
+
pkg_setup() {
- use plugins && use python && python-single-r1_pkg_setup
+ use python && python-single-r1_pkg_setup
if use theme-manager ; then
mono-env_pkg_setup
export XDG_CACHE_HOME="${T}/.cache"
fi
-
- if use !plugins ; then
- local myplugins
-
- use perl && myplugins+="perl\n"
- use python && myplugins+="python\n"
- use plugin-checksum && myplugins+="plugin-checksum\n"
- use plugin-doat && myplugins+="plugin-doat\n"
- use plugin-fishlim && myplugins+="plugin-fishlim\n"
- use plugin-sysinfo && myplugins+="plugin-sysinfo\n"
-
- if [[ ${myplugins} ]] ; then
- ewarn "The following plugins/interfaces have been disabled, because"
- ewarn "\"plugins\" USE flag is disabled. Check metadata.xml"
- ewarn "to get more information or run \"equery u hexchat\"."
- ewarn "\n${myplugins}"
- fi
- fi
-}
-
-src_prepare() {
- sed -i \
- -e "/intl\/Makefile/d" \
- -e "/po\/Makefile.in/d" \
- configure.ac || die
- sed -i -e "/SUBDIRS/s/intl//" Makefile.am || die
- epatch -p1 \
- "${FILESDIR}"/${PN}-2.9.5-autoconf-missing-macros.patch
- epatch_user
- cp $(type -p gettextize) "${T}"/ || die
- sed -i -e 's:read dummy < /dev/tty::' "${T}/gettextize" || die
- einfo "Running gettextize -f --no-changelog..."
- "${T}"/gettextize -f --no-changelog > /dev/null || die "gettexize failed"
- AT_M4DIR="m4" eautoreconf
}
src_configure() {
econf \
+ --enable-plugin \
$(use_enable nls) \
- $(use_enable libproxy socks) \
- $(use_enable ipv6) \
$(use_enable ssl openssl) \
$(use_enable gtk gtkfe) \
$(use_enable !gtk textfe) \
- $(usex plugins \
- "$(usex python "--enable-python=${EPYTHON}" "--disable-python")" \
- "--disable-python" \
- ) \
- $(usex plugins \
- "$(use_enable perl)" \
- "--disable-perl" \
- ) \
- $(use_enable plugins plugin) \
- $(usex plugins \
- "$(use_enable plugin-checksum checksum)" \
- "--disable-checksum" \
- ) \
- $(usex plugins \
- "$(use_enable plugin-doat doat)" \
- "--disable-doat" \
- ) \
- $(usex plugins \
- "$(use_enable plugin-fishlim fishlim)" \
- "--disable-fishlim" \
- ) \
- $(usex plugins \
- "$(use_enable plugin-sysinfo sysinfo)" \
- "--disable-sysinfo" \
- ) \
+ $(use_enable python python "${EPYTHON}") \
+ $(use_enable perl) \
+ $(use_enable plugin-checksum checksum) \
+ $(use_enable plugin-doat doat) \
+ $(use_enable plugin-fishlim fishlim) \
+ $(use_enable plugin-sysinfo sysinfo) \
$(use_enable dbus) \
+ $(use_enable lua) \
$(use_enable libnotify) \
$(use_enable libcanberra) \
- $(use_enable ntlm) \
$(use_enable libproxy) \
$(use_enable spell isocodes) \
- --enable-minimal-flags \
+ $(use_enable debug) \
$(use_with theme-manager)
}
@@ -137,7 +94,7 @@ src_install() {
UPDATE_DESKTOP_DATABASE=true \
install
dodoc readme.md
- prune_libtool_files --all
+ find "${D}" -name '*.la' -delete || die
}
pkg_preinst() {
@@ -149,30 +106,25 @@ pkg_preinst() {
pkg_postinst() {
if use gtk ; then
gnome2_icon_cache_update
- einfo
else
- einfo
elog "You have disabled the gtk USE flag. This means you don't have"
elog "the GTK-GUI for HexChat but only a text interface called \"hexchat-text\"."
- elog
fi
if use theme-manager ; then
fdo-mime_desktop_database_update
fdo-mime_mime_database_update
elog "Themes are available at:"
- elog " http://hexchat.org/themes.html"
- elog
+ elog " https://hexchat.github.io/themes.html"
fi
- einfo
+ elog
elog "optional dependencies:"
elog " media-sound/sox (sound playback if you don't have libcanberra"
elog " enabled)"
elog " x11-plugins/hexchat-javascript (javascript support)"
elog " x11-themes/sound-theme-freedesktop (default BEEP sound,"
elog " needs libcanberra enabled)"
- einfo
}
pkg_postrm() {