summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWade Cline <wadecline@hotmail.com>2024-07-07 12:49:56 -0700
committerViorel Munteanu <ceamac@gentoo.org>2024-07-08 08:42:35 +0300
commitd76d01fe2451b75b64f7fefe45e7925e7ccdb139 (patch)
treef703f7a03409a136f8084b2705fa1fc03df2d6f0 /net-irc/inspircd
parentdev-ruby/combustion: drop 1.3.7-r2 (diff)
downloadgentoo-d76d01fe2451b75b64f7fefe45e7925e7ccdb139.tar.gz
gentoo-d76d01fe2451b75b64f7fefe45e7925e7ccdb139.tar.bz2
gentoo-d76d01fe2451b75b64f7fefe45e7925e7ccdb139.zip
net-irc/inspircd: add 3.17.1
Signed-off-by: Wade Cline <wadecline@hotmail.com> Closes: https://github.com/gentoo/gentoo/pull/37385 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'net-irc/inspircd')
-rw-r--r--net-irc/inspircd/Manifest2
-rw-r--r--net-irc/inspircd/inspircd-3.17.1.ebuild112
2 files changed, 114 insertions, 0 deletions
diff --git a/net-irc/inspircd/Manifest b/net-irc/inspircd/Manifest
index 4f047c848ab2..4d33fb785e54 100644
--- a/net-irc/inspircd/Manifest
+++ b/net-irc/inspircd/Manifest
@@ -1,2 +1,4 @@
DIST inspircd-3.16.1-fix-build-paths.patch.bz2 4751 BLAKE2B 78ae06bfbdd6d389af2890aadebc5765f16d1616bb9c1b8820a21b2f2a283f4f4aea5bc4f7edc5d61acc80da67ca80a2d0b007a669cf7a37f1ea77b11f552643 SHA512 1fec0c784a1d306a62c9a5320236bfb53bffd4278bbcc8439ea640500b8668cec4e6c23174d1d88f8109bc88549c931ff889b4c07a8f0f5446bb85a434665702
DIST inspircd-3.16.1.tar.gz 877817 BLAKE2B a54992c32a13a512bce93157b23a17d433fbdbf7efcaa54a66be17628335db379d0abbb14e22a455e069fd8fb2a1f3e0152a112acbe634e6de87208b4a1b8cd5 SHA512 2b488858b0012bcb3eb92a33960e9927c861587c7b7451a47fd3e10a97fad9c392524d98712593fd455c5cbae7fd1779e4b90b9e55680c2f36b483e0acf2bba5
+DIST inspircd-3.17.1-fix-build-paths.patch.bz2 4689 BLAKE2B ca479cde2278e3605d31177d658f33ad56f847a5ccae7898e0e739e803323aa6b3137fa8e27bc5191fea4087d0d8c08a6818290e663eacd6f9c7a38fe53d9699 SHA512 103f97f4ce810ebc4b8fce54b4379dcee3aec68e75f5e1569825770b09a961a9d73e0da3a5eb97fa4153a5a2ab69478c60ed531bd84f36a59517de05cf10aeb9
+DIST inspircd-3.17.1.tar.gz 881389 BLAKE2B 30e6dc24e8e517a71b3a582c3e2c92ef1e52f8a52e1b4acace79537bbf6ae04f904be0f55a96bc65acdbb386d5fbf80c5fcec88cbbb5f74f4f5f15bdb0ca701c SHA512 ae8699506d32e7c09c1b982baeea36eca520d6be65732976e77695f1ca1768aa070f0ae3b9abf9fd390201021a679ef5478114b66f40e996de6873f3fb83836b
diff --git a/net-irc/inspircd/inspircd-3.17.1.ebuild b/net-irc/inspircd/inspircd-3.17.1.ebuild
new file mode 100644
index 000000000000..d00bd38f826e
--- /dev/null
+++ b/net-irc/inspircd/inspircd-3.17.1.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1 systemd toolchain-funcs
+
+DESCRIPTION="Inspire IRCd - The Stable, High-Performance Modular IRCd"
+HOMEPAGE="https://www.inspircd.org/"
+SRC_URI="
+ https://github.com/inspircd/inspircd/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/clinew/gentoo-distfiles/raw/master/inspircd-${PV}-fix-build-paths.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="argon2 debug gnutls ldap maxminddb mbedtls mysql pcre pcre2 postgres re2 regex-posix regex-stdlib sqlite ssl sslrehashsignal tre"
+
+RDEPEND="
+ acct-group/inspircd
+ acct-user/inspircd
+ dev-lang/perl
+ argon2? ( app-crypt/argon2 )
+ gnutls? ( net-libs/gnutls:= dev-libs/libgcrypt:0 )
+ ldap? ( net-nds/openldap:= )
+ maxminddb? ( dev-libs/libmaxminddb:= )
+ mbedtls? ( net-libs/mbedtls:= )
+ mysql? ( dev-db/mysql-connector-c:= )
+ pcre? ( dev-libs/libpcre )
+ pcre2? ( dev-libs/libpcre2 )
+ postgres? ( dev-db/postgresql:= )
+ re2? ( dev-libs/re2:= )
+ sqlite? ( >=dev-db/sqlite-3.0 )
+ ssl? ( dev-libs/openssl:= )
+ tre? ( dev-libs/tre )"
+DEPEND="${RDEPEND}"
+
+DOC_CONTENTS="
+ You will find example configuration files under /usr/share/doc/${PN}.\n
+ Read the ${PN}.conf file carefully before starting the service."
+DOCS=( docs/. .configure/apparmor )
+PATCHES=( "${WORKDIR}"/${P}-fix-build-paths.patch )
+
+src_configure() {
+ local extras=""
+
+ use argon2 && extras+="argon2,"
+ use gnutls && extras+="ssl_gnutls,"
+ use ldap && extras+="ldap,"
+ use maxminddb && extras+="geo_maxmind,"
+ use mbedtls && extras+="ssl_mbedtls,"
+ use mysql && extras+="mysql,"
+ use pcre && extras+="regex_pcre,"
+ use pcre2 && extras+="regex_pcre2,"
+ use postgres && extras+="pgsql,"
+ use re2 && extras+="regex_re2,"
+ use regex-posix && extras+="regex_posix,"
+ use regex-stdlib && extras+="regex_stdlib,"
+ use sqlite && extras+="sqlite3,"
+ use ssl && extras+="ssl_openssl,"
+ use sslrehashsignal && extras+="sslrehashsignal,"
+ use tre && extras+="regex_tre,"
+
+ # The first configuration run enables certain "extra" InspIRCd
+ # modules, the second run generates the actual makefile.
+ if [[ -n ${extras} ]]; then
+ ./configure --enable-extras=${extras%,} || die
+ fi
+
+ local myconf=(
+ --disable-auto-extras
+ --disable-ownership
+ --system
+ --uid ${PN}
+ --gid ${PN}
+ --binary-dir="/usr/bin"
+ --data-dir="/var/lib/${PN}/data"
+ --example-dir="/usr/share/doc/${PV}"
+ --manual-dir="/usr/share/man"
+ --module-dir="/usr/$(get_libdir)/${PN}/modules")
+ CXX="$(tc-getCXX)" ./configure "${myconf[@]}" || die
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" CXXFLAGS="${CXXFLAGS}" $(usev debug INSPIRCD_DEBUG=2) INSPIRCD_VERBOSE=1
+}
+
+src_install() {
+ default
+
+ insinto "/usr/include/${PN}"
+ doins -r include/.
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ systemd_dounit .configure/inspircd.service
+
+ keepdir "/var/log/${PN}"
+ insinto "/etc/logrotate.d"
+ newins .configure/logrotate "${PN}"
+
+ diropts -o"${PN}" -g"${PN}" -m0700
+ keepdir "/var/lib/${PN}/data"
+
+ readme.gentoo_create_doc
+
+ rmdir "${ED}"/run{/inspircd,} || die
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}