summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2022-11-21 11:30:55 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-11-21 15:18:15 +0100
commit9e74b3947d088a9d0fedc61bc1aa2f4d5763a5a1 (patch)
tree520efad1ba96375b9cd12f8eaef808ab09a015cb /net-libs/cppzmq/cppzmq-4.9.0.ebuild
parentdev-python/termcolor: Bump to 2.1.1 (diff)
downloadgentoo-9e74b3947d088a9d0fedc61bc1aa2f4d5763a5a1.tar.gz
gentoo-9e74b3947d088a9d0fedc61bc1aa2f4d5763a5a1.tar.bz2
gentoo-9e74b3947d088a9d0fedc61bc1aa2f4d5763a5a1.zip
net-libs/cppzmq: add 4.9.0
Signed-off-by: David Roman <davidroman96@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/28363 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'net-libs/cppzmq/cppzmq-4.9.0.ebuild')
-rw-r--r--net-libs/cppzmq/cppzmq-4.9.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-libs/cppzmq/cppzmq-4.9.0.ebuild b/net-libs/cppzmq/cppzmq-4.9.0.ebuild
new file mode 100644
index 000000000000..1cf6afcb3d30
--- /dev/null
+++ b/net-libs/cppzmq/cppzmq-4.9.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="High-level CPP Binding for ZeroMQ"
+HOMEPAGE="https://github.com/zeromq/cppzmq"
+SRC_URI="https://github.com/zeromq/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~x86-linux"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=net-libs/zeromq-4.3.1"
+# Tests require cmake modules from catch2 and headers from older version of catch
+DEPEND="${RDEPEND}
+ test? ( =dev-cpp/catch-2* )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-disable-static.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCPPZMQ_CMAKECONFIG_INSTALL_DIR="/usr/$(get_libdir)/cmake/${PN}/"
+ -DCPPZMQ_BUILD_TESTS="$(usex test)"
+ )
+ if has_version -d '>=net-libs/zeromq-4.3.1[drafts]'; then
+ mycmakeargs+=( -DENABLE_DRAFTS=on )
+ fi
+ cmake_src_configure
+}