summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-07-21 11:49:58 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-07-21 11:51:00 +0200
commitae16bd74a047e45b1c7e94909cb859f5d4b74fa8 (patch)
treefd4b6338429cc59a389272c8bc4198c80cd0f508 /net-libs/gloox
parentnet-misc/wireguard: version bump (diff)
downloadgentoo-ae16bd74a047e45b1c7e94909cb859f5d4b74fa8.tar.gz
gentoo-ae16bd74a047e45b1c7e94909cb859f5d4b74fa8.tar.bz2
gentoo-ae16bd74a047e45b1c7e94909cb859f5d4b74fa8.zip
net-libs/gloox: Bump to version 1.0.16
Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-libs/gloox')
-rw-r--r--net-libs/gloox/Manifest1
-rw-r--r--net-libs/gloox/gloox-1.0.16.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/net-libs/gloox/Manifest b/net-libs/gloox/Manifest
index d644a1109b63..61d8b4bff738 100644
--- a/net-libs/gloox/Manifest
+++ b/net-libs/gloox/Manifest
@@ -1,3 +1,4 @@
DIST gloox-1.0.14.tar.bz2 696719 SHA256 520b72a66fa9fea917a0336872101539f0bea30d1f871e12c31b6c2cd0203941 SHA512 0c3242bbb9713e944b9b4926ea7588434c52ae78a1fadc0b2a6da9677303550e805d1f570188a464806a9d56242efb50d268f65b3f661ed3a4df1b7055046b77 WHIRLPOOL 2ed53195b8658112167195749c3e58b451c587c7530bdf2197eb77a750344e92d0e4c13843997e3098c51512ecd45943d6849ec60a7953a55a2420b072ca622d
DIST gloox-1.0.15.tar.bz2 697835 SHA256 31e1fe7c0aedc74bf9566c4de68244825df9fbc20eabee5214536b4e3beea311 SHA512 2f640612bce27750e159f435b9f10849acec1917dc5e858ee8f128d19c259d283dec76a857cbecc34b22cc9aa23da4a4387e9f60c0bd1b7c6dab21de1bd83768 WHIRLPOOL 5aaae1b38cb3ae6b39206095b4a53f6682e10372990949646c3320dc5f7be079fa8077ed2e729179ac0e2e420de8ae8ba0836b2d976b6e914436603dcba2fda9
+DIST gloox-1.0.16.tar.bz2 697791 SHA256 fe80376adc03813bbaca01aca60b83eea6df0bc2a67394b070f3ee70e460ddef SHA512 7722e154792428284fb5522f61d297eb63ad5d78b9a3139def21fbfd811beadfc0d13aaa03235c96975b3b29a7b1c2f9e384cb8f38b3c3e320c572c927643643 WHIRLPOOL 96d68aa61c96e4782911921714bedc1455507c96ceb017e8de947d097bd0b25dc2b776d49113b0bb4334f4000b4f9ba7e6c17b99d7eddb86ce2918a22a35c8ad
DIST gloox-1.0.9.tar.bz2 670206 SHA256 143dd50e1edc4eb1d304fa28bdd6ab9e53b60c37c1726dd0e34c06c51f9a453e SHA512 a3fa7acc76fdca0421030e71b6a13ca0b04589946df2a781609f1bddae5329299d68ce99a4a94a0760206b112759636379ce67d220422b99302fc799964bfa22 WHIRLPOOL 414eb34fa3ec11ae929f84198d95ed0da9de0739655ae1188ac3eb03998de5cecb9c165ad284496b405b49126236b628dc5b4579e855b10377add145fabb63b1
diff --git a/net-libs/gloox/gloox-1.0.16.ebuild b/net-libs/gloox/gloox-1.0.16.ebuild
new file mode 100644
index 000000000000..b66bb2b81ced
--- /dev/null
+++ b/net-libs/gloox/gloox-1.0.16.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils
+
+MY_P="${P/_/-}"
+DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
+HOMEPAGE="http://camaya.net/gloox"
+SRC_URI="http://camaya.net/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0/13"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~ia64 ~sparc ~x86"
+IUSE="debug gnutls idn libressl ssl static-libs test zlib"
+
+DEPEND="idn? ( net-dns/libidn )
+ gnutls? ( net-libs/gnutls )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ )
+ zlib? ( sys-libs/zlib )"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ # Examples are not installed anyway, so - why should we build them?
+ econf \
+ --without-examples \
+ $(use debug && echo "--enable-debug") \
+ $(use_enable static-libs static) \
+ $(use_with idn libidn) \
+ $(use_with gnutls) \
+ $(use_with ssl openssl) \
+ $(use_with test tests) \
+ $(use_with zlib)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}