summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-04-28 09:45:06 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-04-28 09:45:22 +0200
commit9bffa0bfcc726db610cef7e7a88b4021a1e90792 (patch)
treeb6b7abaf45e04153e76fe79038f6ac9c67dd3fbe /net-libs/gsoap/files
parentnet-libs/gsoap: Bump to version 2.8.45 (diff)
downloadgentoo-9bffa0bfcc726db610cef7e7a88b4021a1e90792.tar.gz
gentoo-9bffa0bfcc726db610cef7e7a88b4021a1e90792.tar.bz2
gentoo-9bffa0bfcc726db610cef7e7a88b4021a1e90792.zip
net-libs/gsoap: Removed old.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'net-libs/gsoap/files')
-rw-r--r--net-libs/gsoap/files/gsoap-2.7-fix-missing-cookie-support.patch24
-rw-r--r--net-libs/gsoap/files/gsoap-2.7-fix-pre-iso-headers.patch98
2 files changed, 0 insertions, 122 deletions
diff --git a/net-libs/gsoap/files/gsoap-2.7-fix-missing-cookie-support.patch b/net-libs/gsoap/files/gsoap-2.7-fix-missing-cookie-support.patch
deleted file mode 100644
index 7f3ad8d283b9..000000000000
--- a/net-libs/gsoap/files/gsoap-2.7-fix-missing-cookie-support.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From: Gokturk Yuksek <gokturk@binghamton.edu>
-Subject: [PATCH] Backport missing cookie support
-
-For <gsoap-2.8.24, successful compilation results in missing cookie
-support due to undefined compilation flag. This is fixed in the later
-versions by upstream.
-
-Upstream-URL: https://sourceforge.net/p/gsoap2/code/85/tree//gsoap/Makefile.am?diff=51af4d3f5fcbc945b53d89a4:84
-Gentoo-Bug-URL: https://bugs.gentoo.org/show_bug.cgi?id=340647
-
---- a/gsoap/Makefile.am
-+++ b/gsoap/Makefile.am
-@@ -42,9 +42,9 @@
- libgsoapck___a_SOURCES = stdsoap2_ck_cpp.cpp
- libgsoapck___a_CXXFLAGS = $(SOAPCPP2_DEBUG) $(SOAPCPP2_NONAMESPACES) -D$(platform) -DWITH_COOKIES
- libgsoapssl_a_SOURCES = stdsoap2_ssl.c
--libgsoapssl_a_CFLAGS = $(SOAPCPP2_DEBUG) $(SOAPCPP2_NONAMESPACES) -D$(platform) -DWITH_OPENSSL -DWITH_DOM -DWITH_GZIP
-+libgsoapssl_a_CFLAGS = $(SOAPCPP2_DEBUG) $(SOAPCPP2_NONAMESPACES) -D$(platform) -DWITH_OPENSSL -DWITH_DOM -DWITH_GZIP -DWITH_COOKIES
- libgsoapssl___a_SOURCES = stdsoap2_ssl_cpp.cpp
--libgsoapssl___a_CXXFLAGS = $(SOAPCPP2_DEBUG) $(SOAPCPP2_NONAMESPACES) -D$(platform) -DWITH_OPENSSL -DWITH_DOM -DWITH_GZIP
-+libgsoapssl___a_CXXFLAGS = $(SOAPCPP2_DEBUG) $(SOAPCPP2_NONAMESPACES) -D$(platform) -DWITH_OPENSSL -DWITH_DOM -DWITH_GZIP -DWITH_COOKIES
-
- BUILT_SOURCES = stdsoap2_cpp.cpp $(lib_LIBRARIES)
-
diff --git a/net-libs/gsoap/files/gsoap-2.7-fix-pre-iso-headers.patch b/net-libs/gsoap/files/gsoap-2.7-fix-pre-iso-headers.patch
deleted file mode 100644
index 5762d5282211..000000000000
--- a/net-libs/gsoap/files/gsoap-2.7-fix-pre-iso-headers.patch
+++ /dev/null
@@ -1,98 +0,0 @@
---- gsoap/samples/factorytest/factorytest.cpp.orig 2009-03-04 01:16:22.300484305 +0100
-+++ gsoap/samples/factorytest/factorytest.cpp 2009-03-04 01:15:47.656485143 +0100
-@@ -49,7 +49,7 @@
- #include "soapH.h"
- #include "factorytest.nsmap"
-
--#include <iostream.h>
-+#include <iostream>
-
- // default factory service endpoint:
- const char *factory = "http://localhost:18085";
-@@ -167,7 +167,7 @@
- int main(int argc, char **argv)
- { if (argc > 1)
- factory = argv[1]; // use factory from command line arg by default
-- cout << "Connecting to factory " << factory << endl;
-+ std::cout << "Connecting to factory " << factory << std::endl;
- Adder adder; // create unique new remote adder object
- Counter counter1("myCounter"); // new counter object "myCounter" (created if not exists)
- Counter counter2("myCounter"); // lookup and use counter "myCounter" (this is an alias to counter1!)
-@@ -175,22 +175,22 @@
- counter1.set(adder.get());
- adder.add(3.0);
- counter1.inc();
-- cout << "Adder=" << adder.get() << endl;
-- cout << "Counter=" << counter2.get() << endl; // counter2 is an alias for counter1 so this prints the value of counter1
-- cout << "Sleep for 90 seconds to test factory server purging objects:" << endl;
-+ std::cout << "Adder=" << adder.get() << std::endl;
-+ std::cout << "Counter=" << counter2.get() << std::endl; // counter2 is an alias for counter1 so this prints the value of counter1
-+ std::cout << "Sleep for 90 seconds to test factory server purging objects:" << std::endl;
- // counter is periodically incremented which keeps it alive
- sleep(30);
- counter1.inc();
-- cout << "Counter=" << counter2.get() << endl;
-+ std::cout << "Counter=" << counter2.get() << std::endl;
- sleep(30);
- counter1.inc();
-- cout << "Counter=" << counter2.get() << endl;
-+ std::cout << "Counter=" << counter2.get() << std::endl;
- sleep(30);
- counter1.inc();
-- cout << "Counter=" << counter2.get() << endl;
-+ std::cout << "Counter=" << counter2.get() << std::endl;
- // after 90 secs, the adder should be gone
-- cout << "Adder is no longer available:" << endl;
-+ std::cout << "Adder is no longer available:" << std::endl;
- adder.add(3.0);
-- cout << "Adder status = " << adder.status << endl;
-+ std::cout << "Adder status = " << adder.status << std::endl;
- return 0;
- }
---- gsoap/samples/lu/luclient.cpp.orig 2009-03-04 01:16:48.632483467 +0100
-+++ gsoap/samples/lu/luclient.cpp 2009-03-04 01:17:54.550483188 +0100
-@@ -32,7 +32,7 @@
- */
-
- #include "soapH.h"
--#include <iostream.h>
-+#include <iostream>
-
- const char luserver[] = "http://websrv.cs.fsu.edu/~engelen/luserver.cgi";
-
-@@ -51,14 +51,14 @@
- a[3].resize(2,3); // 2-element vector indexed from 2 to 3
- a[3][2] = 1;
- a[3][3] = 2;
-- cout << "* Demonstration example *" << endl;
-- cout << "Matrix:" << endl;
-+ std::cout << "* Demonstration example *" << std::endl;
-+ std::cout << "Matrix:" << std::endl;
- a.print();
- vector b(soap, 3);
- b[1] = 1;
- b[2] = 2;
- b[3] = 3;
-- cout << "Vector:" << endl;
-+ std::cout << "Vector:" << std::endl;
- b.print();
- vector x(soap);
- if (argc < 2)
-@@ -71,7 +71,7 @@
- soap_print_fault_location(soap, stderr);
- }
- else
-- { cout << "Solution vector from service:" << endl;
-+ { std::cout << "Solution vector from service:" << std::endl;
- x.print();
- }
- matrix a1(soap);
-@@ -80,7 +80,7 @@
- soap_print_fault_location(soap, stderr);
- }
- else
-- { cout << "Inverse matrix matrix from service:" << endl;
-+ { std::cout << "Inverse matrix matrix from service:" << std::endl;
- a1.print();
- }
- soap_destroy(soap);