summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-06-06 20:37:16 +0200
committerJeroen Roovers <jer@gentoo.org>2017-06-06 20:37:16 +0200
commit2a4de56b55c6af6cfc460706ef851368e45725d2 (patch)
treeaac618f587096d77b9b1b7554ba2fd812114c120 /net-libs/libflowmanager/libflowmanager-3.0.0-r1.ebuild
parentx11-wm/ctwm: Remove testing cruft. (diff)
downloadgentoo-2a4de56b55c6af6cfc460706ef851368e45725d2.tar.gz
gentoo-2a4de56b55c6af6cfc460706ef851368e45725d2.tar.bz2
gentoo-2a4de56b55c6af6cfc460706ef851368e45725d2.zip
net-libs/libflowmanager: Prune libtool files.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'net-libs/libflowmanager/libflowmanager-3.0.0-r1.ebuild')
-rw-r--r--net-libs/libflowmanager/libflowmanager-3.0.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-libs/libflowmanager/libflowmanager-3.0.0-r1.ebuild b/net-libs/libflowmanager/libflowmanager-3.0.0-r1.ebuild
new file mode 100644
index 000000000000..05a50cf545b1
--- /dev/null
+++ b/net-libs/libflowmanager/libflowmanager-3.0.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="A library that measures and reports on packet flows"
+HOMEPAGE="http://research.wand.net.nz/software/libflowmanager.php"
+SRC_URI="http://research.wand.net.nz/software/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/3"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="
+ >=net-libs/libtrace-3.0.6
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files
+}