summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-25 11:29:42 -0400
committerSam James <sam@gentoo.org>2024-03-26 12:24:30 +0000
commit9dc2b0c59ee947b470757ffc8d62c0f85a4b1f84 (patch)
treeff02d74dfb7919ecdb159d715ca37b870b5de33b /net-libs/libnetconf2
parentnet-misc/dropbox: drop versions (diff)
downloadgentoo-9dc2b0c59ee947b470757ffc8d62c0f85a4b1f84.tar.gz
gentoo-9dc2b0c59ee947b470757ffc8d62c0f85a4b1f84.tar.bz2
gentoo-9dc2b0c59ee947b470757ffc8d62c0f85a4b1f84.zip
net-libs/libnetconf2: mark as LTO-unsafe
It fails tests which seems like a promising sign that something unpromising happened. Closes: https://bugs.gentoo.org/877449 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/libnetconf2')
-rw-r--r--net-libs/libnetconf2/libnetconf2-2.1.31.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/net-libs/libnetconf2/libnetconf2-2.1.31.ebuild b/net-libs/libnetconf2/libnetconf2-2.1.31.ebuild
index a10855bd1960..14144aaf22aa 100644
--- a/net-libs/libnetconf2/libnetconf2-2.1.31.ebuild
+++ b/net-libs/libnetconf2/libnetconf2-2.1.31.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake
+inherit cmake flag-o-matic
DESCRIPTION="C library for building NETCONF servers and clients"
HOMEPAGE="https://github.com/CESNET/libnetconf2"
@@ -27,6 +27,15 @@ BDEPEND="
doc? ( app-text/doxygen[dot] )"
src_configure() {
+ # fails tests, but only with LTO.
+ # [ ERROR ] --- 0 != 0xffffffffffffffff
+ # [ LINE ] --- /var/tmp/portage/net-libs/libnetconf2-2.1.31/work/libnetconf2-2.1.31/tests/client/test_client_ssh.c:716: error: Failure!
+ # [ FAILED ] test_nc_client_ssh_ch_add_bind_listen
+ #
+ # https://bugs.gentoo.org/877449
+ # https://github.com/CESNET/libnetconf2/issues/471
+ filter-lto
+
local mycmakeargs=(
-DENABLE_TESTS=$(usex test)
-DENABLE_VALGRIND_TESTS=OFF