summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-02-17 15:21:02 +0100
committerJeroen Roovers <jer@gentoo.org>2018-02-17 15:21:18 +0100
commit5cac5ad2a05eea8de21cb1d3c5839154870521a8 (patch)
tree8b8c785aa96a7ac8dfac0e76367936f9de48025c /net-libs/libpcap
parentsys-kernel/vanilla-sources: bump {4.15.4,4.14.20,4.9.82,4.4.116} (diff)
downloadgentoo-5cac5ad2a05eea8de21cb1d3c5839154870521a8.tar.gz
gentoo-5cac5ad2a05eea8de21cb1d3c5839154870521a8.tar.bz2
gentoo-5cac5ad2a05eea8de21cb1d3c5839154870521a8.zip
net-libs/libpcap: Fix parallel make issue by Geoff Levand (bug #647538).
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-libs/libpcap')
-rw-r--r--net-libs/libpcap/files/libpcap-9999-libnl.patch22
-rw-r--r--net-libs/libpcap/files/libpcap-9999-parallel.patch22
-rw-r--r--net-libs/libpcap/libpcap-1.8.1-r1.ebuild7
-rw-r--r--net-libs/libpcap/libpcap-1.8.1-r2.ebuild3
-rw-r--r--net-libs/libpcap/libpcap-1.8.1.ebuild7
-rw-r--r--net-libs/libpcap/libpcap-9999.ebuild7
6 files changed, 33 insertions, 35 deletions
diff --git a/net-libs/libpcap/files/libpcap-9999-libnl.patch b/net-libs/libpcap/files/libpcap-9999-libnl.patch
deleted file mode 100644
index f243906ebad2..000000000000
--- a/net-libs/libpcap/files/libpcap-9999-libnl.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -492,10 +492,6 @@
-
- incdir=-I/usr/include/libnl3
- libnldir=
-- if test x$withval != x ; then
-- libnldir=-L${withval}/lib/.libs
-- incdir=-I${withval}/include
-- fi
-
- #
- # Try libnl 3.x first.
-@@ -510,7 +506,7 @@
- AC_DEFINE(HAVE_LIBNL_3_x,1,[if libnl exists and is version 3.x])
- AC_DEFINE(HAVE_LIBNL_NLE,1,[libnl has NLE_FAILURE])
- AC_DEFINE(HAVE_LIBNL_SOCKETS,1,[libnl has new-style socket api])
-- V_INCLS="$V_INCLS ${incdir}"
-+ V_INCLS="${incdir} $V_INCLS"
- have_any_nl="yes"
- ],[], ${incdir} ${libnldir} -lnl-genl-3 -lnl-3 )
-
diff --git a/net-libs/libpcap/files/libpcap-9999-parallel.patch b/net-libs/libpcap/files/libpcap-9999-parallel.patch
new file mode 100644
index 000000000000..61381a8e6d6c
--- /dev/null
+++ b/net-libs/libpcap/files/libpcap-9999-parallel.patch
@@ -0,0 +1,22 @@
+From 0dd90a6bdbce4dca14106859eee63ef643a106e2 Mon Sep 17 00:00:00 2001
+From: Alfredo Alvarez Fernandez <alfredoalvarezernandez@gmail.com>
+Date: Tue, 21 Feb 2017 11:41:43 +0100
+Subject: [PATCH] Makefile.in: Fix missing dependency
+
+---
+ Makefile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 7044f0438..f5d443aed 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -465,7 +465,7 @@ grammar.h: grammar.c
+ $(MAKE) $(MAKEFLAGS) grammar.c; \
+ fi
+
+-grammar.o: grammar.c
++grammar.o: grammar.c scanner.h
+ $(CC) $(FULL_CFLAGS) -c grammar.c
+
+ gencode.o: $(srcdir)/gencode.c grammar.h scanner.h
diff --git a/net-libs/libpcap/libpcap-1.8.1-r1.ebuild b/net-libs/libpcap/libpcap-1.8.1-r1.ebuild
index af93e87f6c24..e3cfd9d27415 100644
--- a/net-libs/libpcap/libpcap-1.8.1-r1.ebuild
+++ b/net-libs/libpcap/libpcap-1.8.1-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools eutils multilib-minimal
+inherit autotools multilib-minimal ltprune
DESCRIPTION="A system-independent library for user-level network packet capture"
HOMEPAGE="
@@ -38,13 +38,12 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.8.1-darwin.patch
"${FILESDIR}"/${PN}-1.8.1-libnl.patch
"${FILESDIR}"/${PN}-1.8.1-usbmon.patch
+ "${FILESDIR}"/${PN}-9999-parallel.patch
)
src_prepare() {
default
- eapply_user
-
echo ${PV} > VERSION || die
eautoreconf
diff --git a/net-libs/libpcap/libpcap-1.8.1-r2.ebuild b/net-libs/libpcap/libpcap-1.8.1-r2.ebuild
index a8f06895f6d2..cbce63e8d61c 100644
--- a/net-libs/libpcap/libpcap-1.8.1-r2.ebuild
+++ b/net-libs/libpcap/libpcap-1.8.1-r2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools eutils multilib-minimal
+inherit autotools multilib-minimal ltprune
DESCRIPTION="A system-independent library for user-level network packet capture"
HOMEPAGE="
@@ -39,6 +39,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.8.1-libnl.patch
"${FILESDIR}"/${PN}-1.8.1-usbmon.patch
"${FILESDIR}"/${PN}-1.8.1-disable-remote.patch
+ "${FILESDIR}"/${PN}-9999-parallel.patch
)
src_prepare() {
diff --git a/net-libs/libpcap/libpcap-1.8.1.ebuild b/net-libs/libpcap/libpcap-1.8.1.ebuild
index 3a8543b92dd7..e362e19d2b4d 100644
--- a/net-libs/libpcap/libpcap-1.8.1.ebuild
+++ b/net-libs/libpcap/libpcap-1.8.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools eutils multilib-minimal
+inherit autotools multilib-minimal ltprune
DESCRIPTION="A system-independent library for user-level network packet capture"
HOMEPAGE="
@@ -38,13 +38,12 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.8.1-darwin.patch
"${FILESDIR}"/${PN}-1.8.1-libnl.patch
"${FILESDIR}"/${PN}-1.8.1-usbmon.patch
+ "${FILESDIR}"/${PN}-9999-parallel.patch
)
src_prepare() {
default
- eapply_user
-
echo ${PV} > VERSION || die
eautoreconf
diff --git a/net-libs/libpcap/libpcap-9999.ebuild b/net-libs/libpcap/libpcap-9999.ebuild
index f7dcbffb9bf8..ad1d93451530 100644
--- a/net-libs/libpcap/libpcap-9999.ebuild
+++ b/net-libs/libpcap/libpcap-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools eutils git-r3 multilib-minimal
+inherit autotools git-r3 multilib-minimal ltprune
DESCRIPTION="A system-independent library for user-level network packet capture"
EGIT_REPO_URI="https://github.com/the-tcpdump-group/libpcap"
@@ -31,7 +31,6 @@ DEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-1.6.1-prefix-solaris.patch
- "${FILESDIR}"/${PN}-9999-libnl.patch
"${FILESDIR}"/${PN}-9999-prefix-darwin.patch
)
@@ -55,7 +54,7 @@ multilib_src_compile() {
}
multilib_src_install_all() {
- dodoc CREDITS CHANGES VERSION TODO README{,.dag,.linux,.macosx,.septel}
+ dodoc CREDITS CHANGES VERSION TODO README*
# remove static libraries (--disable-static does not work)
if ! use static-libs; then