summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2017-09-19 10:40:56 +0100
committerTony Vroon <chainsaw@gentoo.org>2017-09-19 10:42:39 +0100
commit5faccaea1a242f29fd22a9e2512fac0214f178e9 (patch)
tree68054ca6b8d855ce58aad8a2772682ea56592466 /net-libs/libpri/libpri-1.6.0.ebuild
parentdev-python/dulwich: remove old versions, thanks sbraz (diff)
downloadgentoo-5faccaea1a242f29fd22a9e2512fac0214f178e9.tar.gz
gentoo-5faccaea1a242f29fd22a9e2512fac0214f178e9.tar.bz2
gentoo-5faccaea1a242f29fd22a9e2512fac0214f178e9.zip
net-libs/libpri: Version bump to 1.6.0
Package-Manager: Portage-2.3.8, Repoman-2.3.1
Diffstat (limited to 'net-libs/libpri/libpri-1.6.0.ebuild')
-rw-r--r--net-libs/libpri/libpri-1.6.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-libs/libpri/libpri-1.6.0.ebuild b/net-libs/libpri/libpri-1.6.0.ebuild
new file mode 100644
index 000000000000..0d4713219a90
--- /dev/null
+++ b/net-libs/libpri/libpri-1.6.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Primary Rate ISDN (PRI) library"
+HOMEPAGE="http://www.asterisk.org/"
+SRC_URI="http://downloads.asterisk.org/pub/telephony/${PN}/releases/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.4.13-multilib.patch"
+ "${FILESDIR}/${PN}-1.6.0-respect-user-flags.patch"
+ "${FILESDIR}/${PN}-1.4.13-no-static-lib.patch"
+)
+
+src_compile() {
+ tc-export CC
+ default
+}
+src_install() {
+ emake INSTALL_PREFIX="${D}" LIBDIR="${D}/usr/$(get_libdir)" install
+ dodoc ChangeLog README TODO
+}