summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-09-05 08:00:56 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-09-05 08:01:23 -0500
commit4ae2203b373bfbebfb4797e77a8e81e8b110a198 (patch)
tree0e0f2f5c60b014fed7b02152c0b2f8e9f3fc39fe /net-libs/nodejs
parentsys-fs/zfs: add 2.2.6 (diff)
downloadgentoo-4ae2203b373bfbebfb4797e77a8e81e8b110a198.tar.gz
gentoo-4ae2203b373bfbebfb4797e77a8e81e8b110a198.tar.bz2
gentoo-4ae2203b373bfbebfb4797e77a8e81e8b110a198.zip
net-libs/nodejs: sync live
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'net-libs/nodejs')
-rw-r--r--net-libs/nodejs/nodejs-99999999.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/net-libs/nodejs/nodejs-99999999.ebuild b/net-libs/nodejs/nodejs-99999999.ebuild
index 40e5d335039b..2c68aa6262a1 100644
--- a/net-libs/nodejs/nodejs-99999999.ebuild
+++ b/net-libs/nodejs/nodejs-99999999.ebuild
@@ -7,7 +7,7 @@ CONFIG_CHECK="~ADVISE_SYSCALLS"
PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="threads(+)"
-inherit bash-completion-r1 check-reqs flag-o-matic linux-info ninja-utils pax-utils python-any-r1 xdg-utils
+inherit bash-completion-r1 check-reqs flag-o-matic linux-info ninja-utils pax-utils python-any-r1 toolchain-funcs xdg-utils
DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
HOMEPAGE="https://nodejs.org/"
@@ -24,7 +24,7 @@ else
S="${WORKDIR}/node-v${PV}"
fi
-IUSE="corepack cpu_flags_x86_sse2 debug doc +icu inspector lto +npm pax-kernel +snapshot +ssl +system-icu +system-ssl test"
+IUSE="corepack cpu_flags_x86_sse2 debug doc +icu inspector lto npm pax-kernel +snapshot +ssl +system-icu +system-ssl test"
REQUIRED_USE="inspector? ( icu ssl )
npm? ( ssl )
system-icu? ( icu )
@@ -39,11 +39,14 @@ RDEPEND=">=app-arch/brotli-1.0.9:=
>=dev-libs/simdjson-3.9.1:=
>=net-dns/c-ares-1.18.1:=
>=net-libs/nghttp2-1.61.0:=
- >=net-libs/ngtcp2-1.3.0:=
sys-libs/zlib
corepack? ( !sys-apps/yarn )
system-icu? ( >=dev-libs/icu-73:= )
- system-ssl? ( >=dev-libs/openssl-1.1.1:0= )
+ system-ssl? (
+ >=net-libs/ngtcp2-1.3.0:=
+ >=dev-libs/openssl-1.1.1:0=
+ )
+ !system-ssl? ( >=net-libs/ngtcp2-1.3.0:=[-gnutls] )
sys-devel/gcc:*"
BDEPEND="${PYTHON_DEPS}
app-alternatives/ninja