summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2025-01-31 17:33:30 +0100
committerGuilherme Amadio <amadio@gentoo.org>2025-01-31 17:34:28 +0100
commit81b6754e600271799bd9a723e644b8acee066aeb (patch)
treed8fd32d844b96616eb80137f0ecabc18d5e9a639 /net-libs/xrootd
parentnet-libs/xrootd: skip tests extended attributes, bug 937090 (diff)
downloadgentoo-81b6754e600271799bd9a723e644b8acee066aeb.tar.gz
gentoo-81b6754e600271799bd9a723e644b8acee066aeb.tar.bz2
gentoo-81b6754e600271799bd9a723e644b8acee066aeb.zip
net-libs/xrootd: add 5.7.3
Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'net-libs/xrootd')
-rw-r--r--net-libs/xrootd/Manifest1
-rw-r--r--net-libs/xrootd/xrootd-5.7.3.ebuild224
2 files changed, 225 insertions, 0 deletions
diff --git a/net-libs/xrootd/Manifest b/net-libs/xrootd/Manifest
index c693c2b153e4..d9bd1f3367f3 100644
--- a/net-libs/xrootd/Manifest
+++ b/net-libs/xrootd/Manifest
@@ -1,3 +1,4 @@
DIST xrootd-5.6.7.tar.gz 6698751 BLAKE2B cb702a450b81665b53cf15d5c8df239826148c3cd746db7778b48ae01244257ce4877402c3e07ef6aa5228f9ae97f1b39210ed46ea2c802c35b7c4d8ad6a7fcf SHA512 e7ec8b6eae684f27b5044890c45492f7d9b2b8812a9131ff45db63984869aa62cd85836d71b4100e89a6bb98ee3864062940d4dec0fdb340472df126d6de4d41
DIST xrootd-5.6.9.tar.gz 6701277 BLAKE2B 0086455f251879acf2d635ed0ae533dfa2c3e006798df27111d35599f1833ce1342c9eec1f540f3a165376c91233181420635bae5e1cb4d552681d8cfe36d902 SHA512 9ba15524451ebe7ee12d689f9c56d85508996285d01885236d396b7742ff6cc03036a6b4bd1424b0e1553cbf382c0954c10cec76fa1a99a7dfff330686bad0cd
DIST xrootd-5.7.2.tar.gz 6826940 BLAKE2B 4f2c6cc945c0c7706671a9bcfc9f2ffa5d28d82bdbbc4a865f9e57d3f7afa28b2fe7db74222587eb93c1028aa6644aa14d58acd9989384299d0f0a7a11d51b19 SHA512 a117b2e239695ac243ada3e1a0339d20057645b9e22753c32d44f3949e9ca0eab262397a8264e11293676e512b5cda921392f6ae52b935f93c60ea7247ac4f02
+DIST xrootd-5.7.3.tar.gz 6833395 BLAKE2B 88a30ee71cefc9b18a3d5ebb9268510a36024440cee97fff226a1873b335a191ca26e0c159ab92c150fa82d4609cf50f6bb82e142cf993750a1eaaf316cd6afb SHA512 3e9eb692d1836d5bebd64742fd145b5ffcd1e096f4bf007694dc1a1131118cb752316e291e626743c80af6a576791aa6cca31bd482a47c8774c4a01b2e599f4e
diff --git a/net-libs/xrootd/xrootd-5.7.3.ebuild b/net-libs/xrootd/xrootd-5.7.3.ebuild
new file mode 100644
index 000000000000..3c19284b1087
--- /dev/null
+++ b/net-libs/xrootd/xrootd-5.7.3.ebuild
@@ -0,0 +1,224 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..13} python3_13t )
+DISTUTILS_EXT=1
+DISTUTILS_OPTIONAL=1
+DISTUTILS_USE_PEP517="setuptools"
+DOCS_BUILDER="doxygen"
+DOCS_DEPEND="
+ media-gfx/graphviz
+ virtual/latex-base
+ python? ( dev-python/sphinx )
+"
+
+inherit cmake docs distutils-r1 systemd
+
+DESCRIPTION="Extended ROOT remote file server"
+HOMEPAGE="https://xrootd.slac.stanford.edu/"
+LICENSE="LGPL-3+"
+
+SLOT="0"
+IUSE="ceph examples fuse http kerberos +libxml2 macaroons python readline scitokens +server systemd test xrdec"
+
+if [[ ${PV} =~ "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/xrootd/xrootd.git"
+else
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+ SRC_URI="https://xrootd.web.cern.ch/download/v${PV}/${P}.tar.gz"
+fi
+
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="
+ http? ( kerberos )
+ macaroons? ( server http )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ scitokens? ( server )
+"
+
+CDEPEND="acct-group/xrootd
+ acct-user/xrootd
+ dev-libs/openssl:0=
+ sys-libs/zlib
+ virtual/libcrypt:=
+ ceph? ( sys-cluster/ceph )
+ fuse? ( sys-fs/fuse:0= )
+ http? (
+ net-misc/curl:=
+ net-libs/davix
+ )
+ kerberos? ( virtual/krb5 )
+ libxml2? ( dev-libs/libxml2:2= )
+ macaroons? ( dev-libs/libmacaroons )
+ python? ( ${PYTHON_DEPS} )
+ readline? ( sys-libs/readline:0= )
+ scitokens? ( dev-cpp/scitokens-cpp )
+ systemd? ( sys-apps/systemd:= )
+ xrdec? ( dev-libs/isa-l )
+"
+DEPEND="${CDEPEND}"
+BDEPEND="
+ python? (
+ ${PYTHON_DEPS}
+ ${DISTUTILS_DEPS}
+ test? ( >=dev-python/pytest-7.1.2[${PYTHON_USEDEP}] )
+ )
+ test? (
+ dev-cpp/gtest
+ dev-util/cppunit
+ )
+"
+RDEPEND="${CDEPEND}
+ dev-lang/perl
+"
+
+# XRootD plugins are not intended to be linked with,
+# they are loaded at runtime by the XRootD server.
+# See https://github.com/xrootd/xrootd/issues/447
+QA_SONAME="/usr/lib.*/libXrd.*-5\.so"
+
+pkg_setup() {
+ use python && python_setup
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ if use python; then
+ pushd "${S}"/bindings/python > /dev/null || die
+ distutils-r1_src_prepare
+ popd > /dev/null || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_SYSTEM_ISAL=TRUE
+ $(usex python "-DINSTALL_PYTHON_BINDINGS=FALSE" "")
+ -DXRDCEPH_SUBMODULE=$(usex ceph)
+ -DCMAKE_DISABLE_FIND_PACKAGE_LibXml2=$(usex libxml2 "no" "yes")
+ -DCMAKE_DISABLE_FIND_PACKAGE_systemd=$(usex systemd "no" "yes")
+ -DENABLE_FUSE=$(usex fuse)
+ -DENABLE_HTTP=$(usex http)
+ -DENABLE_KRB5=$(usex kerberos)
+ -DENABLE_MACAROONS=$(usex macaroons)
+ -DENABLE_PYTHON=$(usex python)
+ -DENABLE_READLINE=$(usex readline)
+ -DENABLE_SCITOKENS=$(usex scitokens)
+ -DENABLE_SERVER_TESTS=$(usex server)
+ -DENABLE_TESTS=$(usex test)
+ -DENABLE_VOMS=no
+ -DENABLE_XRDCL=yes
+ -DENABLE_XRDCLHTTP=$(usex http)
+ -DENABLE_XRDEC=$(usex xrdec)
+ -DFORCE_ENABLED=yes
+ -DXRDCL_ONLY=$(usex server "no" "yes")
+ )
+ cmake_src_configure
+
+ if use python; then
+ pushd "${BUILD_DIR}"/bindings/python > /dev/null || die
+ distutils-r1_src_configure
+ popd > /dev/null || die
+ fi
+}
+
+src_compile() {
+ cmake_src_compile
+ if use python; then
+ pushd "${BUILD_DIR}"/bindings/python > /dev/null || die
+ distutils-r1_src_compile
+ popd > /dev/null || die
+ fi
+
+ docs_compile
+ # secondary documentation for python bindings
+ if use python && use doc; then
+ emake -C bindings/python/docs html
+ fi
+}
+
+python_test() {
+ epytest
+}
+
+src_test() {
+ export CTEST_OUTPUT_ON_FAILURE=1
+
+ local CMAKE_SKIP_TESTS=(
+ # bug 937090, these fail on tmpfs, as they require
+ # a filesystem with extended attributes
+ $(usev server '
+ XrdCl::LocalFileHandlerTest.XAttrTest
+ XrdCl::FileTest.XAttrTest
+ XrdCl::FileCopyTest.ThirdPartyCopyTest
+ XrdCl::FileCopyTest.NormalCopyTest
+ XrdCl::FileSystemTest.XAttrTest
+ XrdCl::WorkflowTest.XAttrWorkflowTest
+ XrdCl::WorkflowTest.CheckpointTest
+ ')
+ # server fails to start due to long path to unix domain socket
+ $(usev scitokens '
+ XRootD::scitokens::setup
+ XRootD::scitokens::test
+ XRootD::scitokens::teardown
+ ')
+ )
+ cmake_src_test
+ # Python tests currently require manual configuration and start-up of an xrootd server.
+ # TODO: get this to run properly.
+ #use python && distutils-r1_src_test
+}
+
+src_install() {
+ dodoc docs/ReleaseNotes.txt
+ cmake_src_install
+ find "${ED}" \( -iname '*.md5' -o -iname '*.map' \) -delete || die
+
+ if use server; then
+ local i
+ for i in cmsd frm_purged frm_xfrd xrootd; do
+ newinitd "${FILESDIR}"/${i}.initd ${i}
+ done
+ # all daemons MUST use single master config file
+ newconfd "${FILESDIR}"/xrootd.confd xrootd
+
+ if use systemd; then
+ systemd_dounit packaging/common/*.{service,socket}
+ fi
+ fi
+
+ # base configs
+ insinto /etc/xrootd
+ doins packaging/common/*.cfg
+
+ keepdir /etc/xrootd/config.d
+ keepdir /var/log/xrootd
+
+ fowners -R xrootd:xrootd /etc/xrootd
+ fowners -R xrootd:xrootd /var/log/xrootd
+
+ if use python; then
+ pushd "${BUILD_DIR}"/bindings/python > /dev/null || die
+ distutils-r1_src_install
+ popd > /dev/null || die
+
+ if use doc; then
+ docinto python
+ docompress -x "/usr/share/doc/${PF}/python/html"
+ dodoc -r bindings/python/docs/build/html
+ fi
+ if use examples; then
+ docinto python
+ dodoc -r bindings/python/examples
+ fi
+ fi
+
+ if use server && use test; then
+ rm "${ED}"/usr/bin/xrdshmap || die "Failed to remove test binary ${f} from installed tree"
+ fi
+}