summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-15 21:41:02 +0000
committerSam James <sam@gentoo.org>2020-09-15 21:46:13 +0000
commit219255769e2cf40e8b7427fe0073d3a2827ed50f (patch)
treebf5b83bf8678d4552af9521c0449cdb7ca3151c4 /net-libs
parentnet-misc/gsasl: bump to 1.8.1 (diff)
downloadgentoo-219255769e2cf40e8b7427fe0073d3a2827ed50f.tar.gz
gentoo-219255769e2cf40e8b7427fe0073d3a2827ed50f.tar.bz2
gentoo-219255769e2cf40e8b7427fe0073d3a2827ed50f.zip
net-libs/libgsasl: bump to 1.8.1
Closes: https://bugs.gentoo.org/725358 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libgsasl/Manifest1
-rw-r--r--net-libs/libgsasl/files/libgsasl-1.8.1-gss-extra.patch21
-rw-r--r--net-libs/libgsasl/libgsasl-1.8.1.ebuild69
3 files changed, 91 insertions, 0 deletions
diff --git a/net-libs/libgsasl/Manifest b/net-libs/libgsasl/Manifest
index a971e9afd739..8398d6f53955 100644
--- a/net-libs/libgsasl/Manifest
+++ b/net-libs/libgsasl/Manifest
@@ -1 +1,2 @@
DIST libgsasl-1.8.0.tar.gz 1208417 BLAKE2B 03eea4be45ccc28bbc5c98b5f266552e6f5da151dfc561b1f01dac107a6edf0f06a3000e868c07d5539df33334d3c965c6c276de30c75038e25165aa7e2db2e8 SHA512 7e591d12404919559bf67590f862270ffcae2030a14097cdaf92820aa79619b3048541e9f83b3fcb98a84622c44a52ecaceeebb1be55b9e9f68fb1790ade8721
+DIST libgsasl-1.8.1.tar.gz 1791261 BLAKE2B bd8b954f9d950fe449fe140baca840a14f12ef6318e74a6fd070b35504b8c3a7002f13fe93142bce992e4a1df773ebaad4ec01d04c01c63a7374187a8142136b SHA512 52bda3a962a2cbb598009fd02c547a4f8b5b9a4243511aa8104df97b4737023281ab57dbbcf839db3cad73c64cbc72bbd89b49da8b0379dd635220ffb642aa22
diff --git a/net-libs/libgsasl/files/libgsasl-1.8.1-gss-extra.patch b/net-libs/libgsasl/files/libgsasl-1.8.1-gss-extra.patch
new file mode 100644
index 000000000000..15350a87d51d
--- /dev/null
+++ b/net-libs/libgsasl/files/libgsasl-1.8.1-gss-extra.patch
@@ -0,0 +1,21 @@
+Gentoo bug #359005
+--- a/m4/gss-extra.m4
++++ b/m4/gss-extra.m4
+@@ -19,7 +19,16 @@
+ AC_CHECK_FUNCS([gss_decapsulate_token])
+ AC_CHECK_FUNCS([gss_oid_equal])
+ AC_CHECK_FUNCS([gss_inquire_mech_for_saslname])
+- AC_CHECK_FUNCS([GSS_C_NT_HOSTBASED_SERVICE])
++ AC_MSG_CHECKING([for GSS_C_NT_HOSTBASED_SERVICE])
++ AC_EGREP_CPP(hostbased_service_gss_nt_yes, gssapi.h,
++ [#include <gssapi.h>
++ #ifdef GSS_C_NT_HOSTBASED_SERVICE
++ hostbased_service_gss_nt_yes
++ #endif],
++ [AC_DEFINE(HAVE_GSS_C_NT_HOSTBASED_SERVICE,,
++ [Define if your GSSAPI implimentation defines GSS_C_NT_HOSTBASED_SERVICE])
++ AC_MSG_RESULT([yes])],
++ AC_MSG_RESULT([no]))
+ if test "$gssapi_impl" != "gss"; then
+ AC_CHECK_HEADERS([gssapi.h gssapi/gssapi.h])
+ if test "$ac_cv_header_gssapi_h$ac_cv_header_gssapi_gssapi_h" = "nono"; then
diff --git a/net-libs/libgsasl/libgsasl-1.8.1.ebuild b/net-libs/libgsasl/libgsasl-1.8.1.ebuild
new file mode 100644
index 000000000000..c23abb24fb4a
--- /dev/null
+++ b/net-libs/libgsasl/libgsasl-1.8.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="The GNU SASL library"
+HOMEPAGE="https://www.gnu.org/software/gsasl/"
+SRC_URI="mirror://gnu/${PN/lib}/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="idn gcrypt kerberos nls ntlm static-libs"
+
+DEPEND="
+ gcrypt? ( dev-libs/libgcrypt:0= )
+ idn? ( net-dns/libidn:= )
+ kerberos? ( virtual/krb5 )
+ nls? ( >=sys-devel/gettext-0.18.1 )
+ ntlm? ( net-libs/libntlm )
+"
+RDEPEND="${DEPEND}
+ !net-misc/gsasl"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.8.1-gss-extra.patch"
+)
+
+src_prepare() {
+ default
+
+ sed -i -e 's/ -Werror//' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ local krb5_impl
+ if use kerberos; then
+ krb5_impl="--with-gssapi-impl="
+ # These are the two providers of virtual/krb5
+ if has_version app-crypt/mit-krb5; then
+ krb5_impl+="mit"
+ else
+ krb5_impl+="heimdal"
+ fi
+ fi
+
+ local myeconfargs=(
+ $(use_with gcrypt libgcrypt)
+ $(use_with idn stringprep)
+ $(use_enable kerberos gssapi)
+ ${krb5_impl}
+ $(use_enable nls)
+ $(use_enable ntlm)
+ $(use_enable static-libs static)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if ! use static-libs; then
+ rm -f "${ED}"/usr/lib*/lib*.la || die
+ fi
+}