summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2022-09-19 12:15:26 +0200
committerGuilherme Amadio <amadio@gentoo.org>2022-09-19 14:11:14 +0200
commit2c3112a75d4776c1082827174bd42415da15cf9a (patch)
tree18347abfe2b530924e63cb26f15bd124514abb8d /net-libs
parentdev-util/uftrace: stabilize 0.11 for amd64 (diff)
downloadgentoo-2c3112a75d4776c1082827174bd42415da15cf9a.tar.gz
gentoo-2c3112a75d4776c1082827174bd42415da15cf9a.tar.bz2
gentoo-2c3112a75d4776c1082827174bd42415da15cf9a.zip
net-libs/davix: version bump to 0.8.3
Closes: https://bugs.gentoo.org/763645 Closes: https://bugs.gentoo.org/831849 Closes: https://bugs.gentoo.org/840209 Closes: https://bugs.gentoo.org/861473 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/davix/Manifest1
-rw-r--r--net-libs/davix/davix-0.8.3.ebuild88
-rw-r--r--net-libs/davix/files/davix-0.8.3-enable-ctest.patch25
3 files changed, 114 insertions, 0 deletions
diff --git a/net-libs/davix/Manifest b/net-libs/davix/Manifest
index 597a524ae88d..7e03c70554eb 100644
--- a/net-libs/davix/Manifest
+++ b/net-libs/davix/Manifest
@@ -1 +1,2 @@
DIST davix-0.7.6.tar 4338692 BLAKE2B 72a918f52993ea358f243df671823a4624ac5650753e06c8f70f75a800f10adfe7f6c63d9c8fdcefb94874e3c60c3909e7aa96969af1210347ea941a42f4b9df SHA512 3e379acc763e72e2e1684121e2688da6c617b2c1f52ffd7a2a2559998a64aba957f09f7b138c57f8f4d7a26caff4fef09952cca48585bb4f6aea1f071aa9a7b7
+DIST davix-0.8.3.tar.gz 7615016 BLAKE2B 7bb9ba6e267439db0f8b42d2a2b48ded801e3a10d6443101918514f999922e9cabce485b7a666ee0c1fb60d18cd537aa76b93096eeb0445b5ce4b25e214496d4 SHA512 ce5c66e8d59710e5658a6bb9bebdce3749843ab672274171f936cc533ce42689e1f75454de2a71529df97eb182d996c4ade00f30e1b21891fbfe4a40b1dd2dc5
diff --git a/net-libs/davix/davix-0.8.3.ebuild b/net-libs/davix/davix-0.8.3.ebuild
new file mode 100644
index 000000000000..225557b09fd3
--- /dev/null
+++ b/net-libs/davix/davix-0.8.3.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit cmake python-any-r1
+
+DESCRIPTION="High-performance file management over WebDAV/HTTP"
+HOMEPAGE="https://github.com/cern-fts/davix"
+SRC_URI="https://github.com/cern-fts/${PN}/releases/download/R_${PV//./_}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc ipv6 test tools"
+RESTRICT="!test? ( test )"
+
+CDEPEND="
+ dev-libs/libxml2:2=
+ dev-libs/openssl:0=
+ net-libs/gsoap[ssl,-gnutls]
+ net-misc/curl:0=
+ kernel_linux? ( sys-apps/util-linux )
+"
+
+DEPEND="${CDEPEND}"
+BDEPEND="
+ doc? (
+ app-doc/doxygen[dot]
+ dev-python/sphinx
+ )
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+"
+
+RDEPEND="${CDEPEND}"
+
+REQUIRED_USE="test? ( tools )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.3-enable-ctest.patch
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ for x in doc test; do
+ if ! use $x; then
+ sed -i -e "/add_subdirectory ($x)/d" CMakeLists.txt
+ fi
+ done
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPython_EXECUTABLE="${PYTHON}"
+ -DDOC_INSTALL_DIR="${EPREFIX}/usr/share/doc/${P}"
+ -DEMBEDDED_LIBCURL=OFF
+ -DLIBCURL_BACKEND_BY_DEFAULT=OFF
+ -DENABLE_HTML_DOCS=$(usex doc)
+ -DENABLE_IPV6=$(usex ipv6)
+ -DENABLE_TCP_NODELAY=TRUE
+ -DENABLE_THIRD_PARTY_COPY=TRUE
+ -DENABLE_TOOLS=$(usex tools)
+ -DHTML_INSTALL_DIR="${EPREFIX}/usr/share/doc/${P}/html"
+ -DSOUND_INSTALL_DIR="${EPREFIX}/usr/share/${PN}/sounds"
+ -DSTATIC_LIBRARY=OFF
+ -DSYSCONF_INSTALL_DIR="${EPREFIX}/etc"
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ if use doc; then
+ cmake_src_compile doc
+ fi
+}
+
+src_install() {
+ cmake_src_install
+ if use test; then
+ rm "${ED}/usr/bin/davix-unit-tests" || die
+ fi
+}
diff --git a/net-libs/davix/files/davix-0.8.3-enable-ctest.patch b/net-libs/davix/files/davix-0.8.3-enable-ctest.patch
new file mode 100644
index 000000000000..cbf6fc0663ae
--- /dev/null
+++ b/net-libs/davix/files/davix-0.8.3-enable-ctest.patch
@@ -0,0 +1,25 @@
+From f72e33a2877a2e26279b64c61e5d04249529727a Mon Sep 17 00:00:00 2001
+From: Guilherme Amadio <amadio@cern.ch>
+Date: Fri, 16 Sep 2022 15:22:31 +0200
+Subject: [PATCH] Include CTest in main CMakeLists.txt
+
+---
+ CMakeLists.txt | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ddd6a391..cb87ffc1 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -126,6 +126,8 @@ endif()
+ include_directories(${CMAKE_CURRENT_SOURCE_DIR}/deps/libneon/src/ ${UUID_INCLUDE_DIRS})
+ include_directories(${CMAKE_SOURCE_DIR}/include/davix)
+
++include(CTest)
++
+ add_subdirectory (src)
+ add_subdirectory (doc)
+
+--
+2.37.3
+