summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-03-27 09:37:17 -0400
committerCraig Andrews <candrews@gentoo.org>2023-03-27 09:37:17 -0400
commiteacc8a15297bb0f71d410b6de69ab34281a299fd (patch)
treedd41a2c80d8e4f174c23fba18563e0e105097b26 /net-libs
parentnet-libs/ngtcp2: add 0.14.0 (diff)
downloadgentoo-eacc8a15297bb0f71d410b6de69ab34281a299fd.tar.gz
gentoo-eacc8a15297bb0f71d410b6de69ab34281a299fd.tar.bz2
gentoo-eacc8a15297bb0f71d410b6de69ab34281a299fd.zip
net-libs/ngtcp2: drop 0.13.1
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/ngtcp2/Manifest1
-rw-r--r--net-libs/ngtcp2/ngtcp2-0.13.1.ebuild52
2 files changed, 0 insertions, 53 deletions
diff --git a/net-libs/ngtcp2/Manifest b/net-libs/ngtcp2/Manifest
index 56acb5d07c35..a0ec37b5f177 100644
--- a/net-libs/ngtcp2/Manifest
+++ b/net-libs/ngtcp2/Manifest
@@ -1,2 +1 @@
-DIST ngtcp2-0.13.1.tar.xz 582412 BLAKE2B 086203def9e89a718852c0232d3dea9ee732f58b9fa76ec418de24fa6415ea507da391068611f16b60d8f19034bff7f69e73cc777d3a1d82cc901cb2a9e599fb SHA512 c8ff2eba9d2b7c5424e32e17ea481168ef3aa3140c0e17d210b4ef1065bc5c8d2e4393b99e7aea72693f8b6aa1cb9b44e9d48dde4e55e380bb614ec77a7b95fa
DIST ngtcp2-0.14.0.tar.xz 592228 BLAKE2B 245390baca48948a438edede40a00f8a65d9dfb2d674711c8c12c3cdea229b8740d565581941a4973535fa290a84343205fa5ec8dfde479a1795613127a83304 SHA512 6401302bcec57271e93405fb66ad6695b53645866c63f7d766c1b98dbc7ac1c884490b436c3dc71bf0541733e7a7b29e6bb90ed659290549a4abe50b299da231
diff --git a/net-libs/ngtcp2/ngtcp2-0.13.1.ebuild b/net-libs/ngtcp2/ngtcp2-0.13.1.ebuild
deleted file mode 100644
index 4d3a4cbaa377..000000000000
--- a/net-libs/ngtcp2/ngtcp2-0.13.1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake-multilib
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/ngtcp2/ngtcp2.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/ngtcp2/ngtcp2/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~amd64 ~hppa ~riscv ~x86"
-fi
-
-DESCRIPTION="Implementation of the IETF QUIC Protocol"
-HOMEPAGE="https://github.com/ngtcp2/ngtcp2/"
-
-LICENSE="MIT"
-SLOT="0/0"
-IUSE="+gnutls openssl +ssl static-libs test"
-REQUIRED_USE="ssl? ( || ( gnutls openssl ) )"
-
-BDEPEND="virtual/pkgconfig"
-RDEPEND="
- ssl? (
- gnutls? ( >=net-libs/gnutls-3.7.2:0= )
- openssl? (
- >=dev-libs/openssl-1.1.1:0=
- )
- )"
-DEPEND="${RDEPEND}
- test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
-RESTRICT="!test? ( test )"
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DENABLE_STATIC_LIB=$(usex static-libs)
- -DENABLE_GNUTLS=$(usex gnutls)
- -DENABLE_OPENSSL=$(usex openssl)
- -DENABLE_BORINGSSL=OFF
- -DENABLE_PICOTLS=OFF
- -DENABLE_WOLFSSL=OFF
- -DCMAKE_DISABLE_FIND_PACKAGE_Libev=ON
- -DCMAKE_DISABLE_FIND_PACKAGE_Libnghttp3=ON
- )
- cmake_src_configure
-}
-
-multilib_src_test() {
- cmake_build check
-}