summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/notmuch/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/notmuch/files')
-rw-r--r--net-mail/notmuch/files/0.16-0001-test-exit-with-nonzero-value-when-not-.patch56
-rw-r--r--net-mail/notmuch/files/0.19-0001-doc-gzipped-notmuch.3-before-trying-to.patch28
-rw-r--r--net-mail/notmuch/files/0.19-0002-Rename-rst2man-to-rst2man.py-for-Gento.patch38
-rw-r--r--net-mail/notmuch/files/0.19-0003-build-eliminate-use-of-python-execfile.patch47
-rw-r--r--net-mail/notmuch/files/50notmuch-gentoo.el7
-rw-r--r--net-mail/notmuch/files/60notmuch-pick-gentoo.el1
6 files changed, 177 insertions, 0 deletions
diff --git a/net-mail/notmuch/files/0.16-0001-test-exit-with-nonzero-value-when-not-.patch b/net-mail/notmuch/files/0.16-0001-test-exit-with-nonzero-value-when-not-.patch
new file mode 100644
index 000000000000..f66a12497320
--- /dev/null
+++ b/net-mail/notmuch/files/0.16-0001-test-exit-with-nonzero-value-when-not-.patch
@@ -0,0 +1,56 @@
+From c1f05bfb791e82776f5759e38c758cedd7e6190f Mon Sep 17 00:00:00 2001
+From: Tomi Ollila <tomi.ollila@iki.fi>
+Date: Sun, 8 Sep 2013 18:53:30 +0300
+Subject: [PATCH] test: exit with nonzero value when not all tests completed
+ successfully
+
+If any of the tests in our test system is not passing the execution
+of the test suite completes with nonzero exit value.
+
+It is better to rely on the exit value of the test system instead
+of some arbitrary strings in test output (or use both).
+---
+ test/aggregate-results.sh | 9 +++++++++
+ test/notmuch-test | 3 +++
+ 2 files changed, 12 insertions(+)
+
+diff --git a/test/aggregate-results.sh b/test/aggregate-results.sh
+index 732d6ca..b016edb 100755
+--- a/test/aggregate-results.sh
++++ b/test/aggregate-results.sh
+@@ -1,5 +1,7 @@
+ #!/usr/bin/env bash
+
++set -eu
++
+ fixed=0
+ success=0
+ failed=0
+@@ -79,3 +81,10 @@ if [ "$skipped" != "0" ]; then
+ tests=$(pluralize "test" $skipped)
+ echo "$skipped $tests skipped."
+ fi
++
++if [ $success -gt 0 -a $fixed -eq 0 -a $failed -eq 0 -a $skipped -eq 0 ]
++then
++ exit 0
++else
++ exit 1
++fi
+diff --git a/test/notmuch-test b/test/notmuch-test
+index 6db7979..aa28bb0 100755
+--- a/test/notmuch-test
++++ b/test/notmuch-test
+@@ -97,6 +97,9 @@ trap - HUP INT TERM
+
+ # Report results
+ ./aggregate-results.sh test-results/*
++ev=$?
+
+ # Clean up
+ rm -rf test-results corpus.mail
++
++exit $ev
+--
+1.8.3.2
+
diff --git a/net-mail/notmuch/files/0.19-0001-doc-gzipped-notmuch.3-before-trying-to.patch b/net-mail/notmuch/files/0.19-0001-doc-gzipped-notmuch.3-before-trying-to.patch
new file mode 100644
index 000000000000..3890328f75ac
--- /dev/null
+++ b/net-mail/notmuch/files/0.19-0001-doc-gzipped-notmuch.3-before-trying-to.patch
@@ -0,0 +1,28 @@
+From a95173249ae8811241da7640814934837abce53b Mon Sep 17 00:00:00 2001
+From: David Bremner <david@tethera.net>
+Date: Sun, 25 Jan 2015 15:04:51 +0100
+Subject: [PATCH] doc: gzipped notmuch.3 before trying to install notmuch.3.gz
+
+If HAVE_SPHINX=0 but HAVE_DOXYGEN=1, then the previous version was
+trying to install notmuch.3.gz but only got as far as creating
+notmuch.3
+---
+ doc/Makefile.local | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/doc/Makefile.local b/doc/Makefile.local
+index e7d0bac..a719d8b 100644
+--- a/doc/Makefile.local
++++ b/doc/Makefile.local
+@@ -63,7 +63,7 @@ install-man: install-apidocs
+ ifeq ($(HAVE_DOXYGEN),1)
+ MAN_GZIP_FILES += ${APIMAN}.gz
+ apidocs: $(APIMAN)
+-install-apidocs: apidocs
++install-apidocs: ${APIMAN}.gz
+ mkdir -p "$(DESTDIR)$(mandir)/man3"
+ install -m0644 $(DOCBUILDDIR)/man/man3/*.3.gz $(DESTDIR)/$(mandir)/man3
+
+--
+2.2.2
+
diff --git a/net-mail/notmuch/files/0.19-0002-Rename-rst2man-to-rst2man.py-for-Gento.patch b/net-mail/notmuch/files/0.19-0002-Rename-rst2man-to-rst2man.py-for-Gento.patch
new file mode 100644
index 000000000000..beda83ddff3f
--- /dev/null
+++ b/net-mail/notmuch/files/0.19-0002-Rename-rst2man-to-rst2man.py-for-Gento.patch
@@ -0,0 +1,38 @@
+From dcae4803d006af1a7b961a492d65c28a3cffbc3c Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Amadeusz=20=C5=BBo=C5=82nowski?= <aidecoe@aidecoe.name>
+Date: Thu, 29 Jan 2015 14:17:01 +0100
+Subject: [PATCH 2/2] Rename rst2man to rst2man.py for Gentoo
+
+Gentoo doesn't provide symlink rst2man.py -> rst2man.
+---
+ configure | 2 +-
+ doc/prerst2man.py | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure b/configure
+index d14e7d1..bf78066 100755
+--- a/configure
++++ b/configure
+@@ -436,7 +436,7 @@ else
+ have_sphinx=0
+
+ printf "Checking if rst2man is available... "
+- if rst2man -V > /dev/null 2>&1; then
++ if rst2man.py -V > /dev/null 2>&1; then
+ printf "Yes.\n"
+ have_rst2man=1
+ else
+diff --git a/doc/prerst2man.py b/doc/prerst2man.py
+index 437dea9..22b8258 100644
+--- a/doc/prerst2man.py
++++ b/doc/prerst2man.py
+@@ -59,5 +59,5 @@ for page in man_pages:
+ outfile.write("".join(lines))
+ outfile.close()
+
+- system('set -x; rst2man {0} {1}/{2}.{3}'
++ system('set -x; rst2man.py {0} {1}/{2}.{3}'
+ .format(filename, outdir, page[0], page[4]))
+--
+2.2.2
+
diff --git a/net-mail/notmuch/files/0.19-0003-build-eliminate-use-of-python-execfile.patch b/net-mail/notmuch/files/0.19-0003-build-eliminate-use-of-python-execfile.patch
new file mode 100644
index 000000000000..2eff9d63612d
--- /dev/null
+++ b/net-mail/notmuch/files/0.19-0003-build-eliminate-use-of-python-execfile.patch
@@ -0,0 +1,47 @@
+From 381385ccb7581bb16b72c23fd804c40b0330fe71 Mon Sep 17 00:00:00 2001
+From: David Bremner <david@tethera.net>
+Date: Sat, 3 Jan 2015 14:14:03 +0100
+Subject: [PATCH 3/3] build: eliminate use of python execfile command
+
+As discussed in
+id:8cc9dd580ad672527e12f43706f9803b2c8e99d8.1405220724.git.wking@tremily.us,
+execfile is unavailable in python3.
+
+The approach of this commit avoids modifying the python module path,
+which is arguably preferable since it avoids potentially accidentally
+importing a module from the wrong place.
+---
+ devel/release-checks.sh | 2 +-
+ doc/prerst2man.py | 3 ++-
+ 2 files changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/devel/release-checks.sh b/devel/release-checks.sh
+index 797d62a..ae02f55 100755
+--- a/devel/release-checks.sh
++++ b/devel/release-checks.sh
+@@ -130,7 +130,7 @@ else
+ fi
+
+ echo -n "Checking that python bindings version is $VERSION... "
+-py_version=`python -c "execfile('$PV_FILE'); print __VERSION__"`
++py_version=`python -c "with open('$PV_FILE') as vf: exec(vf.read()); print __VERSION__"`
+ if [ "$py_version" = "$VERSION" ]
+ then
+ echo Yes.
+diff --git a/doc/prerst2man.py b/doc/prerst2man.py
+index 22b8258..45dddca 100644
+--- a/doc/prerst2man.py
++++ b/doc/prerst2man.py
+@@ -10,7 +10,8 @@ outdir = argv[2]
+ if not isdir(outdir):
+ makedirs(outdir, 0o755)
+
+-execfile(sourcedir + "/conf.py")
++with open(sourcedir + "/conf.py") as cf:
++ exec(cf.read())
+
+
+ def header(file, startdocname, command, description, authors, section):
+--
+2.2.2
+
diff --git a/net-mail/notmuch/files/50notmuch-gentoo.el b/net-mail/notmuch/files/50notmuch-gentoo.el
new file mode 100644
index 000000000000..95e06246fea4
--- /dev/null
+++ b/net-mail/notmuch/files/50notmuch-gentoo.el
@@ -0,0 +1,7 @@
+(add-to-list 'load-path "@SITELISP@")
+(if (boundp 'image-load-path)
+ (add-to-list 'image-load-path "@SITEETC@" t))
+(autoload 'notmuch "notmuch" nil t)
+(autoload 'notmuch-search "notmuch" nil t)
+(autoload 'notmuch-hello "notmuch-hello" nil t)
+(autoload 'notmuch-show "notmuch-show" nil t)
diff --git a/net-mail/notmuch/files/60notmuch-pick-gentoo.el b/net-mail/notmuch/files/60notmuch-pick-gentoo.el
new file mode 100644
index 000000000000..84ef4b4d2293
--- /dev/null
+++ b/net-mail/notmuch/files/60notmuch-pick-gentoo.el
@@ -0,0 +1 @@
+(autoload 'notmuch-pick "notmuch-pick" "Run notmuch pick with the given `query' and display the results" t)