summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/postfix-logwatch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/postfix-logwatch')
-rw-r--r--net-mail/postfix-logwatch/Manifest2
-rw-r--r--net-mail/postfix-logwatch/metadata.xml15
-rw-r--r--net-mail/postfix-logwatch/postfix-logwatch-1.40.00.ebuild64
-rw-r--r--net-mail/postfix-logwatch/postfix-logwatch-1.40.03.ebuild37
4 files changed, 118 insertions, 0 deletions
diff --git a/net-mail/postfix-logwatch/Manifest b/net-mail/postfix-logwatch/Manifest
new file mode 100644
index 000000000000..802d5e96841e
--- /dev/null
+++ b/net-mail/postfix-logwatch/Manifest
@@ -0,0 +1,2 @@
+DIST postfix-logwatch-1.40.00.tgz 107441 SHA256 d72a9a91a6871606810485b342ca684a2e8724897b9c906cc27d3df7a15b2616 SHA512 c388cfefceeefcc19bc987865dbe0312ef0f470524ebd8af33abe639137cce699ad79f33b2b64168d2d572981372a9af58e60f6cdfbc661fc56ab64f1c19be03 WHIRLPOOL 027af839c2118eb4abb00c9417ecd4c612a8f6ed81d26461c6025df4effe644b9a809c57d90474f8d515326b3528f6b0311c7b9626fa655e158cfa4712d1abd8
+DIST postfix-logwatch-1.40.03.tgz 107065 SHA256 c9aae87471554bb93c9d91bd2df3999ce3fae19f75ffd43fdee3f8552232c748 SHA512 7059f409cabb3cb638885342ab876e1c85c87530c3544bf04c54a56707695acdc5cbb706e3f192ef5608c9a00706e4d7be3cc7b32286460719d7b497e44b3341 WHIRLPOOL 3c8e556863a79ec55af5e1a19204ddbc2fb3ac60c1a8162239f465da2cda465983f705755be7750e58e0a196c680b1e880f5c6aed0157baf275f6443535104a4
diff --git a/net-mail/postfix-logwatch/metadata.xml b/net-mail/postfix-logwatch/metadata.xml
new file mode 100644
index 000000000000..6ceb397c34a1
--- /dev/null
+++ b/net-mail/postfix-logwatch/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="logwatch">
+ Install filters for use with <pkg>sys-apps/logwatch</pkg>.
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">logreporters</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-mail/postfix-logwatch/postfix-logwatch-1.40.00.ebuild b/net-mail/postfix-logwatch/postfix-logwatch-1.40.00.ebuild
new file mode 100644
index 000000000000..ac84ab33ffa6
--- /dev/null
+++ b/net-mail/postfix-logwatch/postfix-logwatch-1.40.00.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A log analyzer for postfix"
+HOMEPAGE="http://logreporters.sourceforge.net/"
+SRC_URI="mirror://sourceforge/logreporters/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64"
+
+# >sys-apps/logwatch-7.4.0 ships our logwatch scripts and will
+# thus obsolete this use flag.
+IUSE="logwatch"
+
+RDEPEND="dev-lang/perl
+ logwatch? ( !>sys-apps/logwatch-7.4.0 )"
+
+src_prepare() {
+ # Replace the default config file location with ours.
+ local cfg_default='/usr/local/etc/${progname_prefix}-logwatch.conf'
+ local cfg_gentoo='/etc/${progname_prefix}-logwatch.conf';
+ sed -i "s~${cfg_default}~${cfg_gentoo}~" ${PN} \
+ || die 'failed to update the default config location'
+}
+
+src_compile() {
+ # The default make target just outputs instructions. We don't want
+ # the user to see these, so we avoid the default emake.
+ :
+}
+
+src_install() {
+ # There are two different "versions" of the package in the
+ # tarball: a standalone executable and a logwatch filter. The
+ # standalone is always installed. However, the logwatch filter is
+ # only installed with USE="logwatch".
+ dodoc Bugs Changes README ${PN}.conf-topn
+ doman ${PN}.1
+ dobin ${PN}
+ insinto /etc
+ doins ${PN}.conf
+
+ if use logwatch; then
+ # Remove the taint mode (-T) switch from the header of the
+ # standalone executable, and save the result as our logwatch
+ # filter.
+ #
+ # We don't do this for the standalone script because it's nice
+ # to have the taint flag when it works.
+ #
+ sed 's~^#!/usr/bin/perl -T$~#!/usr/bin/perl~' ${PN} > postfix \
+ || die 'failed to remove the perl taint switch'
+
+ insinto /etc/logwatch/scripts/services
+ doins postfix
+
+ insinto /etc/logwatch/conf/services
+ newins ${PN}.conf postfix.conf
+ fi
+}
diff --git a/net-mail/postfix-logwatch/postfix-logwatch-1.40.03.ebuild b/net-mail/postfix-logwatch/postfix-logwatch-1.40.03.ebuild
new file mode 100644
index 000000000000..99d064ad9cab
--- /dev/null
+++ b/net-mail/postfix-logwatch/postfix-logwatch-1.40.03.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A log analyzer for postfix"
+HOMEPAGE="http://logreporters.sourceforge.net/"
+SRC_URI="mirror://sourceforge/logreporters/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="dev-lang/perl"
+
+src_prepare() {
+ # Replace the default config file location with ours.
+ local cfg_default='/usr/local/etc/${progname_prefix}-logwatch.conf'
+ local cfg_gentoo='/etc/${progname_prefix}-logwatch.conf';
+ sed -i "s~${cfg_default}~${cfg_gentoo}~" ${PN} \
+ || die 'failed to update the default config location'
+}
+
+src_compile() {
+ # The default make target just outputs instructions. We don't want
+ # the user to see these, so we avoid the default emake.
+ :
+}
+
+src_install() {
+ dodoc Bugs Changes README ${PN}.conf-topn
+ doman ${PN}.1
+ dobin ${PN}
+ insinto /etc
+ doins ${PN}.conf
+}