summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2020-11-25 22:51:31 +0100
committerPiotr Karbowski <slashbeast@gentoo.org>2020-11-25 22:52:47 +0100
commit038140d81b3f6bef55872554e79a896d14d3b71d (patch)
tree7f6d175aaa17524f62dbfece31d7977babd2fa51 /net-misc/axel/axel-2.17.10.ebuild
parentnet-vpn/openvpn-1.5.0-r1: Restore + on openssl USE flag (diff)
downloadgentoo-038140d81b3f6bef55872554e79a896d14d3b71d.tar.gz
gentoo-038140d81b3f6bef55872554e79a896d14d3b71d.tar.bz2
gentoo-038140d81b3f6bef55872554e79a896d14d3b71d.zip
net-misc/axel: 2.17.10 bump
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'net-misc/axel/axel-2.17.10.ebuild')
-rw-r--r--net-misc/axel/axel-2.17.10.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/axel/axel-2.17.10.ebuild b/net-misc/axel/axel-2.17.10.ebuild
new file mode 100644
index 000000000000..dad9472d9679
--- /dev/null
+++ b/net-misc/axel/axel-2.17.10.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Light Unix download accelerator"
+HOMEPAGE="https://github.com/axel-download-accelerator/axel"
+SRC_URI="https://github.com/axel-download-accelerator/axel/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug libressl nls ssl"
+
+CDEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+"
+DEPEND="${CDEPEND}
+ nls? ( sys-devel/gettext )"
+RDEPEND="${CDEPEND}
+ nls? ( virtual/libintl virtual/libiconv )"
+
+DOCS=( doc/. )
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with ssl)
+}
+
+pkg_postinst() {
+ einfo 'To use axel with Portage, one can configure make.conf with:'
+ einfo
+ einfo 'FETCHCOMMAND="axel --timeout=30 --alternate --no-clobber --output=\"\${DISTDIR}/\${FILE}\" \"\${URI}\""'
+ einfo 'RESUMECOMMAND="axel --timeout=30 --alternate --no-clobber --output=\"\${DISTDIR}/\${FILE}\" \"\${URI}\""'
+}