summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-14 11:32:54 +0100
committerDavid Seifert <soap@gentoo.org>2021-02-14 11:32:54 +0100
commitcb4b67edc310230fde780458896b3b5089a58eec (patch)
tree3eb8cb8aa07e2552078cc5238d5f3b8c50d4098b /net-misc/cgminer/cgminer-4.9.2.ebuild
parentnet-misc/cgminer: Apply gcc-10 workaround (diff)
downloadgentoo-cb4b67edc310230fde780458896b3b5089a58eec.tar.gz
gentoo-cb4b67edc310230fde780458896b3b5089a58eec.tar.bz2
gentoo-cb4b67edc310230fde780458896b3b5089a58eec.zip
net-misc/cgminer: Remove old
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-misc/cgminer/cgminer-4.9.2.ebuild')
-rw-r--r--net-misc/cgminer/cgminer-4.9.2.ebuild85
1 files changed, 0 insertions, 85 deletions
diff --git a/net-misc/cgminer/cgminer-4.9.2.ebuild b/net-misc/cgminer/cgminer-4.9.2.ebuild
deleted file mode 100644
index 6cf544e6b085..000000000000
--- a/net-misc/cgminer/cgminer-4.9.2.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Bitcoin CPU/GPU/FPGA/ASIC miner in C"
-HOMEPAGE="https://bitcointalk.org/?topic=28402.msg357369 https://github.com/ckolivas/cgminer"
-SRC_URI="http://ck.kolivas.org/apps/cgminer/${P}.tar.bz2"
-#SRC_URI="http://ck.kolivas.org/apps/cgminer/4.5/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-
-HARDWARE="ants1 ants2 ants3 avalon avalon2 avalon4 bab bflsc bitforce bitfury bitmine_A1 blockerupter cointerra drillbit hashfast hashratio icarus klondike knc minion modminer sp10 sp30"
-IUSE="doc examples udev hardened ncurses ${HARDWARE}"
-
-REQUIRED_USE="|| ( ${HARDWARE} )"
-
-RDEPEND="net-misc/curl
- >=dev-libs/jansson-2.6
- virtual/libusb:1[udev]
- ncurses? ( sys-libs/ncurses:0= )
- udev? ( virtual/libudev )"
-DEPEND="virtual/pkgconfig
- ${RDEPEND}"
-
-src_configure() {
- use hardened && append-cflags "-no-pie"
-
- # PKG_CHECK_MODULES needs PKG_CONFIG for --with-system-jansson.
- export PKG_CONFIG=/usr/bin/pkg-config
- econf $(use_with ncurses curses) \
- $(use_enable ants1) \
- $(use_enable ants2) \
- $(use_enable ants3) \
- $(use_enable avalon) \
- $(use_enable avalon2) \
- $(use_enable avalon4) \
- $(use_enable bab) \
- $(use_enable bitmine_A1) \
- $(use_enable bflsc) \
- $(use_enable bitforce) \
- $(use_enable bitfury) \
- $(use_enable blockerupter) \
- $(use_enable cointerra) \
- $(use_enable drillbit) \
- $(use_enable hashfast) \
- $(use_enable hashratio) \
- $(use_enable icarus) \
- $(use_enable klondike) \
- $(use_enable knc) \
- $(use_enable minion) \
- $(use_enable modminer) \
- $(use_enable sp10) \
- $(use_enable sp30) \
- $(use_enable udev) \
- --disable-forcecombo \
- --with-system-libusb \
- --with-system-jansson
- # sanitize directories (is this still needed?)
- sed -i 's~^\(\#define CGMINER_PREFIX \).*$~\1"'"${EPREFIX}/usr/lib/cgminer"'"~' config.h
-}
-
-src_install() { # How about using some make install?
- dobin cgminer
-
- if use udev; then
- insinto /lib/udev/rules.d
- use udev && doins 01-cgminer.rules
- fi
-
- if use doc; then
- dodoc AUTHORS NEWS README API-README
- use icarus || use bitforce || use modminer && dodoc FPGA-README
- use avalon || use bflsc && dodoc ASIC-README
- fi
-
- if use examples; then
- docinto examples
- dodoc api-example.php miner.php API.java api-example.c example.conf
- fi
-}