summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-14 04:40:13 +0100
committerSam James <sam@gentoo.org>2023-09-14 04:40:13 +0100
commit0457bac499c5e9a2f733065d74c051f1cf938f10 (patch)
tree66b9b22858980b7efec46e4ebc34962994530e1d /net-misc/curl
parentapp-text/ghostscript-gpl: add 10.02.0 (diff)
downloadgentoo-0457bac499c5e9a2f733065d74c051f1cf938f10.tar.gz
gentoo-0457bac499c5e9a2f733065d74c051f1cf938f10.tar.bz2
gentoo-0457bac499c5e9a2f733065d74c051f1cf938f10.zip
net-misc/curl: drop old configure args
No revbump as it makes 0 diff. to the effective configuration as NSS was straight up removed in 8.3.0 and the rest are just reflecting defaults (renamed options anyway). Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/curl')
-rw-r--r--net-misc/curl/curl-8.3.0.ebuild27
-rw-r--r--net-misc/curl/curl-9999.ebuild27
2 files changed, 18 insertions, 36 deletions
diff --git a/net-misc/curl/curl-8.3.0.ebuild b/net-misc/curl/curl-8.3.0.ebuild
index 9bc62ec0c41d..8a2356959332 100644
--- a/net-misc/curl/curl-8.3.0.ebuild
+++ b/net-misc/curl/curl-8.3.0.ebuild
@@ -22,9 +22,9 @@ fi
LICENSE="BSD curl ISC test? ( BSD-4 )"
SLOT="0"
-IUSE="+adns alt-svc brotli +ftp gnutls gopher hsts +http2 idn +imap kerberos ldap mbedtls nss +openssl +pop3 +progress-meter rtmp rustls samba +smtp ssh ssl sslv3 static-libs test telnet +tftp websockets zstd"
+IUSE="+adns alt-svc brotli +ftp gnutls gopher hsts +http2 idn +imap kerberos ldap mbedtls +openssl +pop3 +progress-meter rtmp rustls samba +smtp ssh ssl sslv3 static-libs test telnet +tftp websockets zstd"
# These select the default SSL implementation
-IUSE+=" curl_ssl_gnutls curl_ssl_mbedtls curl_ssl_nss +curl_ssl_openssl curl_ssl_rustls"
+IUSE+=" curl_ssl_gnutls curl_ssl_mbedtls +curl_ssl_openssl curl_ssl_rustls"
IUSE+=" nghttp3"
RESTRICT="!test? ( test )"
@@ -35,14 +35,12 @@ REQUIRED_USE="
^^ (
curl_ssl_gnutls
curl_ssl_mbedtls
- curl_ssl_nss
curl_ssl_openssl
curl_ssl_rustls
)
)
curl_ssl_gnutls? ( gnutls )
curl_ssl_mbedtls? ( mbedtls )
- curl_ssl_nss? ( nss )
curl_ssl_openssl? ( openssl )
curl_ssl_rustls? ( rustls )
"
@@ -78,11 +76,6 @@ RDEPEND="
app-misc/ca-certificates
net-libs/mbedtls:=[${MULTILIB_USEDEP}]
)
- nss? (
- app-misc/ca-certificates
- dev-libs/nss[${MULTILIB_USEDEP}]
- dev-libs/nss-pem
- )
openssl? (
dev-libs/openssl:=[sslv3(-)=,static-libs?,${MULTILIB_USEDEP}]
)
@@ -147,7 +140,7 @@ multilib_src_configure() {
myconf+=( --without-ca-fallback --with-ca-bundle="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt )
if use ssl; then
- myconf+=( --without-gnutls --without-mbedtls --without-nss --without-rustls )
+ myconf+=( --without-gnutls --without-mbedtls --without-rustls )
if use gnutls; then
multilib_is_native_abi && einfo "SSL provided by gnutls"
@@ -157,10 +150,6 @@ multilib_src_configure() {
multilib_is_native_abi && einfo "SSL provided by mbedtls"
myconf+=( --with-mbedtls )
fi
- if use nss; then
- multilib_is_native_abi && einfo "SSL provided by nss"
- myconf+=( --with-nss --with-nss-deprecated )
- fi
if use openssl; then
multilib_is_native_abi && einfo "SSL provided by openssl"
myconf+=( --with-ssl --with-ca-path="${EPREFIX}"/etc/ssl/certs )
@@ -175,9 +164,6 @@ multilib_src_configure() {
elif use curl_ssl_mbedtls; then
multilib_is_native_abi && einfo "Default SSL provided by mbedtls"
myconf+=( --with-default-ssl-backend=mbedtls )
- elif use curl_ssl_nss; then
- multilib_is_native_abi && einfo "Default SSL provided by nss"
- myconf+=( --with-default-ssl-backend=nss )
elif use curl_ssl_openssl; then
multilib_is_native_abi && einfo "Default SSL provided by openssl"
myconf+=( --with-default-ssl-backend=openssl )
@@ -206,7 +192,12 @@ multilib_src_configure() {
myconf+=(
$(use_enable alt-svc)
- --enable-crypto-auth
+ --enable-basic-auth
+ --enable-bearer-auth
+ --enable-digest-auth
+ --enable-kerberos-auth
+ --enable-negotiate-auth
+ --enable-aws
--enable-dict
--disable-ech
--enable-file
diff --git a/net-misc/curl/curl-9999.ebuild b/net-misc/curl/curl-9999.ebuild
index 9bc62ec0c41d..8a2356959332 100644
--- a/net-misc/curl/curl-9999.ebuild
+++ b/net-misc/curl/curl-9999.ebuild
@@ -22,9 +22,9 @@ fi
LICENSE="BSD curl ISC test? ( BSD-4 )"
SLOT="0"
-IUSE="+adns alt-svc brotli +ftp gnutls gopher hsts +http2 idn +imap kerberos ldap mbedtls nss +openssl +pop3 +progress-meter rtmp rustls samba +smtp ssh ssl sslv3 static-libs test telnet +tftp websockets zstd"
+IUSE="+adns alt-svc brotli +ftp gnutls gopher hsts +http2 idn +imap kerberos ldap mbedtls +openssl +pop3 +progress-meter rtmp rustls samba +smtp ssh ssl sslv3 static-libs test telnet +tftp websockets zstd"
# These select the default SSL implementation
-IUSE+=" curl_ssl_gnutls curl_ssl_mbedtls curl_ssl_nss +curl_ssl_openssl curl_ssl_rustls"
+IUSE+=" curl_ssl_gnutls curl_ssl_mbedtls +curl_ssl_openssl curl_ssl_rustls"
IUSE+=" nghttp3"
RESTRICT="!test? ( test )"
@@ -35,14 +35,12 @@ REQUIRED_USE="
^^ (
curl_ssl_gnutls
curl_ssl_mbedtls
- curl_ssl_nss
curl_ssl_openssl
curl_ssl_rustls
)
)
curl_ssl_gnutls? ( gnutls )
curl_ssl_mbedtls? ( mbedtls )
- curl_ssl_nss? ( nss )
curl_ssl_openssl? ( openssl )
curl_ssl_rustls? ( rustls )
"
@@ -78,11 +76,6 @@ RDEPEND="
app-misc/ca-certificates
net-libs/mbedtls:=[${MULTILIB_USEDEP}]
)
- nss? (
- app-misc/ca-certificates
- dev-libs/nss[${MULTILIB_USEDEP}]
- dev-libs/nss-pem
- )
openssl? (
dev-libs/openssl:=[sslv3(-)=,static-libs?,${MULTILIB_USEDEP}]
)
@@ -147,7 +140,7 @@ multilib_src_configure() {
myconf+=( --without-ca-fallback --with-ca-bundle="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt )
if use ssl; then
- myconf+=( --without-gnutls --without-mbedtls --without-nss --without-rustls )
+ myconf+=( --without-gnutls --without-mbedtls --without-rustls )
if use gnutls; then
multilib_is_native_abi && einfo "SSL provided by gnutls"
@@ -157,10 +150,6 @@ multilib_src_configure() {
multilib_is_native_abi && einfo "SSL provided by mbedtls"
myconf+=( --with-mbedtls )
fi
- if use nss; then
- multilib_is_native_abi && einfo "SSL provided by nss"
- myconf+=( --with-nss --with-nss-deprecated )
- fi
if use openssl; then
multilib_is_native_abi && einfo "SSL provided by openssl"
myconf+=( --with-ssl --with-ca-path="${EPREFIX}"/etc/ssl/certs )
@@ -175,9 +164,6 @@ multilib_src_configure() {
elif use curl_ssl_mbedtls; then
multilib_is_native_abi && einfo "Default SSL provided by mbedtls"
myconf+=( --with-default-ssl-backend=mbedtls )
- elif use curl_ssl_nss; then
- multilib_is_native_abi && einfo "Default SSL provided by nss"
- myconf+=( --with-default-ssl-backend=nss )
elif use curl_ssl_openssl; then
multilib_is_native_abi && einfo "Default SSL provided by openssl"
myconf+=( --with-default-ssl-backend=openssl )
@@ -206,7 +192,12 @@ multilib_src_configure() {
myconf+=(
$(use_enable alt-svc)
- --enable-crypto-auth
+ --enable-basic-auth
+ --enable-bearer-auth
+ --enable-digest-auth
+ --enable-kerberos-auth
+ --enable-negotiate-auth
+ --enable-aws
--enable-dict
--disable-ech
--enable-file