summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-10 10:42:45 +0000
committerSam James <sam@gentoo.org>2023-01-10 10:52:12 +0000
commit0bedba8bbadeeb9cef3673d33a09f13d7bec54c7 (patch)
treeadc52c203d8974e8e5083422dce11ebc1788ad1d /net-misc/dhcping
parentapp-crypt/sequoia-sq: fix compilation with newer rustc (diff)
downloadgentoo-0bedba8bbadeeb9cef3673d33a09f13d7bec54c7.tar.gz
gentoo-0bedba8bbadeeb9cef3673d33a09f13d7bec54c7.tar.bz2
gentoo-0bedba8bbadeeb9cef3673d33a09f13d7bec54c7.zip
net-misc/dhcping: fix configure w/ clang 16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/dhcping')
-rw-r--r--net-misc/dhcping/dhcping-1.2-r1.ebuild (renamed from net-misc/dhcping/dhcping-1.2.ebuild)13
1 files changed, 11 insertions, 2 deletions
diff --git a/net-misc/dhcping/dhcping-1.2.ebuild b/net-misc/dhcping/dhcping-1.2-r1.ebuild
index b288cce6699a..57e443ea7948 100644
--- a/net-misc/dhcping/dhcping-1.2.ebuild
+++ b/net-misc/dhcping/dhcping-1.2-r1.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+inherit autotools
DESCRIPTION="Utility to send DHCP requests to DHCP servers to see if responding"
HOMEPAGE="http://www.mavetju.org/unix/general.php"
@@ -10,3 +12,10 @@ SRC_URI="http://www.mavetju.org/download/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 x86"
+
+src_prepare() {
+ default
+
+ # Clang 16
+ eautoreconf
+}