summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-11-26 10:36:01 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-11-26 10:36:44 +0100
commit144096f62d58d80b2ceccae80b9310c7bc577440 (patch)
tree874178bb9ab160d14129d4f41640deca89b25d5d /net-misc/gallery-dl
parentapp-editors/jedit: removed obsolete 5.2.0-r1 (diff)
downloadgentoo-144096f62d58d80b2ceccae80b9310c7bc577440.tar.gz
gentoo-144096f62d58d80b2ceccae80b9310c7bc577440.tar.bz2
gentoo-144096f62d58d80b2ceccae80b9310c7bc577440.zip
net-misc/gallery-dl: use EPYTHON for extra files installation
Closes: https://bugs.gentoo.org/766372 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'net-misc/gallery-dl')
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.17.5.ebuild6
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.18.1.ebuild6
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.19.2.ebuild6
-rw-r--r--net-misc/gallery-dl/gallery-dl-9999.ebuild6
4 files changed, 8 insertions, 16 deletions
diff --git a/net-misc/gallery-dl/gallery-dl-1.17.5.ebuild b/net-misc/gallery-dl/gallery-dl-1.17.5.ebuild
index 705fa73ec888..f202ee3c50b3 100644
--- a/net-misc/gallery-dl/gallery-dl-1.17.5.ebuild
+++ b/net-misc/gallery-dl/gallery-dl-1.17.5.ebuild
@@ -28,10 +28,8 @@ RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
distutils_enable_tests setup.py
-src_compile() {
- emake data/completion/{,_}gallery-dl man
-
- distutils-r1_src_compile
+python_compile_all() {
+ emake PYTHON=${EPYTHON} data/completion/{,_}gallery-dl man
}
pkg_postinst() {
diff --git a/net-misc/gallery-dl/gallery-dl-1.18.1.ebuild b/net-misc/gallery-dl/gallery-dl-1.18.1.ebuild
index 705fa73ec888..f202ee3c50b3 100644
--- a/net-misc/gallery-dl/gallery-dl-1.18.1.ebuild
+++ b/net-misc/gallery-dl/gallery-dl-1.18.1.ebuild
@@ -28,10 +28,8 @@ RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
distutils_enable_tests setup.py
-src_compile() {
- emake data/completion/{,_}gallery-dl man
-
- distutils-r1_src_compile
+python_compile_all() {
+ emake PYTHON=${EPYTHON} data/completion/{,_}gallery-dl man
}
pkg_postinst() {
diff --git a/net-misc/gallery-dl/gallery-dl-1.19.2.ebuild b/net-misc/gallery-dl/gallery-dl-1.19.2.ebuild
index d3b25012fb26..79c29ccc0450 100644
--- a/net-misc/gallery-dl/gallery-dl-1.19.2.ebuild
+++ b/net-misc/gallery-dl/gallery-dl-1.19.2.ebuild
@@ -28,10 +28,8 @@ RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
distutils_enable_tests setup.py
-src_compile() {
- emake data/completion/{,_}gallery-dl man
-
- distutils-r1_src_compile
+python_compile_all() {
+ emake PYTHON=${EPYTHON} data/completion/{,_}gallery-dl man
}
pkg_postinst() {
diff --git a/net-misc/gallery-dl/gallery-dl-9999.ebuild b/net-misc/gallery-dl/gallery-dl-9999.ebuild
index d3b25012fb26..79c29ccc0450 100644
--- a/net-misc/gallery-dl/gallery-dl-9999.ebuild
+++ b/net-misc/gallery-dl/gallery-dl-9999.ebuild
@@ -28,10 +28,8 @@ RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
distutils_enable_tests setup.py
-src_compile() {
- emake data/completion/{,_}gallery-dl man
-
- distutils-r1_src_compile
+python_compile_all() {
+ emake PYTHON=${EPYTHON} data/completion/{,_}gallery-dl man
}
pkg_postinst() {