summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-04-21 08:21:06 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-04-21 08:21:27 -0400
commit0bff87e9dd485eeb5376d489b10e511782713eac (patch)
tree9c396847a87117374360d4871f5d52b27c6a74ad /net-misc/hath/hath-0.4.1.ebuild
parentdev-lang/perl: Stop treating minor devrels as ABI compatible (diff)
downloadgentoo-0bff87e9dd485eeb5376d489b10e511782713eac.tar.gz
gentoo-0bff87e9dd485eeb5376d489b10e511782713eac.tar.bz2
gentoo-0bff87e9dd485eeb5376d489b10e511782713eac.zip
net-misc/hath: new version 0.4.1.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-misc/hath/hath-0.4.1.ebuild')
-rw-r--r--net-misc/hath/hath-0.4.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-misc/hath/hath-0.4.1.ebuild b/net-misc/hath/hath-0.4.1.ebuild
new file mode 100644
index 000000000000..36ab7c32af8d
--- /dev/null
+++ b/net-misc/hath/hath-0.4.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.2
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Hath manipulates network blocks in CIDR notation"
+HOMEPAGE="http://michael.orlitzky.com/code/hath.xhtml"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cmdargs-0.10:=
+ >=dev-haskell/split-0.2:=
+ >=dev-haskell/tasty-0.8:=
+ >=dev-haskell/tasty-hunit-0.8:=
+ >=dev-haskell/tasty-quickcheck-0.8.1:=
+ >=dev-lang/ghc-8:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-util/shelltestrunner )
+"
+
+src_install() {
+ cabal_src_install
+ doman "${S}/doc/man1/${PN}.1"
+}