summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Brewer <tomboy64@sina.cn>2016-02-03 22:41:46 +0100
committerMatthew Brewer <tomboy64@sina.cn>2016-02-04 22:18:22 +0100
commitd7f91b1cff28c329e5e0515ff5a67ef0bca1dd25 (patch)
treed9ba21b2f72c7666c1ab7a5ea65f5ba6e72305a7 /net-misc/i2pd/files
parentdev-libs/libusb: revbump to fix static-libs bug #515204 for stable users (diff)
downloadgentoo-d7f91b1cff28c329e5e0515ff5a67ef0bca1dd25.tar.gz
gentoo-d7f91b1cff28c329e5e0515ff5a67ef0bca1dd25.tar.bz2
gentoo-d7f91b1cff28c329e5e0515ff5a67ef0bca1dd25.zip
net-misc/i2pd: version bump 2.4.0
- rewrote configuration to use ECDSA-P256 for signed messages - default config now includes irc pre-setup (irc.postman.i2p) Package-Manager: portage-2.2.26 RepoMan-Options: --ignore-arches
Diffstat (limited to 'net-misc/i2pd/files')
-rw-r--r--net-misc/i2pd/files/i2pd-2.4.0-fix_installed_components.patch30
-rw-r--r--net-misc/i2pd/files/i2pd.confd5
-rw-r--r--net-misc/i2pd/files/i2pd.initd8
-rw-r--r--net-misc/i2pd/files/i2pd.service2
-rw-r--r--net-misc/i2pd/files/tunnels.cfg17
5 files changed, 56 insertions, 6 deletions
diff --git a/net-misc/i2pd/files/i2pd-2.4.0-fix_installed_components.patch b/net-misc/i2pd/files/i2pd-2.4.0-fix_installed_components.patch
new file mode 100644
index 000000000000..84749c8fc9aa
--- /dev/null
+++ b/net-misc/i2pd/files/i2pd-2.4.0-fix_installed_components.patch
@@ -0,0 +1,30 @@
+--- build/CMakeLists.txt.old 2016-02-04 21:30:50.954251000 +0100
++++ build/CMakeLists.txt 2016-02-04 21:34:50.457793484 +0100
+@@ -356,10 +356,6 @@
+ endif ()
+ endif ()
+
+-install(FILES ../LICENSE
+- DESTINATION .
+- COMPONENT Runtime
+- )
+ # Take a copy on Appveyor
+ install(FILES "C:/projects/openssl-$ENV{OPENSSL}/LICENSE"
+ DESTINATION .
+@@ -369,7 +365,6 @@
+ )
+
+ file(GLOB_RECURSE I2PD_SOURCES "../*.cpp" "../build" "../Win32" "../Makefile*")
+-install(FILES ${I2PD_SOURCES} DESTINATION src/ COMPONENT Source)
+ # install(DIRECTORY ../ DESTINATION src/
+ # # OPTIONAL
+ # COMPONENT Source FILES_MATCHING
+@@ -378,7 +373,7 @@
+ # )
+
+ file(GLOB I2PD_HEADERS "../*.h")
+-install(FILES ${I2PD_HEADERS} DESTINATION src/ COMPONENT Headers)
++install(FILES ${I2PD_HEADERS} DESTINATION "include/${PROJECT_NAME}" COMPONENT Headers)
+ # install(DIRECTORY ../ DESTINATION src/
+ # # OPTIONAL
+ # COMPONENT Headers FILES_MATCHING
diff --git a/net-misc/i2pd/files/i2pd.confd b/net-misc/i2pd/files/i2pd.confd
index 7913af7e6d00..fb937556e032 100644
--- a/net-misc/i2pd/files/i2pd.confd
+++ b/net-misc/i2pd/files/i2pd.confd
@@ -2,5 +2,8 @@ I2PD_USER="${I2PD_USER:-i2pd}"
I2PD_GROUP="${I2PD_GROUP:-i2pd}"
I2PD_LOG="/var/log/i2pd.log"
I2PD_PID="/var/run/i2pd.pid"
+I2PD_CFGDIR="/etc/i2pd/"
# Options to i2pd
-I2PDOPTIONS="--conf=/etc/i2pd.conf"
+I2PDOPTIONS="--conf=${I2PD_CFGDIR}i2pd.conf --tunconf=${I2PD_CFGDIR}tunnels.cfg"
+# for debugging purposes
+#I2PDOPTIONS="--conf=${I2PD_CFGDIR}i2pd.conf --tunconf=${I2PD_CFGDIR}tunnels.cfg --log=file --logfile=${I2PD_LOG}"
diff --git a/net-misc/i2pd/files/i2pd.initd b/net-misc/i2pd/files/i2pd.initd
index cc3d2349b970..1c12209246a7 100644
--- a/net-misc/i2pd/files/i2pd.initd
+++ b/net-misc/i2pd/files/i2pd.initd
@@ -11,14 +11,14 @@ depend() {
start() {
ebegin "Starting ${SVCNAME}"
- checkpath -f "${I2PD_LOG}" -o "${I2PD_USER}:${I2PD_GROUP}"
- checkpath -f "${I2PD_PID}" -o "${I2PD_USER}:${I2PD_GROUP}"
- start-stop-daemon -S -b -u "${I2PD_USER}:${I2PD_GROUP}" /usr/bin/i2pd -- ${I2PDOPTIONS}
+ checkpath -f "${I2PD_LOG}" -o "${I2PD_USER}:${I2PD_GROUP}"
+ checkpath -f "${I2PD_PID}" -o "${I2PD_USER}:${I2PD_GROUP}"
+ start-stop-daemon -S -b -u "${I2PD_USER}:${I2PD_GROUP}" /usr/bin/i2pd -- ${I2PDOPTIONS}
eend $?
}
stop() {
ebegin "Stopping ${SVCNAME}"
- start-stop-daemon -K -p "${I2PD_PID}"
+ start-stop-daemon -K -p "${I2PD_PID}" -R SIGTERM/20 SIGKILL/20 -P
eend $?
}
diff --git a/net-misc/i2pd/files/i2pd.service b/net-misc/i2pd/files/i2pd.service
index 7f44cde2b2f3..2eee094eee2d 100644
--- a/net-misc/i2pd/files/i2pd.service
+++ b/net-misc/i2pd/files/i2pd.service
@@ -11,7 +11,7 @@ Group=i2pd
PermissionsStartOnly=yes
ExecStartPre=/bin/touch /var/run/i2pd.pid /var/log/i2pd.log
ExecStartPre=/bin/chown i2pd:i2pd /run/i2pd.pid /var/log/i2pd.log
-ExecStart=/usr/lib/i2pd/i2p --conf=/etc/i2pd.conf
+ExecStart=/usr/lib/i2pd/i2p --conf=/etc/i2pd/i2pd.conf --tunconf=/etc/i2pd/tunnels.cfg
[Install]
WantedBy=multi-user.target
diff --git a/net-misc/i2pd/files/tunnels.cfg b/net-misc/i2pd/files/tunnels.cfg
new file mode 100644
index 000000000000..e35504ad5ee7
--- /dev/null
+++ b/net-misc/i2pd/files/tunnels.cfg
@@ -0,0 +1,17 @@
+# outgoing tunnel sample, to remote service
+# mandatory parameters:
+# * type -- always "client"
+# * port -- local port to listen to
+# * destination -- i2p hostname
+# optional parameters (may be omitted)
+# * keys -- our identity, if unset, will be generated on every startup,
+# if set and file missing, keys will be generated and placed to this file
+# * address -- local interface to bind
+# * signaturetype -- signature type for new destination. 0,1 or 7
+[IRC]
+type = client
+address = 127.0.0.1
+port = 6668
+destination = irc.postman.i2p
+keys = irc-keys.dat
+signaturetype = 1