summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-02 00:47:47 +0100
committerSam James <sam@gentoo.org>2023-06-02 01:24:32 +0100
commit709240c79986e92294e0329e66b99f20dd05b1de (patch)
tree286694c06a0648a57b624f7da6e9c59f4a251289 /net-misc/ntp
parentnet-misc/ntp: drop 4.2.8_p15-r2 (diff)
downloadgentoo-709240c79986e92294e0329e66b99f20dd05b1de.tar.gz
gentoo-709240c79986e92294e0329e66b99f20dd05b1de.tar.bz2
gentoo-709240c79986e92294e0329e66b99f20dd05b1de.zip
net-misc/ntp: add 4.2.8_p16
We don't need to generate our own man pages, see: ``` * CMP: =net-misc/ntp-4.2.8_p15-r6 with net-misc/ntp-4.2.8_p16/image * FILES:-usr/share/man/man8/keygen.8.xz * FILES:-usr/share/man/man8/ntpd.8.xz * FILES:-usr/share/man/man8/ntpdate.8.xz * FILES:-usr/share/man/man8/ntpdc.8.xz * FILES:-usr/share/man/man8/ntpdsim.8.xz * FILES:-usr/share/man/man8/ntpq.8.xz * FILES:-usr/share/man/man8/ntptime.8.xz * FILES:-usr/share/man/man8/ntptrace.8.xz * FILES:-usr/share/man/man8/tickadj.8.xz * SIZE: 18.14MiB -> 18.17MiB, 305 -> 296 files * ------> FILES(-9) SIZE(+0.16%) ``` ... but man pages remain in man1. Bug: https://bugs.gentoo.org/904337 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/ntp')
-rw-r--r--net-misc/ntp/Manifest1
-rw-r--r--net-misc/ntp/ntp-4.2.8_p16.ebuild158
2 files changed, 159 insertions, 0 deletions
diff --git a/net-misc/ntp/Manifest b/net-misc/ntp/Manifest
index c61825354c75..8d4e8fc54354 100644
--- a/net-misc/ntp/Manifest
+++ b/net-misc/ntp/Manifest
@@ -1,2 +1,3 @@
DIST ntp-4.2.8p15-manpages.tar.xz 25700 BLAKE2B 6a225bc19dcebee31cb8e0d621963863d567a882655b57be8b65a16f9d3dd138787c7c6b9ff08853306f2e9b11d65cb76e3215cc5b2262a91c411d437974fc18 SHA512 21721550864b4e7e91bf20ca894109253439b737799dfc803e1496b3454199f34646f40e0156c08a39d5914e5a92f35908cec0245e1e2627c75c0e64939ba028
DIST ntp-4.2.8p15.tar.gz 7015970 BLAKE2B 5697d6623d79686f9ca9ad907172bf942383067d1e9817117d20db042e9f7410644f236f1a0d77ab6bf6ec468476e12ea65b494a28f0dd8674bf08fc8875cfef SHA512 f5ad765e45fc302263dd40e94c287698fd235b94f3684e49f1d5d09d7d8bdd6b8c0fb96ecdabffea3d233e1e79b3c9687b76dc204ba76bad3f554682f4a97794
+DIST ntp-4.2.8p16.tar.gz 7084978 BLAKE2B a6cd6f56da7fda85be70f1293674fdab76140608407b5bda422049a49133694803cf3d38174a329d75f599fcce0ff899c00b47a18b22a1b801e495b476445a3e SHA512 0b4a3336def620d3ab2f06dacf8621e848167e35657c0a1206eca178a7541dd8730071bd7a0a8dea2c4682c4f38d31c3772d01093c26fd5a4395e37a86e770e2
diff --git a/net-misc/ntp/ntp-4.2.8_p16.ebuild b/net-misc/ntp/ntp-4.2.8_p16.ebuild
new file mode 100644
index 000000000000..89ee3f382279
--- /dev/null
+++ b/net-misc/ntp/ntp-4.2.8_p16.ebuild
@@ -0,0 +1,158 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic systemd tmpfiles
+
+MY_P=${P/_p/p}
+DESCRIPTION="Network Time Protocol suite/programs"
+HOMEPAGE="https://www.ntp.org/"
+SRC_URI="https://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-${PV:0:3}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="HPND BSD ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="caps debug ipv6 openntpd parse-clocks readline samba selinux snmp ssl +threads vim-syntax zeroconf"
+
+DEPEND="
+ >=dev-libs/libevent-2.0.9:=[threads(+)?]
+ readline? ( >=sys-libs/readline-4.1:= )
+ kernel_linux? ( caps? ( sys-libs/libcap ) )
+ zeroconf? ( net-dns/avahi[mdnsresponder-compat] )
+ snmp? ( net-analyzer/net-snmp )
+ ssl? ( dev-libs/openssl:= )
+ parse-clocks? ( net-misc/pps-tools )
+"
+RDEPEND="
+ ${DEPEND}
+ acct-group/ntp
+ acct-user/ntp
+ selinux? ( sec-policy/selinux-ntp )
+ vim-syntax? ( app-vim/ntp-syntax )
+ !net-misc/ntpsec
+ !openntpd? ( !net-misc/openntpd )
+"
+BDEPEND="
+ acct-group/ntp
+ acct-user/ntp
+ virtual/pkgconfig
+"
+PDEPEND="openntpd? ( net-misc/openntpd )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.2.8-ipc-caps.patch # bug #533966
+ "${FILESDIR}"/${PN}-4.2.8-sntp-test-pthreads.patch # bug #563922
+ "${FILESDIR}"/${PN}-4.2.8_p14-add_cap_ipc_lock.patch # bug #711530
+ "${FILESDIR}"/${PN}-4.2.8_p15-configure-clang16.patch
+)
+
+src_prepare() {
+ default
+
+ # Make sure every build uses the same install layout, bug #539092
+ find sntp/loc/ -type f '!' -name legacy -delete || die
+
+ # bug #622754
+ eautoreconf
+
+ # Disable pointless checks.
+ touch .checkChangeLog .gcc-warning FRC.html html/.datecheck || die
+}
+
+src_configure() {
+ # bug #264109
+ append-cppflags -D_GNU_SOURCE
+
+ # avoid libmd5/libelf
+ export ac_cv_search_MD5Init=no ac_cv_header_md5_h=no
+ export ac_cv_lib_elf_nlist=no
+ # blah, no real configure options #176333
+ export ac_cv_header_dns_sd_h=$(usex zeroconf)
+ export ac_cv_lib_dns_sd_DNSServiceRegister=${ac_cv_header_dns_sd_h}
+ # Unity builds, we don't really need support for it, bug #804109
+ export PATH_RUBY=/bin/false
+
+ local myeconfargs=(
+ --with-lineeditlibs=readline,edit,editline
+ --with-yielding-select
+ --disable-local-libevent
+
+ # Increase the default memlimit from 32MiB to 128MiB, bug #533232
+ --with-memlock=256
+
+ $(use_enable caps linuxcaps)
+ $(use_enable parse-clocks)
+ $(use_enable ipv6)
+ $(use_enable debug debugging)
+ $(use_with readline lineeditlibs readline)
+ $(use_enable samba ntp-signd)
+ $(use_with snmp ntpsnmpd)
+ $(use_with ssl crypto)
+ $(use_enable threads thread-support)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ # Move ntpd/ntpdate to sbin, bug #66671
+ dodir /usr/sbin
+ mv "${ED}"/usr/bin/{ntpd,ntpdate} "${ED}"/usr/sbin/ || die "move to sbin"
+
+ dodoc INSTALL WHERE-TO-START
+
+ insinto /etc
+ doins "${FILESDIR}"/ntp.conf
+
+ #bug #524726
+ use ipv6 || sed -i '/^restrict .*::1/d' "${ED}"/etc/ntp.conf
+
+ newinitd "${FILESDIR}"/ntpd.rc-r2 ntpd
+ newconfd "${FILESDIR}"/ntpd.confd ntpd
+ newinitd "${FILESDIR}"/ntp-client.rc ntp-client
+ newconfd "${FILESDIR}"/ntp-client.confd ntp-client
+ newinitd "${FILESDIR}"/sntp.rc sntp
+ newconfd "${FILESDIR}"/sntp.confd sntp
+ if ! use caps ; then
+ sed -i "s|-u ntp:ntp||" "${ED}"/etc/conf.d/ntpd || die
+ fi
+ sed -i "s:/usr/bin:/usr/sbin:" "${ED}"/etc/init.d/ntpd || die
+
+ if use openntpd ; then
+ cd "${ED}" || die
+ rm usr/sbin/ntpd || die
+ rm etc/{conf,init}.d/ntpd || die
+ rm usr/share/man/*/ntpd.8 || die
+ else
+ newtmpfiles "${FILESDIR}"/ntp.tmpfiles ntp.conf
+ systemd_newunit "${FILESDIR}"/ntpd.service-r2 ntpd.service
+ if use caps ; then
+ sed -i '/ExecStart/ s|$| -u ntp:ntp|' \
+ "${D}$(systemd_get_systemunitdir)"/ntpd.service \
+ || die
+ fi
+ systemd_enable_ntpunit 60-ntpd ntpd.service
+ fi
+
+ systemd_newunit "${FILESDIR}"/ntpdate.service-r2 ntpdate.service
+ systemd_install_serviced "${FILESDIR}"/ntpdate.service.conf
+ systemd_newunit "${FILESDIR}"/sntp.service-r3 sntp.service
+ systemd_install_serviced "${FILESDIR}"/sntp.service.conf
+}
+
+pkg_postinst() {
+ if ! use openntpd; then
+ tmpfiles_process ntp.conf
+ fi
+
+ if grep -qs '^[^#].*notrust' "${EROOT}"/etc/ntp.conf ; then
+ eerror "The notrust option was found in your /etc/ntp.conf!"
+ ewarn "If your ntpd starts sending out weird responses,"
+ ewarn "then make sure you have keys properly setup and see"
+ ewarn "https://bugs.gentoo.org/41827"
+ fi
+}