summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/orbited
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/orbited')
-rw-r--r--net-misc/orbited/Manifest1
-rw-r--r--net-misc/orbited/files/orbited.cfg42
-rw-r--r--net-misc/orbited/files/orbited.init31
-rw-r--r--net-misc/orbited/metadata.xml10
-rw-r--r--net-misc/orbited/orbited-0.7.10-r1.ebuild37
-rw-r--r--net-misc/orbited/orbited-0.7.10-r2.ebuild37
6 files changed, 158 insertions, 0 deletions
diff --git a/net-misc/orbited/Manifest b/net-misc/orbited/Manifest
new file mode 100644
index 000000000000..c4fbcc995e06
--- /dev/null
+++ b/net-misc/orbited/Manifest
@@ -0,0 +1 @@
+DIST orbited-0.7.10.tar.gz 168647 SHA256 71e7627a485fbb6184bb0b4c894ee4dcc74cc970d04888f908d0ca2dec69332d SHA512 6783bbe687a5191f773e723f068651a6cd55baa39a825dfa16e27b3c51a39f32dcef04f61b2b58756514ee99e39c1cbe450ae24e5d3835e95ace9b59403b9376 WHIRLPOOL 588ede0193a2e6f04453568974a6ec59216f2b6fbd625dc3e7c134131c10ec2e5901f5136f20ea6d683504593c2e6ce432501953714f82b8533f7708ff1434d5
diff --git a/net-misc/orbited/files/orbited.cfg b/net-misc/orbited/files/orbited.cfg
new file mode 100644
index 000000000000..5379c47999e0
--- /dev/null
+++ b/net-misc/orbited/files/orbited.cfg
@@ -0,0 +1,42 @@
+# Example Orbited Configuration file
+
+[global]
+reactor=select
+# reactor=kqueue
+# reactor=epoll
+session.ping_interval = 40
+session.ping_timeout = 30
+# once the sockets are open, orbited will drop its privileges to this user.
+user=orbited
+
+[listen]
+http://:8000
+#stomp://:61613
+# uncomment to enable SSL on port 8043 using given .key and .crt files
+#https://:8043
+#
+#[ssl]
+#key=orbited.key
+#crt=orbited.crt
+
+[static]
+
+[access]
+localhost:8000 -> irc.freenode.net:6667
+* -> localhost:4747
+#* -> localhost:61613
+
+[logging]
+debug=STDERR,debug.log
+info=STDERR,info.log
+access=STDERR,info.log
+warn=STDERR,error.log
+error=STDERR,error.log
+
+#Don't enable debug by default
+enabled.default=info,access,warn,error
+
+# Turn debug on for the "Proxy" logger
+[loggers]
+#Proxy=debug,info,access,warn,error
+
diff --git a/net-misc/orbited/files/orbited.init b/net-misc/orbited/files/orbited.init
new file mode 100644
index 000000000000..28a9a6c03aed
--- /dev/null
+++ b/net-misc/orbited/files/orbited.init
@@ -0,0 +1,31 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+ use dns
+}
+
+checkconfig() {
+ if [ ! -f "/etc/orbited.cfg" ] ; then
+ eerror "No /etc/orbited.cfg file exists!"
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting orbited..."
+ /usr/bin/orbited --config=/etc/orbited.cfg >/dev/null 2>&1 &
+ pid=$!
+ echo $pid > /var/run/orbited.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping orbited..."
+ start-stop-daemon --stop --quiet --pidfile=/var/run/orbited.pid --retry 20
+ eend $?
+}
+
diff --git a/net-misc/orbited/metadata.xml b/net-misc/orbited/metadata.xml
new file mode 100644
index 000000000000..45dda01a91ea
--- /dev/null
+++ b/net-misc/orbited/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">orbited</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/orbited/orbited-0.7.10-r1.ebuild b/net-misc/orbited/orbited-0.7.10-r1.ebuild
new file mode 100644
index 000000000000..26ca05dc1e3c
--- /dev/null
+++ b/net-misc/orbited/orbited-0.7.10-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit distutils
+
+DESCRIPTION="Real-time communication for the browser"
+HOMEPAGE="http://orbited.org"
+SRC_URI="mirror://pypi/o/${PN}/${P}.tar.gz"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/demjson
+ >=dev-python/morbid-0.8.4
+ dev-python/stomper
+ dev-python/twisted-core
+ dev-python/twisted-web"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ distutils_src_install
+ insinto /etc
+ doins "${FILESDIR}/orbited.cfg" || die
+ newinitd "${FILESDIR}/orbited.init" orbited || die
+}
diff --git a/net-misc/orbited/orbited-0.7.10-r2.ebuild b/net-misc/orbited/orbited-0.7.10-r2.ebuild
new file mode 100644
index 000000000000..89c57c034ce7
--- /dev/null
+++ b/net-misc/orbited/orbited-0.7.10-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Real-time communication for the browser."
+HOMEPAGE="http://orbited.org"
+SRC_URI="mirror://pypi/o/${PN}/${P}.tar.gz"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/demjson[${PYTHON_USEDEP}]
+ >=dev-python/morbid-0.8.4[${PYTHON_USEDEP}]
+ dev-python/stomper[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/twisted-web[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ distutils-r1_src_install
+ insinto /etc
+ doins "${FILESDIR}/orbited.cfg" || die
+ newinitd "${FILESDIR}/orbited.init" orbited || die
+}