summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/samplicator/samplicator-1.3.6.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/samplicator/samplicator-1.3.6.ebuild')
-rw-r--r--net-misc/samplicator/samplicator-1.3.6.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-misc/samplicator/samplicator-1.3.6.ebuild b/net-misc/samplicator/samplicator-1.3.6.ebuild
new file mode 100644
index 000000000000..e8ac460e1944
--- /dev/null
+++ b/net-misc/samplicator/samplicator-1.3.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils user
+
+DESCRIPTION="UDP packets forwarder and duplicator"
+HOMEPAGE="http://${PN}.googlecode.com/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="Artistic GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+pkg_setup() {
+ # Add samplicator group and user to system
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /etc/${PN} ${PN}
+}
+
+src_install() {
+ # Install and copy documentation
+ default
+
+ # Install Gentoo init script and its config
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.conf ${PN}
+
+ # Install manual page
+ doman "${FILESDIR}"/${PN}.8
+}
+
+pkg_postinst() {
+ ewarn ""
+ ewarn "Don't specify the receiver on the command line, because it will get all packets."
+ ewarn "Instead of this, specify it in a config file; defined in such way it will only get packets with a matching source."
+ ewarn ""
+
+ einfo "For every receiver type create a file in directory /etc/${PN} (see example below)"
+ einfo "and specify the path to it in variable CONFIG of the corresponding initscript config file in /etc/conf.d/"
+ einfo ""
+ einfo "Receiver config examples: "
+ einfo ""
+ einfo " /etc/${PN}/netflow:"
+ einfo " 10.0.0.0/255.0.0.0:1.1.1.1/9996 2.2.2.2/9996 3.3.3.3/9996"
+ einfo ""
+ einfo " /etc/${PN}/syslog:"
+ einfo " 10.0.0.0/255.255.0.0:2.2.2.2/514 3.3.3.3/514"
+ einfo ""
+ einfo " /etc/${PN}/snmp:"
+ einfo " 10.0.0.0/255.255.255.255:3.3.3.3/162"
+}