summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2024-08-23 21:55:47 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-08-30 10:33:05 +0300
commite12ade455b9e37ff0e60123086bcd195ba3309b3 (patch)
treec8233b5805ca60b3ea355cd8c7ad341c49309f5a /net-misc/tinyssh
parentnet-misc/tinyssh: synchronize live ebuild (diff)
downloadgentoo-e12ade455b9e37ff0e60123086bcd195ba3309b3.tar.gz
gentoo-e12ade455b9e37ff0e60123086bcd195ba3309b3.tar.bz2
gentoo-e12ade455b9e37ff0e60123086bcd195ba3309b3.zip
net-misc/tinyssh: fix include path to sodium
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/38273 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-misc/tinyssh')
-rw-r--r--net-misc/tinyssh/tinyssh-20240101-r2.ebuild (renamed from net-misc/tinyssh/tinyssh-20240101-r1.ebuild)5
-rw-r--r--net-misc/tinyssh/tinyssh-99999999.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/net-misc/tinyssh/tinyssh-20240101-r1.ebuild b/net-misc/tinyssh/tinyssh-20240101-r2.ebuild
index 442fb8e5f171..db7411fdc4a4 100644
--- a/net-misc/tinyssh/tinyssh-20240101-r1.ebuild
+++ b/net-misc/tinyssh/tinyssh-20240101-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit systemd toolchain-funcs
@@ -46,10 +46,11 @@ src_compile() {
if use sodium
then
+ # -I${includedir}/sodium needed as tinyssh uses `#include "crypto_auth_hmacsha256.h"` rather than `#include <sodium.h>`
emake \
CC="$(tc-getCC)" \
LIBS="$("${PKG_CONFIG}" --libs libsodium)" \
- CFLAGS="${CFLAGS} $("${PKG_CONFIG}" --cflags libsodium)" \
+ CFLAGS="${CFLAGS} $("${PKG_CONFIG}" --cflags libsodium) -I$("${PKG_CONFIG}" --variable=includedir libsodium)/sodium/" \
LDFLAGS="${LDFLAGS}"
else
emake CC="$(tc-getCC)"
diff --git a/net-misc/tinyssh/tinyssh-99999999.ebuild b/net-misc/tinyssh/tinyssh-99999999.ebuild
index 0edea200702b..9d2ed3e6c433 100644
--- a/net-misc/tinyssh/tinyssh-99999999.ebuild
+++ b/net-misc/tinyssh/tinyssh-99999999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit systemd toolchain-funcs
@@ -45,10 +45,11 @@ src_compile() {
if use sodium
then
+ # -I${includedir}/sodium needed as tinyssh uses `#include "crypto_auth_hmacsha256.h"` rather than `#include <sodium.h>`
emake \
CC="$(tc-getCC)" \
LIBS="$("${PKG_CONFIG}" --libs libsodium)" \
- CFLAGS="${CFLAGS} $("${PKG_CONFIG}" --cflags libsodium)" \
+ CFLAGS="${CFLAGS} $("${PKG_CONFIG}" --cflags libsodium) -I$("${PKG_CONFIG}" --variable=includedir libsodium)/sodium/" \
LDFLAGS="${LDFLAGS}"
else
emake CC="$(tc-getCC)"