summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-22 08:14:26 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-22 08:19:00 +0200
commitfdbed3a4250c4c64e08d229eda636df0cbbbffc5 (patch)
tree496b1070f6b50fb98eee4701e43e607e2fb23289 /net-misc/tuba
parentdev-ruby/autoprefixer-rails: enable ruby33 (diff)
downloadgentoo-fdbed3a4250c4c64e08d229eda636df0cbbbffc5.tar.gz
gentoo-fdbed3a4250c4c64e08d229eda636df0cbbbffc5.tar.bz2
gentoo-fdbed3a4250c4c64e08d229eda636df0cbbbffc5.zip
net-misc/tuba: Bump to 0.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-misc/tuba')
-rw-r--r--net-misc/tuba/Manifest1
-rw-r--r--net-misc/tuba/tuba-0.8.0.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/net-misc/tuba/Manifest b/net-misc/tuba/Manifest
index 16968ac79828..6f1e9f9a29bd 100644
--- a/net-misc/tuba/Manifest
+++ b/net-misc/tuba/Manifest
@@ -1,2 +1,3 @@
DIST Tuba-0.6.3.gh.tar.gz 1124191 BLAKE2B b5a7107c94d9adf89fc02224891c12b71fc2b640e962006fbfcf1d0673e5f3f73b11423b6d66e8952e2aef122ade6a57607cced5d4707bd91193157fd561ce11 SHA512 b987b9b8434a0abd086a3197154b27bd4a0bca69df07bcec26c59a2da51cf447943e7a05a83529a99670f2b1b7ea1a7dce1da39148844d23706940f3a0a423d8
DIST Tuba-0.7.2.gh.tar.gz 1388074 BLAKE2B 6785225612db57592f351d2e0937b9578f4861230e999190f64b1068f344624ad41e69afcb199913c0a8e5b5eadb1438b7c6c48746b3582e1978afe6e09cde32 SHA512 bbabadbf2131233a737d6ccded50fde0af44330c7a69d1e0688a6ef42fe548826cacbe714a61df78dbe5afe867940b1dbae868efc3dfae707342b9f7ce5a9835
+DIST Tuba-0.8.0.gh.tar.gz 1730326 BLAKE2B 7f1e716f26c758e06cb0f532f780855759e637dfdfbed80d4a5bd2b92b68ff1f925141a71ad1f588d55f1e32d0c750ce58fd431ca429cd5dc65f0e5f059d8b60 SHA512 d768fe86678c66af267afe2f0d4c7449dfa61a44d7ba43c538e6ad6beb029a87f1f35f280251870f5df612d55f2f3170bb2abee99abcf559bd7a901ede2986ec
diff --git a/net-misc/tuba/tuba-0.8.0.ebuild b/net-misc/tuba/tuba-0.8.0.ebuild
new file mode 100644
index 000000000000..e75bb85f2c86
--- /dev/null
+++ b/net-misc/tuba/tuba-0.8.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson optfeature vala
+
+MY_P=${P^}
+DESCRIPTION="Browse the Fediverse (GTK client)"
+HOMEPAGE="
+ https://tuba.geopjr.dev/
+ https://github.com/GeopJr/Tuba/
+"
+SRC_URI="
+ https://github.com/GeopJr/Tuba/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3 CC-BY-SA-4.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+# TODO: optional dep on libspelling-1
+DEPEND="
+ app-crypt/libsecret[introspection,vala]
+ >=dev-libs/glib-2.76.0:2
+ dev-libs/icu:=
+ >=dev-libs/json-glib-1.4.4[introspection]
+ >=dev-libs/libgee-0.8.5:0.8[introspection]
+ dev-libs/libxml2
+ >=gui-libs/gtk-4.13.4:4[gstreamer,introspection]
+ >=gui-libs/libadwaita-1.5:1[introspection,vala]
+ >=gui-libs/gtksourceview-5.6.0:5[introspection,vala]
+ net-libs/libsoup:3.0[introspection,vala]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ $(vala_depend)
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ # disable calling updaters (see pkg_post*)
+ -Ddistro=true
+ # not packaged
+ -Dclapper=false
+ )
+
+ vala_setup
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ dosym dev.geopjr.Tuba /usr/bin/tuba
+}
+
+pkg_postinst() {
+ optfeature "WebP image support" gui-libs/gdk-pixbuf-loader-webp
+
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}