summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-17 22:47:30 +0100
committerSam James <sam@gentoo.org>2022-10-17 22:47:30 +0100
commit7ef76bbf5cdac2c3da2bd8e3ba295ad1e8855870 (patch)
tree91bffa4ed5d82d274403becd459cf0e31a8d33c6 /net-misc/whois
parentnet-misc/whois: sync live (diff)
downloadgentoo-7ef76bbf5cdac2c3da2bd8e3ba295ad1e8855870.tar.gz
gentoo-7ef76bbf5cdac2c3da2bd8e3ba295ad1e8855870.tar.bz2
gentoo-7ef76bbf5cdac2c3da2bd8e3ba295ad1e8855870.zip
net-misc/whois: add 5.5.14
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/whois')
-rw-r--r--net-misc/whois/Manifest1
-rw-r--r--net-misc/whois/whois-5.5.14.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/net-misc/whois/Manifest b/net-misc/whois/Manifest
index 0f47f345127c..71c9ea9aae3a 100644
--- a/net-misc/whois/Manifest
+++ b/net-misc/whois/Manifest
@@ -1 +1,2 @@
DIST whois_5.5.13.tar.xz 87384 BLAKE2B 6ce90ad907c4ea79301adbcda5a402344df9f283ac258a3186f5c405e0abfb97f603f3f163652f1cf03a1fc60290b8f9f54b509bf7d9fd3cec12189eeeaaffe5 SHA512 b4a70cc6d58133287d70775ecd8173c255f800362639a3e2dea0d3d56c35405b7fc93c4c220cc50cbd15ae5ae402a59bd15f99e98a7cccb314f82a205aa7ee61
+DIST whois_5.5.14.tar.xz 87480 BLAKE2B 868c9dc968581535ee2b56a6293f634e2c8dc6c00703a45d4ca4f0ce6769786ee4921bd66f3a470b2a7f31808db2971b284c23b76b608bff1edbb7bbe37f892a SHA512 f190d488d7bd68717c0a83ca85709fad09c33b619c46d7e0dd12e79621fdba56b9d43480c25ef3c9df2f6ade0ee72d692bfc5d0bd96839ef92194004313d1cc6
diff --git a/net-misc/whois/whois-5.5.14.ebuild b/net-misc/whois/whois-5.5.14.ebuild
new file mode 100644
index 000000000000..4c1dfcda83b9
--- /dev/null
+++ b/net-misc/whois/whois-5.5.14.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P=${P/-/_}
+DESCRIPTION="Improved Whois Client"
+HOMEPAGE="https://github.com/rfc1036/whois"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/rfc1036/whois.git"
+else
+ SRC_URI="mirror://debian/pool/main/w/whois/${MY_P}.tar.xz"
+ #SRC_URI="https://github.com/rfc1036/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="iconv idn nls xcrypt"
+
+RDEPEND="
+ iconv? ( virtual/libiconv )
+ idn? ( net-dns/libidn2:= )
+ nls? ( virtual/libintl )
+ xcrypt? ( >=sys-libs/libxcrypt-4.1:= )
+ !xcrypt? ( virtual/libcrypt:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/xz-utils
+ >=dev-lang/perl-5
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.7.2-config-file.patch
+ "${FILESDIR}"/${PN}-5.3.0-libidn_automagic.patch
+ "${FILESDIR}"/${PN}-5.5.6-libxcrypt_automagic.patch
+)
+
+src_prepare() {
+ default
+
+ if use nls ; then
+ sed -i -e 's:#\(.*pos\):\1:' Makefile || die
+ else
+ sed -i -e '/ENABLE_NLS/s:define:undef:' config.h || die
+
+ # don't generate po files when nls is disabled (bug #419889)
+ sed -i -e '/^all:/s/ pos//' \
+ -e '/^install:/s/ install-pos//' Makefile || die
+ fi
+}
+
+src_configure() { :; } # expected no-op
+
+src_compile() {
+ unset HAVE_ICONV HAVE_LIBIDN
+
+ use iconv && export HAVE_ICONV=1
+ use idn && export HAVE_LIBIDN=1
+ use xcrypt && export HAVE_XCRYPT=1
+
+ tc-export CC
+
+ emake CFLAGS="${CFLAGS} ${CPPFLAGS}"
+}
+
+src_install() {
+ emake BASEDIR="${ED}" prefix=/usr install
+
+ insinto /etc
+ doins whois.conf
+ dodoc README debian/changelog
+}