summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-11-04 17:24:14 +1000
committerMatt Jolly <kangie@gentoo.org>2024-11-09 16:25:41 +1000
commit01ba4dc61965ef7658a24728841c04c9a1ce4871 (patch)
treea2a6b927779e5990ff87ec4589373d1d89129a63 /net-misc/zerotier
parentprofiles: mask dev-lang/starlark-rust (diff)
downloadgentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.gz
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.bz2
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.zip
*/*: update for slotted Rust
Tidyups: - $(cargo_crate_uris) - Rust BDEPENDS come from the eclass except in very rare circumstances (RUST_OPTIONAL=1) - RUST_M{AX,IN}_VER where required. - Suboptimal crate separator (`-` -> `@`) Signed-off-by: Matt Jolly <kangie@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/39218 Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'net-misc/zerotier')
-rw-r--r--net-misc/zerotier/zerotier-1.14.1-r1.ebuild (renamed from net-misc/zerotier/zerotier-1.14.1.ebuild)4
-rw-r--r--net-misc/zerotier/zerotier-1.14.2-r1.ebuild (renamed from net-misc/zerotier/zerotier-1.14.2.ebuild)4
2 files changed, 6 insertions, 2 deletions
diff --git a/net-misc/zerotier/zerotier-1.14.1.ebuild b/net-misc/zerotier/zerotier-1.14.1-r1.ebuild
index f6f30f150077..ce8818618cac 100644
--- a/net-misc/zerotier/zerotier-1.14.1.ebuild
+++ b/net-misc/zerotier/zerotier-1.14.1-r1.ebuild
@@ -380,6 +380,8 @@ declare -A GIT_CRATES=(
[temporal-sdk]='https://github.com/temporalio/sdk-core;a8150d5c7c3fc1bfd5a941fd315abff1556cd9dc;sdk-core-%commit%/sdk'
)
+RUST_OPTIONAL=1
+
inherit cargo systemd toolchain-funcs
DESCRIPTION="A software-based managed Ethernet switch for planet Earth"
@@ -407,7 +409,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="
sso? (
- virtual/rust
+ ${RUST_DEPEND}
)
"
diff --git a/net-misc/zerotier/zerotier-1.14.2.ebuild b/net-misc/zerotier/zerotier-1.14.2-r1.ebuild
index 16179d08188e..8125b3a115da 100644
--- a/net-misc/zerotier/zerotier-1.14.2.ebuild
+++ b/net-misc/zerotier/zerotier-1.14.2-r1.ebuild
@@ -381,6 +381,8 @@ declare -A GIT_CRATES=(
[temporal-sdk]='https://github.com/temporalio/sdk-core;730aadcc02767ae630e88f8f8c788a85d6bc81e6;sdk-core-%commit%/sdk'
)
+RUST_OPTIONAL=1
+
inherit cargo systemd toolchain-funcs
DESCRIPTION="A software-based managed Ethernet switch for planet Earth"
@@ -408,7 +410,7 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="
sso? (
- virtual/rust
+ ${RUST_DEPEND}
)
"