summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Privoznik <michal.privoznik@gmail.com>2024-08-30 09:47:16 +0200
committerZac Medico <zmedico@gentoo.org>2024-08-31 10:53:04 -0700
commit10ee7afe94f44465509290da003e94391e89bd2b (patch)
tree901792da6f1c4a5efa4ddc2651d0f750c34e4daa /net-misc
parentnet-misc/passt: Don't apply Makefile-2024.03.20.patch on live ebuild (diff)
downloadgentoo-10ee7afe94f44465509290da003e94391e89bd2b.tar.gz
gentoo-10ee7afe94f44465509290da003e94391e89bd2b.tar.bz2
gentoo-10ee7afe94f44465509290da003e94391e89bd2b.zip
net-misc/passt: add 2024.08.21
Signed-off-by: Michal Privoznik <michal.privoznik@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/38342 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/passt/Manifest1
-rw-r--r--net-misc/passt/passt-2024.08.21.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/passt/Manifest b/net-misc/passt/Manifest
index d1b7a339a1a1..6822119362e6 100644
--- a/net-misc/passt/Manifest
+++ b/net-misc/passt/Manifest
@@ -3,3 +3,4 @@ DIST passt-2024.04.05.tar.xz 195772 BLAKE2B 4c237aeda56455f948d4309624d171612d59
DIST passt-2024.04.26.tar.xz 196148 BLAKE2B f3a9b9d2a9fa42e0dd35894d4c92890af9935965ccfb3b1751c396080ab0482bd541fe22f09ae7b068f336f1e985b6905d2cc93987a17f243ba6ec97d880ee68 SHA512 f25b9bc695de555048f6a24ec9bb603ec6def0449227ce837b6e46f8cda5816c2450aa733257aaa349260b0b7c05b2d5580ad21010a1a45a74e9eb3027e37d98
DIST passt-2024.05.10.tar.xz 195992 BLAKE2B 9f4b680daa8103c7de0c92c01824df74e1b221a48cf7724c2c09aae13a3575bdc529eeca01d5015095c51194045e1019bbdf38cc7ef2333d61eaa03b4e0249ae SHA512 04add1113ffbc98d61b7c63352899505d8f19bbdf937a0c025726813163ec7fc31abdb94c12ceefed9b49f18b388acc0687298bce8ba156bbb044d1b1bcdaee3
DIST passt-2024.06.07.tar.xz 198360 BLAKE2B 378d4b18f245309fde54b244ffc435afb417d9d9711247234632ba0ae8dea35cac639c7674e6a6be008a678262af74a1dbe960477088d0b75045e6372d329488 SHA512 103955058c9a4e83264d3f65e3ff6d1a5e8a83b15f2fc73cba45101304fe79ab3c449ce2dc6add398a27f9d6556d5f902cf083223ed5e27228a0bbb506559cf0
+DIST passt-2024.08.21.tar.xz 198360 BLAKE2B 378d4b18f245309fde54b244ffc435afb417d9d9711247234632ba0ae8dea35cac639c7674e6a6be008a678262af74a1dbe960477088d0b75045e6372d329488 SHA512 103955058c9a4e83264d3f65e3ff6d1a5e8a83b15f2fc73cba45101304fe79ab3c449ce2dc6add398a27f9d6556d5f902cf083223ed5e27228a0bbb506559cf0
diff --git a/net-misc/passt/passt-2024.08.21.ebuild b/net-misc/passt/passt-2024.08.21.ebuild
new file mode 100644
index 000000000000..056444e46eba
--- /dev/null
+++ b/net-misc/passt/passt-2024.08.21.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="User-mode networking daemons for VMs and namespaces, replacement for Slirp"
+HOMEPAGE="https://passt.top/"
+
+RELEASE_COMMIT="8a83b53"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://passt.top/passt"
+else
+ SRC_URI="https://passt.top/passt/snapshot/passt-${RELEASE_COMMIT}.tar.xz -> ${P}.tar.xz"
+ S="${WORKDIR}/${PN}-${RELEASE_COMMIT}"
+ KEYWORDS="~amd64 ~arm64 ~loong ~riscv"
+fi
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+IUSE="static"
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_compile() {
+ [[ ${PV} != 9999* ]] && export VERSION="${PV}"
+ export prefix="${EPREFIX}/usr" docdir="${EPREFIX}/usr/share/doc/${P}"
+
+ emake $(usev static)
+}