summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-12-28 15:14:41 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-12-28 15:22:13 +0100
commit1be8890c6d5237188c87d3fdcf988c537d7f68b6 (patch)
tree37afb6c906df0009dfdba3b401c053bd393d1f02 /net-misc
parentx11-drivers/xf86-video-openchrome: Fix build with gcc-10 (diff)
downloadgentoo-1be8890c6d5237188c87d3fdcf988c537d7f68b6.tar.gz
gentoo-1be8890c6d5237188c87d3fdcf988c537d7f68b6.tar.bz2
gentoo-1be8890c6d5237188c87d3fdcf988c537d7f68b6.zip
Move {dev-python → net-misc}/httpstat
Closes: https://bugs.gentoo.org/761478 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/httpstat/Manifest1
-rw-r--r--net-misc/httpstat/files/httpstat-1.2.1-gentoo-tests.patch31
-rw-r--r--net-misc/httpstat/httpstat-1.3.0.ebuild28
-rw-r--r--net-misc/httpstat/metadata.xml13
4 files changed, 73 insertions, 0 deletions
diff --git a/net-misc/httpstat/Manifest b/net-misc/httpstat/Manifest
new file mode 100644
index 000000000000..89394e69be18
--- /dev/null
+++ b/net-misc/httpstat/Manifest
@@ -0,0 +1 @@
+DIST httpstat-1.3.0.tar.gz 97358 BLAKE2B e80a3bd6a6bf7dec1e045e39e9b4491cb81623fa432e32f238fedb71a97fcbd3c362d3211b5cee85e8ed293bc7493d8eb262a0821e473f0a7c8df3f2b8c6fa3e SHA512 6620f7d2da8740da9febdc5d0a177890cc5e85a3a41445c3182f6a8906cad05a475b7547737e60331957a5f48e668194d9592f4e53005a5666ef99b704afbc91
diff --git a/net-misc/httpstat/files/httpstat-1.2.1-gentoo-tests.patch b/net-misc/httpstat/files/httpstat-1.2.1-gentoo-tests.patch
new file mode 100644
index 000000000000..0fcb6523e6e1
--- /dev/null
+++ b/net-misc/httpstat/files/httpstat-1.2.1-gentoo-tests.patch
@@ -0,0 +1,31 @@
+- Testscript doesn't need to run tests for multiple python implementations,
+ PM will take care of that.
+
+- Disabling test which requires specific locales.
+
+--- a/httpstat_test.sh
++++ b/httpstat_test.sh
+@@ -19,8 +19,7 @@ function title() {
+ http_url="google.com"
+ https_url="https://http2.akamai.com"
+
+-for pybin in python python3; do
+-#for pybin in python; do
++for pybin in python; do
+ echo
+ echo "# Test in $pybin"
+
+@@ -40,9 +39,9 @@ for pybin in python python3; do
+ main_silent $https_url
+ assert_exit 0
+
+- title "comma decimal language (ru_RU)"
+- LC_ALL=ru_RU main_silent $http_url
+- assert_exit 0
++ #title "comma decimal language (ru_RU)"
++ #LC_ALL=ru_RU main_silent $http_url
++ #assert_exit 0
+
+ title "HTTPSTAT_DEBUG"
+ HTTPSTAT_DEBUG=true main $http_url | grep -q 'HTTPSTAT_DEBUG=true'
+
diff --git a/net-misc/httpstat/httpstat-1.3.0.ebuild b/net-misc/httpstat/httpstat-1.3.0.ebuild
new file mode 100644
index 000000000000..975c753128f4
--- /dev/null
+++ b/net-misc/httpstat/httpstat-1.3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="httpstat visualizes cURL statistics in a way of beauty and clarity"
+HOMEPAGE="https://github.com/reorx/httpstat"
+SRC_URI="https://github.com/reorx/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="net-misc/curl:*"
+
+# Requires access to google.com and http2.akamai.com
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.2.1-gentoo-tests.patch )
+
+python_test() {
+ ./httpstat_test.sh || die
+}
diff --git a/net-misc/httpstat/metadata.xml b/net-misc/httpstat/metadata.xml
new file mode 100644
index 000000000000..6a6902f9156c
--- /dev/null
+++ b/net-misc/httpstat/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>whissi@gentoo.org</email>
+ <name>Thomas Deutschmann</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/reorx/httpstat/issues</bugs-to>
+ <remote-id type="github">reorx/httpstat</remote-id>
+ <remote-id type="pypi">httpstat</remote-id>
+ </upstream>
+</pkgmetadata>