summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-24 07:30:16 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-24 07:59:57 +0100
commit4086e2e5c61b8338a853460eed28e3fc2feebd6d (patch)
tree52179193bab6f84d20430b1a04f570b8b9bf1415 /net-misc
parentdev-python/ensurepip-setuptools: Bump to 69.0.3 (diff)
downloadgentoo-4086e2e5c61b8338a853460eed28e3fc2feebd6d.tar.gz
gentoo-4086e2e5c61b8338a853460eed28e3fc2feebd6d.tar.bz2
gentoo-4086e2e5c61b8338a853460eed28e3fc2feebd6d.zip
net-misc/tuba: Bump to 0.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/tuba/Manifest1
-rw-r--r--net-misc/tuba/tuba-0.6.1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/net-misc/tuba/Manifest b/net-misc/tuba/Manifest
index ad4a8f87d532..35108dcf4626 100644
--- a/net-misc/tuba/Manifest
+++ b/net-misc/tuba/Manifest
@@ -1,2 +1,3 @@
DIST Tuba-0.5.0.gh.tar.gz 1022753 BLAKE2B d17fed8b93d217a26ad38e3a0a1e576e34b309e80e445dab7054c999eadd78ed579a81af3971ecbe3cdb5f29ea7fd0ae60c2fbcd65b5591a375ad2e38c476d87 SHA512 220cd905d82711dd915bb8dfebb9ca8d840cca3ca707cea0bc1b0b78c27dc2fbf37e779ebfeb4aff123bcda4d2b59786169f8645585868498cca2bb7a87904f1
DIST Tuba-0.6.0.gh.tar.gz 1098534 BLAKE2B 249b58d21683870f4fa67d19dd729de9f863b105d4798d7db06845a27c2639724393a4843793da0df77c17c528606edb9307a9cace1b3ad5c35bee93a664e174 SHA512 f578e17381d282848ea0dd10e9c9c65680be8f29bb8277e7f6afb5e2a855f5189e5db34f5db14ea88b57265d6d1911eb64db75510ea102de6cb16a4202c64f9d
+DIST Tuba-0.6.1.gh.tar.gz 1099106 BLAKE2B 69a574a0858ca083a49ed868544d16f2ae16e2fd7fa71b077efb9f3868cf24920daf8e446e4082438f7d54b18bbc1805b79576ec30a1ccd78d0076b10dc19473 SHA512 4e402330234ed8758fb171774cac3a4fa0f362c8365947223929946d27e92a870db1b42f9640b44bfcd3f6a14ccdcb74e69505a7246cb2e55c9d17b97a74faac
diff --git a/net-misc/tuba/tuba-0.6.1.ebuild b/net-misc/tuba/tuba-0.6.1.ebuild
new file mode 100644
index 000000000000..1f835348cda9
--- /dev/null
+++ b/net-misc/tuba/tuba-0.6.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson optfeature vala
+
+MY_P=${P^}
+DESCRIPTION="Browse the Fediverse (GTK client)"
+HOMEPAGE="
+ https://tuba.geopjr.dev/
+ https://github.com/GeopJr/Tuba/
+"
+SRC_URI="
+ https://github.com/GeopJr/Tuba/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3 CC-BY-SA-4.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+# TODO: optional dep on libspelling-1
+DEPEND="
+ app-crypt/libsecret[introspection]
+ >=dev-libs/glib-2.76.0:2
+ >=dev-libs/json-glib-1.4.4[introspection]
+ >=dev-libs/libgee-0.8.5:0.8[introspection]
+ dev-libs/libxml2
+ >=gui-libs/gtk-4.11.3:4[gstreamer,introspection]
+ >=gui-libs/libadwaita-1.4:1[introspection,vala]
+ >=gui-libs/gtksourceview-5.6.0:5[introspection,vala]
+ net-libs/libsoup:3.0[introspection]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ $(vala_depend)
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ # disable calling updaters (see pkg_post*)
+ -Ddistro=true
+ )
+
+ vala_setup
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ dosym dev.geopjr.Tuba /usr/bin/tuba
+}
+
+pkg_postinst() {
+ optfeature "WebP image support" gui-libs/gdk-pixbuf-loader-webp
+
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}