summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbrahmajit das <listout@protonmail.com>2022-09-17 23:10:35 +0530
committerMatt Turner <mattst88@gentoo.org>2022-09-17 14:32:43 -0400
commit73a3c3e3f24ff46a8aa81c77fa128ea7ff5fc07d (patch)
tree9efa8e47c62b72c3efec5ef81954759f54e8680f /net-misc
parentsys-auth/fprintd: fix tests (diff)
downloadgentoo-73a3c3e3f24ff46a8aa81c77fa128ea7ff5fc07d.tar.gz
gentoo-73a3c3e3f24ff46a8aa81c77fa128ea7ff5fc07d.tar.bz2
gentoo-73a3c3e3f24ff46a8aa81c77fa128ea7ff5fc07d.zip
net-misc/gnome-connections: Version bump to 43.0
Closes: https://github.com/gentoo/gentoo/pull/27308 Signed-off-by: brahmajit das <listout@protonmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gnome-connections/Manifest1
-rw-r--r--net-misc/gnome-connections/gnome-connections-43.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/net-misc/gnome-connections/Manifest b/net-misc/gnome-connections/Manifest
index a3cd4d100bc0..c02bca4c89f6 100644
--- a/net-misc/gnome-connections/Manifest
+++ b/net-misc/gnome-connections/Manifest
@@ -1 +1,2 @@
DIST gnome-connections-42.1.2.tar.xz 3987992 BLAKE2B 2cad2376c238884b069767efbcd8afae5270f576e499fa59defe2d8ec10188cfd9b263a63cd44fcbe9ceed315267807f6b106f93d1fc73092e6c5366d9daac62 SHA512 34bc8e167ccd828c1aa52728017a52282d96b607751d566e3f8a5169d6fd5ccd7c6ae04abb073946f5cf6038c7b23b3eb897e2922b6d5b914d89ac0afbbbc7ed
+DIST gnome-connections-43.0.tar.xz 3992760 BLAKE2B 16ff3cc5d587a6169fdf749ae6e743cd0fbec2b6e127c684ec42ba17da6e73d1d66ef4ef621d01452d21230dc8c99bc27678ec0364b9522b5685cec4b9c69445 SHA512 cd9d53f2e4b8e679992c5a65aa89554d1b840174ecf0f75f103265ebc2f07f63f210da4ef7e3c36af8b5fe761ec9ae4711eb92f5f40ae00225fcd9f2f8a9157b
diff --git a/net-misc/gnome-connections/gnome-connections-43.0.ebuild b/net-misc/gnome-connections/gnome-connections-43.0.ebuild
new file mode 100644
index 000000000000..ec234797b43d
--- /dev/null
+++ b/net-misc/gnome-connections/gnome-connections-43.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+inherit gnome.org gnome2-utils meson python-any-r1 vala xdg
+
+DESCRIPTION="A remote desktop client for the GNOME desktop environment"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/connections"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/gobject-introspection
+ >=dev-libs/glib-2.50:2
+ >=x11-libs/gtk+-3.22:3[introspection]
+ >=net-libs/gtk-vnc-0.4.4[pulseaudio,vala]
+ >=gui-libs/libhandy-1.6.0:1[vala]
+ >=dev-libs/libxml2-2.7.8
+ app-crypt/libsecret[vala]
+
+ >=net-misc/freerdp-2.0.0:0=
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ $(vala_depend)
+ dev-libs/glib
+ dev-util/glib-utils
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ test? (
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+ )
+"
+
+src_prepare() {
+ default
+ vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dprofile=default
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}