summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2022-07-17 19:40:43 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2022-07-17 19:40:53 +0200
commit8b3db754fd85ce1053005111b2acfea657254b8a (patch)
tree09709c27b69b1eb478fb00582f6e09f7a0d05d88 /net-misc
parentnet-misc/wget2: drop 2.0.0-r1 (diff)
downloadgentoo-8b3db754fd85ce1053005111b2acfea657254b8a.tar.gz
gentoo-8b3db754fd85ce1053005111b2acfea657254b8a.tar.bz2
gentoo-8b3db754fd85ce1053005111b2acfea657254b8a.zip
net-misc/wget2: fix libwget version and documentation build
Closes: https://bugs.gentoo.org/858575 Closes: https://bugs.gentoo.org/858578 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/wget2/wget2-2.0.1-r1.ebuild101
-rw-r--r--net-misc/wget2/wget2-9999.ebuild53
2 files changed, 124 insertions, 30 deletions
diff --git a/net-misc/wget2/wget2-2.0.1-r1.ebuild b/net-misc/wget2/wget2-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..39c4ff7aedd7
--- /dev/null
+++ b/net-misc/wget2/wget2-2.0.1-r1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="GNU Wget2 is a file and recursive website downloader"
+HOMEPAGE="https://gitlab.com/gnuwget/wget2"
+SRC_URI="mirror://gnu/wget/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/0" # subslot = libwget.so version
+KEYWORDS="~amd64 ~x86"
+IUSE="brotli bzip2 doc +gnutls gpgme +http2 idn lzip lzma openssl pcre psl +ssl test valgrind xattr zlib"
+REQUIRED_USE="valgrind? ( test )"
+
+RDEPEND="
+ brotli? ( app-arch/brotli )
+ bzip2? ( app-arch/bzip2 )
+ !gnutls? ( dev-libs/libgcrypt:= )
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ dev-libs/openssl:0=
+ )
+ )
+ gpgme? (
+ app-crypt/gpgme:=
+ dev-libs/libassuan
+ dev-libs/libgpg-error
+ )
+ http2? ( net-libs/nghttp2 )
+ idn? ( net-dns/libidn2:= )
+ lzip? ( app-arch/lzlib )
+ lzma? ( app-arch/xz-utils )
+ pcre? ( dev-libs/libpcre2 )
+ psl? ( net-libs/libpsl )
+ xattr? ( sys-apps/attr )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+ valgrind? ( dev-util/valgrind )
+"
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ default
+ sed -e "/LIBWGET_VERSION/s/2.1.0/${PV}/" \
+ -i configure.ac ||die
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ --with-plugin-support
+ --with-ssl="$(usex ssl $(usex gnutls gnutls openssl) none)"
+ --without-libidn
+ --without-libmicrohttpd
+ $(use_enable doc)
+ $(use_enable valgrind valgrind-tests)
+ $(use_enable xattr)
+ $(use_with brotli brotlidec)
+ $(use_with bzip2)
+ $(use_with gpgme)
+ $(use_with http2 libnghttp2)
+ $(use_with idn libidn2)
+ $(use_with lzip)
+ $(use_with lzma)
+ $(use_with pcre libpcre2)
+ $(use_with psl libpsl)
+ $(use_with zlib)
+
+ # Avoid calling ldconfig
+ LDCONFIG=:
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if [[ ${PV} == *9999 ]] ; then
+ if use doc ; then
+ local mpage
+ for mpage in $(find docs/man -type f -regextype grep -regex ".*\.[[:digit:]]$") ; do
+ doman ${mpage}
+ done
+ fi
+ else
+ doman docs/man/man{1/*.1,3/*.3}
+ fi
+
+ find "${D}" -type f -name '*.la' -delete || die
+ rm "${ED}"/usr/bin/${PN}_noinstall || die
+}
diff --git a/net-misc/wget2/wget2-9999.ebuild b/net-misc/wget2/wget2-9999.ebuild
index ce2c19d3ae57..e724cebc4531 100644
--- a/net-misc/wget2/wget2-9999.ebuild
+++ b/net-misc/wget2/wget2-9999.ebuild
@@ -3,17 +3,15 @@
EAPI=8
+inherit autotools git-r3
+
DESCRIPTION="GNU Wget2 is a file and recursive website downloader"
HOMEPAGE="https://gitlab.com/gnuwget/wget2"
-if [[ "${PV}" == *9999 ]] ; then
- inherit autotools git-r3
- EGIT_REPO_URI="https://gitlab.com/gnuwget/wget2.git"
-else
- SRC_URI="mirror://gnu/wget/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
+EGIT_REPO_URI="https://gitlab.com/gnuwget/wget2.git"
+
LICENSE="GPL-3"
SLOT="0/0" # subslot = libwget.so version
+KEYWORDS=""
IUSE="brotli bzip2 doc +gnutls gpgme +http2 idn lzip lzma openssl pcre psl +ssl test valgrind xattr zlib"
REQUIRED_USE="valgrind? ( test )"
@@ -44,40 +42,35 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
- doc? ( app-doc/doxygen )
+ doc? ( app-doc/doxygen[dot] )
valgrind? ( dev-util/valgrind )
"
RESTRICT="!test? ( test )"
src_unpack() {
- if [[ "${PV}" == *9999 ]] ; then
- git-r3_src_unpack
+ git-r3_src_unpack
- # We need to mess with gnulib :-/
- EGIT_REPO_URI="https://git.savannah.gnu.org/r/gnulib.git" \
- EGIT_CHECKOUT_DIR="${WORKDIR}/gnulib" \
- git-r3_src_unpack
- else
- default
- fi
+ # We need to mess with gnulib :-/
+ EGIT_REPO_URI="https://git.savannah.gnu.org/r/gnulib.git" \
+ EGIT_CHECKOUT_DIR="${WORKDIR}/gnulib" \
+ git-r3_src_unpack
}
src_prepare() {
default
- if [[ "${PV}" == *9999 ]] ; then
- local bootstrap_opts=(
- --gnulib-srcdir=../gnulib
- --no-bootstrap-sync
- --copy
- --no-git
- --skip-po
- )
- AUTORECONF="/bin/true" \
- LIBTOOLIZE="/bin/true" \
- sh ./bootstrap "${bootstrap_opts[@]}" || die
- eautoreconf
- fi
+
+ local bootstrap_opts=(
+ --gnulib-srcdir=../gnulib
+ --no-bootstrap-sync
+ --copy
+ --no-git
+ --skip-po
+ )
+ AUTORECONF="/bin/true" \
+ LIBTOOLIZE="/bin/true" \
+ sh ./bootstrap "${bootstrap_opts[@]}" || die
+ eautoreconf
}
src_configure() {