summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-11-20 11:19:06 -0500
committerMike Gilbert <floppym@gentoo.org>2016-11-20 11:21:11 -0500
commitf29adf534acbc354b1d27b2dd689108bf64f5ff1 (patch)
treee4998a67f5955b93878ac684d5178f1e6652f7cb /net-misc
parentkde-apps/konsole: backport patch from upstream making the file filter optional (diff)
downloadgentoo-f29adf534acbc354b1d27b2dd689108bf64f5ff1.tar.gz
gentoo-f29adf534acbc354b1d27b2dd689108bf64f5ff1.tar.bz2
gentoo-f29adf534acbc354b1d27b2dd689108bf64f5ff1.zip
net-misc/openconnect: general ebuild cleanup
Package-Manager: portage-2.3.2_p8
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openconnect/openconnect-9999.ebuild37
1 files changed, 18 insertions, 19 deletions
diff --git a/net-misc/openconnect/openconnect-9999.ebuild b/net-misc/openconnect/openconnect-9999.ebuild
index 7e5fb543bcb6..5f4b500e0013 100644
--- a/net-misc/openconnect/openconnect-9999.ebuild
+++ b/net-misc/openconnect/openconnect-9999.ebuild
@@ -87,24 +87,25 @@ src_configure() {
if use doc; then
python_setup
else
- # If the python cannot be found, the docs will not build
- sed -e 's#"${ac_cv_path_PYTHON}"#""#' -i configure || die
+ export PYTHON=/bin/false
fi
- # liboath not in portage
- econf \
- --with-vpnc-script="${EPREFIX}/etc/openconnect/openconnect.sh" \
- --without-openssl-version-check \
- $(use_enable static-libs static) \
- $(use_enable nls ) \
- $(use_with !gnutls openssl) \
- $(use_with gnutls ) \
- $(use_with libproxy) \
- $(use_with lz4) \
- $(use_with gssapi) \
- $(use_with smartcard libpcsclite) \
- $(use_with stoken) \
+ local myconf=(
+ --with-vpnc-script="${EPREFIX}/etc/openconnect/openconnect.sh"
+ --without-openssl-version-check
+ $(use_enable static-libs static)
+ $(use_enable nls)
+ $(use_with !gnutls openssl)
+ $(use_with gnutls)
+ $(use_with libproxy)
+ $(use_with lz4)
+ $(use_with gssapi)
+ $(use_with smartcard libpcsclite)
+ $(use_with stoken)
$(use_with java)
+ )
+
+ econf "${myconf[@]}"
}
DOC_CONTENTS="The init script for openconnect supports multiple vpn tunnels.
@@ -135,9 +136,8 @@ chmod 755 /etc/openconnect/vpn0/*
"
src_install() {
- emake DESTDIR="${D}" install
+ default
- dodoc AUTHORS TODO
newinitd "${FILESDIR}"/openconnect.init.in-r4 openconnect
dodir /etc/openconnect
insinto /etc/openconnect
@@ -148,8 +148,7 @@ src_install() {
newins "${FILESDIR}"/openconnect.logrotate openconnect
keepdir /var/log/openconnect
- # Remove useless .la files
- prune_libtool_files --all
+ prune_libtool_files
readme.gentoo_create_doc
}