summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-05 18:41:33 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-05 19:00:40 -0400
commitf357a37dedf7864b9196948c81996e92c3ad0b42 (patch)
tree09a1e4cb6c078d809f3c2a769fe68d917ca43f82 /net-misc
parentnet-misc/liveice: EAPI7->8, add missing ncurses dep (diff)
downloadgentoo-f357a37dedf7864b9196948c81996e92c3ad0b42.tar.gz
gentoo-f357a37dedf7864b9196948c81996e92c3ad0b42.tar.bz2
gentoo-f357a37dedf7864b9196948c81996e92c3ad0b42.zip
net-misc/liveice: fix build with upcoming clang16
Was not the intention but has side-effect of fixing #861644 too. (note revbump was done in previous commit at same time) Closes: https://bugs.gentoo.org/861644 Closes: https://bugs.gentoo.org/870838 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/liveice/files/liveice-2000530-clang16.patch37
-rw-r--r--net-misc/liveice/liveice-2000530-r3.ebuild5
2 files changed, 41 insertions, 1 deletions
diff --git a/net-misc/liveice/files/liveice-2000530-clang16.patch b/net-misc/liveice/files/liveice-2000530-clang16.patch
new file mode 100644
index 000000000000..6d1964a9c097
--- /dev/null
+++ b/net-misc/liveice/files/liveice-2000530-clang16.patch
@@ -0,0 +1,37 @@
+Also issues with implicit basename(3), but that is handled from the ebuild.
+https://bugs.gentoo.org/861644
+https://bugs.gentoo.org/870838
+--- a/mixer.c
++++ b/mixer.c
+@@ -29,4 +29,5 @@
+ #include "audio_proc.h"
+ #include "controls.h"
++#include "url.h"
+
+
+@@ -40,4 +41,5 @@
+ #include <time.h>
+
++int parse_file_metadata(char *filename,char **title,char **artist,char **album,char **url);
+
+ short audio_buffer[BUF_SIZE];
+--- a/mixer.h
++++ b/mixer.h
+@@ -157,2 +157,3 @@
+ void write_logfile(cptr ch);
+ void execute_update_script(cptr ch);
++void shout_streamer(void);
+--- a/streams.c
++++ b/streams.c
+@@ -32,4 +32,5 @@
+ #include "serverlib.h"
+ #include "audio_proc.h"
++#include "mixer.h"
+
+ #ifdef SOUNDCARD_SUPPORT
+--- a/url.h
++++ b/url.h
+@@ -11,2 +11,3 @@
+ int string_contains(char *string,char *seek);
+ void strtoupper(char *string);
++char *url_encode(char *str, char **result_p);
diff --git a/net-misc/liveice/liveice-2000530-r3.ebuild b/net-misc/liveice/liveice-2000530-r3.ebuild
index 822c02d34884..d00733459f71 100644
--- a/net-misc/liveice/liveice-2000530-r3.ebuild
+++ b/net-misc/liveice/liveice-2000530-r3.ebuild
@@ -22,6 +22,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-clang16.patch
)
src_prepare() {
@@ -34,7 +35,9 @@ src_configure() {
tc-export CC
append-flags -fcommon
- default
+ # seems to expect GNU's basename, but use simple builtin my_basename
+ # rather than assume by forcing either -D_GNU_SOURCE or <libgen.h>
+ econf ac_cv_func_basename=no #870838
}
src_install() {