summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-20 01:50:38 +0100
committerSam James <sam@gentoo.org>2021-04-20 02:20:39 +0100
commitec5cfb01429f7ecb7ccf037517695d619ae8850a (patch)
treeee4a16955d951281abfdab97baabc264be4b56e5 /net-nntp/newspost/newspost-2.1.1-r3.ebuild
parentnet-news/rsstool: port to EAPI 7 (diff)
downloadgentoo-ec5cfb01429f7ecb7ccf037517695d619ae8850a.tar.gz
gentoo-ec5cfb01429f7ecb7ccf037517695d619ae8850a.tar.bz2
gentoo-ec5cfb01429f7ecb7ccf037517695d619ae8850a.zip
net-nntp/newspost: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-nntp/newspost/newspost-2.1.1-r3.ebuild')
-rw-r--r--net-nntp/newspost/newspost-2.1.1-r3.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/net-nntp/newspost/newspost-2.1.1-r3.ebuild b/net-nntp/newspost/newspost-2.1.1-r3.ebuild
index 0bcce1c68dc6..b0633bc47a2a 100644
--- a/net-nntp/newspost/newspost-2.1.1-r3.ebuild
+++ b/net-nntp/newspost/newspost-2.1.1-r3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit epatch toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="A usenet binary autoposter for unix"
HOMEPAGE="http://newspost.unixcab.org/"
@@ -12,13 +12,16 @@ SRC_URI="http://newspost.unixcab.org/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-src_prepare() {
+PATCHES=(
# Should fix some problems with unexpected server replies, cf. bug 185468
- epatch "${FILESDIR}"/${P}-nntp.patch
- epatch "${FILESDIR}"/CAN-2005-0101.patch
- epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+ "${FILESDIR}"/${P}-nntp.patch
+ "${FILESDIR}"/CAN-2005-0101.patch
+ "${FILESDIR}"/${P}-glibc-2.10.patch
+)
+
+src_prepare() {
+ default
sed -e "/-strip newspost/d" -i Makefile || die
}