summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Kappus <joe@wt.gd>2024-06-03 01:23:18 -0400
committerJoonas Niilola <juippis@gentoo.org>2024-07-20 07:14:38 +0300
commita622299dfbcc5d42b1e9a4e1418b1bbf64323cdd (patch)
treed9b992ab93098c7a1cdb7ec63c9b51968600a411 /net-nntp
parentmedia-video/ffmpeg: fix AMD AV1 vaapi regression w/ newer mesa for 6.1.x (diff)
downloadgentoo-a622299dfbcc5d42b1e9a4e1418b1bbf64323cdd.tar.gz
gentoo-a622299dfbcc5d42b1e9a4e1418b1bbf64323cdd.tar.bz2
gentoo-a622299dfbcc5d42b1e9a4e1418b1bbf64323cdd.zip
net-nntp/sabnzbd: add 4.3.2
Signed-off-by: Joe Kappus <joe@wt.gd> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/sabnzbd/Manifest1
-rw-r--r--net-nntp/sabnzbd/sabnzbd-4.3.2.ebuild173
2 files changed, 174 insertions, 0 deletions
diff --git a/net-nntp/sabnzbd/Manifest b/net-nntp/sabnzbd/Manifest
index 43a63e57d5ce..12586c28bf86 100644
--- a/net-nntp/sabnzbd/Manifest
+++ b/net-nntp/sabnzbd/Manifest
@@ -1,2 +1,3 @@
DIST SABnzbd-4.2.3-src.tar.gz 5096209 BLAKE2B 60d52f89cd85d942d50310b25016a33983889ee13e380785e3510b954e82ce6c29f867e4cf21814e4a949b9f0484cf55766583234bed7e91432a3a741ac3ba3a SHA512 446985d6c5faddd90bff097a55fb2e4e588f9d5aad42215187bade57dab9b00c132d8d9116c68b8210b51d382740a97908f2b5d071cbf6b90fe9c7ecbfc65398
DIST SABnzbd-4.3.1-src.tar.gz 5104424 BLAKE2B d37b06da3943e1ae196b139c5c9be57b7c6af6225535ef3ca95c55dd93b6a64c7a2c2f73494c173d3284e63065f5a8867057a377ccf6505de7f6a2daa8b62a5f SHA512 99584a6e66c81bea59d9c139deb8c9683804000c09feb6df10c96ec52c3d9deedd794cee3d9db845b58c27d151cc2fcd1be1b022ce256f750dc45ba8d4ecae52
+DIST SABnzbd-4.3.2-src.tar.gz 5106752 BLAKE2B 0f8c934b862354158e8aa081adc9beec285e2f3b01899b6ae4e51e7b236aacf1a5dfff21a4e847add1412c620cd6da2e7c2e38173c3450443b37142332ab5659 SHA512 3b119ac4f3de55191e9ed4668b5423e680a11e12f98f0d3d82cc7e2195af316c30711372771a6ab863bcc3fdf39e79f121781341872b42cfbdec332f63ffc29a
diff --git a/net-nntp/sabnzbd/sabnzbd-4.3.2.ebuild b/net-nntp/sabnzbd/sabnzbd-4.3.2.ebuild
new file mode 100644
index 000000000000..2398a9bbcbb2
--- /dev/null
+++ b/net-nntp/sabnzbd/sabnzbd-4.3.2.ebuild
@@ -0,0 +1,173 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite"
+
+inherit optfeature python-single-r1 systemd
+
+MY_PV="${PV/_alpha/Alpha}"
+MY_PV="${MY_PV/_beta/Beta}"
+MY_PV="${MY_PV/_rc/RC}"
+
+MY_P="SABnzbd-${MY_PV}"
+
+DESCRIPTION="Binary newsgrabber with web-interface"
+HOMEPAGE="https://sabnzbd.org/"
+SRC_URI="https://github.com/sabnzbd/sabnzbd/releases/download/${MY_PV}/${MY_P}-src.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+# Sabnzbd is GPL-2 but bundles software with the following licenses.
+LICENSE="GPL-2 BSD LGPL-2 MIT BSD-1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ acct-user/sabnzbd
+ acct-group/sabnzbd
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=dev-python/apprise-1.8.0[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/cheetah3[${PYTHON_USEDEP}]
+ dev-python/cherrypy[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/feedparser-6.0.11[${PYTHON_USEDEP}]
+ >=dev-python/guessit-3.8.0[${PYTHON_USEDEP}]
+ dev-python/notify2[${PYTHON_USEDEP}]
+ dev-python/portend[${PYTHON_USEDEP}]
+ dev-python/puremagic[${PYTHON_USEDEP}]
+ ~dev-python/sabctools-8.2.3[${PYTHON_USEDEP}]
+ ')
+"
+RDEPEND="
+ ${DEPEND}
+ || (
+ >=app-arch/par2cmdline-0.8
+ >=app-arch/par2cmdline-turbo-1.1.0
+ )
+ net-misc/wget
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.5.0[${PYTHON_USEDEP}]
+ <dev-python/pyfakefs-5.4.0[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ ~dev-python/pytest-7.4.4[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/selenium[${PYTHON_USEDEP}]
+ dev-python/tavalidate[${PYTHON_USEDEP}]
+ >=dev-python/tavern-2[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ ')
+ app-arch/p7zip
+ app-arch/unrar
+ app-arch/unzip
+ www-apps/chromedriver-bin
+ )
+"
+
+src_test() {
+ local EPYTEST_IGNORE=(
+ # network sandbox
+ tests/test_getipaddress.py
+ tests/test_rss.py
+ tests/test_urlgrabber.py
+ tests/test_utils/test_happyeyeballs.py
+ tests/test_utils/test_internetspeed.py
+ )
+ local EPYTEST_DESELECT=(
+ # network sandbox
+ 'tests/test_cfg.py::TestValidators::test_validate_host'
+ 'tests/test_consistency.py::TestWiki'
+ 'tests/test_newswrapper.py::TestNewsWrapper'
+ 'tests/test_happyeyeballs.py::TestHappyEyeballs'
+ 'tests/test_internetspeed.py::TestInternetSpeed'
+ # Just plain fails
+ 'tests/test_newsunpack.py::TestPar2Repair::test_basic'
+ # Chromedriver tests don't want to behave in portage
+ 'tests/test_functional_config.py::TestBasicPages::test_base_pages'
+ 'tests/test_functional_config.py::TestBasicPages::test_base_submit_pages'
+ 'tests/test_functional_config.py::TestConfigLogin::test_login'
+ 'tests/test_functional_config.py::TestConfigCategories::test_page'
+ 'tests/test_functional_config.py::TestConfigRSS::test_rss_basic_flow'
+ 'tests/test_functional_config.py::TestConfigServers::test_add_and_remove_server'
+ 'tests/test_functional_downloads.py::TestDownloadFlow::test_download_basic_rar5'
+ 'tests/test_functional_downloads.py::TestDownloadFlow::test_download_zip'
+ 'tests/test_functional_downloads.py::TestDownloadFlow::test_download_7zip'
+ 'tests/test_functional_downloads.py::TestDownloadFlow::test_download_passworded'
+ 'tests/test_functional_downloads.py::TestDownloadFlow::test_download_fully_obfuscated'
+ 'tests/test_functional_downloads.py::TestDownloadFlow::test_download_unicode_rar'
+ 'tests/test_functional_misc.py::TestShowLogging::test_showlog'
+ 'tests/test_functional_misc.py::TestQueueRepair::test_queue_repair'
+ 'tests/test_functional_misc.py::TestDaemonizing::test_daemonizing'
+ 'tests/test_functional_sorting.py::TestDownloadSorting'
+ )
+
+ # The test suite is prone to being broken by random plugins that happen
+ # to be installed, so disable autoloading.
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # Use PYTEST_PLUGINS instead of args to 'epytest' because the test suite
+ # calls pytest itself and the args would get lost. To get the list of plugins,
+ # if stuck, comment out the AUTOLOAD line above, look at the list of loaded
+ # plugins at the top of the pytest output, then translate those into module names
+ # by e.g. checking equery f.
+ local -x PYTEST_PLUGINS=pytest_mock,tavern,tavern._core.pytest,pyfakefs.pytest_plugin,pytest_asyncio.plugin
+
+ epytest -s
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r email icons interfaces locale po sabnzbd scripts tools
+
+ exeinto /usr/share/${PN}
+ doexe SABnzbd.py
+
+ python_fix_shebang "${ED}"/usr/share/${PN}
+ python_optimize "${ED}"/usr/share/${PN}
+
+ newinitd "${FILESDIR}"/${PN}-r1.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+
+ diropts -o ${PN} -g ${PN}
+ dodir /etc/${PN}
+ keepdir /var/log/${PN}
+
+ insinto "/etc/${PN}"
+ insopts -m 0600 -o "${PN}" -g "${PN}"
+ newins "${FILESDIR}"/${PN}-r1.ini ${PN}.ini
+
+ dodoc ISSUES.txt README.mkd
+
+ systemd_newunit "${FILESDIR}"/sabnzbd_at.service 'sabnzbd@.service'
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ einfo "Default directory: /var/lib/${PN}"
+ einfo
+ einfo "To add a user to the sabnzbd group so it can edit SABnzbd+ files, run:"
+ einfo
+ einfo " usermod -a -G sabnzbd <user>"
+ einfo
+ einfo "By default, SABnzbd will listen on TCP port 8080."
+ fi
+
+ optfeature "7z archive support" app-arch/p7zip
+ optfeature "rar archive support" app-arch/unrar app-arch/rar
+ optfeature "zip archive support" app-arch/unzip
+}