summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2018-03-31 13:35:17 +0200
committerDavid Seifert <soap@gentoo.org>2018-04-11 12:14:09 +0200
commitfebc67374d611c52de31b10fe5a3ecacacf9fc5d (patch)
tree14d968224d15fc2f000af64cab9fd19d5657bf5b /net-p2p/airdcpp-webclient
parentsys-block/di: Minor patch correction. (diff)
downloadgentoo-febc67374d611c52de31b10fe5a3ecacacf9fc5d.tar.gz
gentoo-febc67374d611c52de31b10fe5a3ecacacf9fc5d.tar.bz2
gentoo-febc67374d611c52de31b10fe5a3ecacacf9fc5d.zip
net-p2p/airdcpp-webclient: bump to 2.3.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7735
Diffstat (limited to 'net-p2p/airdcpp-webclient')
-rw-r--r--net-p2p/airdcpp-webclient/Manifest1
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-2.3.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/net-p2p/airdcpp-webclient/Manifest b/net-p2p/airdcpp-webclient/Manifest
index 1aff833d625e..573f9f416914 100644
--- a/net-p2p/airdcpp-webclient/Manifest
+++ b/net-p2p/airdcpp-webclient/Manifest
@@ -1 +1,2 @@
DIST airdcpp-webclient-2.2.1.tar.gz 845507 BLAKE2B 5d97fe5d25957d870cc5480153acb746ac20bc398e637ccf25a98e42cc905fb445bbc47c211174552e0ee23d1affb0a9265d8499389373bf6622b14428300bd5 SHA512 97c5b32e590b2fc735fe4978c1a173272c55f84fe97212f7cd1e8bd4a279553c1d992573185781aeceafbbe6bb51303ddb2cd164c748fa798993a661f3abfb81
+DIST airdcpp-webclient-2.3.0.tar.gz 880508 BLAKE2B 426c0582ffad734cae2f66826aa04b2db791a110abc79629f4e3b71a69db354b56d213feae6d807f3b7a3f2906aac00fc50c49eaf3dc7d8e09783f59c99ef4e5 SHA512 b1f47c8f500aa684a8cabcff916b6a1e41230d949a35d57c80f13734f6f88f8c3a31d99f64cc1f6e316d26710da894670f130baf78fec5ecf3a70a70f0d7417a
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-2.3.0.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.3.0.ebuild
new file mode 100644
index 000000000000..9c72310e8ce0
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.3.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
+
+inherit cmake-utils python-any-r1 user
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://airdcpp-web.github.io/"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="nat-pmp +tbb +webui"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-cpp/websocketpp
+ dev-libs/boost:=
+ dev-libs/leveldb:=
+ dev-libs/libmaxminddb:=
+ dev-libs/openssl:0=[-bindist]
+ net-libs/miniupnpc:=
+ sys-libs/zlib:=
+ virtual/libiconv
+ nat-pmp? ( net-libs/libnatpmp:= )
+ tbb? ( dev-cpp/tbb:= )
+"
+DEPEND="
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+ ${RDEPEND}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ enewgroup airdcppd
+ enewuser airdcppd -1 -1 /var/lib/airdcppd airdcppd
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_WEB_UI=OFF
+ -DENABLE_NATPMP=$(usex nat-pmp)
+ -DENABLE_TBB=$(usex tbb)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ newconfd "${FILESDIR}/airdcppd.confd" airdcppd
+ newinitd "${FILESDIR}/airdcppd.initd" airdcppd
+ keepdir /var/lib/airdcppd
+ fowners airdcppd:airdcppd /var/lib/airdcppd
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}