summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-11-27 15:03:11 -0500
committerAnthony G. Basile <blueness@gentoo.org>2015-11-27 15:08:35 -0500
commit4d4bfe017e568d0f596ef21127306678a2faab02 (patch)
tree98d3b262c410d12ba1169310963f2ca4911ff5fe /net-p2p/bitcoin-cli/bitcoin-cli-0.11.2.ebuild
parentdev-util/bitcoin-tx: version bump 0.11.2 (diff)
downloadgentoo-4d4bfe017e568d0f596ef21127306678a2faab02.tar.gz
gentoo-4d4bfe017e568d0f596ef21127306678a2faab02.tar.bz2
gentoo-4d4bfe017e568d0f596ef21127306678a2faab02.zip
net-p2p/bitcoin-cli: version bump to 0.11.2
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-p2p/bitcoin-cli/bitcoin-cli-0.11.2.ebuild')
-rw-r--r--net-p2p/bitcoin-cli/bitcoin-cli-0.11.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-p2p/bitcoin-cli/bitcoin-cli-0.11.2.ebuild b/net-p2p/bitcoin-cli/bitcoin-cli-0.11.2.ebuild
new file mode 100644
index 000000000000..e5a6ee6e9c8f
--- /dev/null
+++ b/net-p2p/bitcoin-cli/bitcoin-cli-0.11.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2010-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+BITCOINCORE_COMMITHASH="7e278929df53e1fb4191bc5ba3176a177ce718bf"
+BITCOINCORE_LJR_DATE="20151118"
+BITCOINCORE_IUSE="ljr"
+inherit bash-completion-r1 bitcoincore
+
+DESCRIPTION="Command-line JSON-RPC client specifically designed for talking to Bitcoin Core Daemon"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+src_prepare() {
+ sed -i 's/have bitcoind &&//;s/^\(complete -F _bitcoind \)bitcoind \(bitcoin-cli\)$/\1\2/' contrib/bitcoind.bash-completion || die
+ bitcoincore_src_prepare
+}
+
+src_configure() {
+ bitcoincore_conf \
+ --enable-util-cli
+}
+
+src_install() {
+ bitcoincore_src_install
+
+ doman contrib/debian/manpages/bitcoin-cli.1
+
+ newbashcomp contrib/bitcoind.bash-completion ${PN}
+}