summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-09-12 22:51:39 -0400
committerMike Frysinger <vapier@gentoo.org>2015-09-12 22:52:22 -0400
commitdc985c3cb2c8094313f60553c2a488f9bd39002d (patch)
treefc2d6b78cbfa7fae2077027ac2692463988bfb00 /net-p2p/ctorrent/ctorrent-3.3.2-r3.ebuild
parentnet-misc/openssh: revert improper 4411ff42539dc7917a8db314327c6fbe699a616f (diff)
downloadgentoo-dc985c3cb2c8094313f60553c2a488f9bd39002d.tar.gz
gentoo-dc985c3cb2c8094313f60553c2a488f9bd39002d.tar.bz2
gentoo-dc985c3cb2c8094313f60553c2a488f9bd39002d.zip
net-p2p/ctorrent: workaround broken rTorrent files
Diffstat (limited to 'net-p2p/ctorrent/ctorrent-3.3.2-r3.ebuild')
-rw-r--r--net-p2p/ctorrent/ctorrent-3.3.2-r3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-p2p/ctorrent/ctorrent-3.3.2-r3.ebuild b/net-p2p/ctorrent/ctorrent-3.3.2-r3.ebuild
new file mode 100644
index 000000000000..d667683b3923
--- /dev/null
+++ b/net-p2p/ctorrent/ctorrent-3.3.2-r3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+MY_P="${PN}-dnh${PV}"
+
+DESCRIPTION="Enhanced CTorrent is a BitTorrent console client written in C and C++"
+HOMEPAGE="http://www.rahul.net/dholmes/ctorrent/"
+SRC_URI="mirror://sourceforge/dtorrent/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND="dev-libs/openssl:="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-CVE-2009-1759.patch
+ epatch "${FILESDIR}"/${P}-negative-ints.patch
+ epatch "${FILESDIR}"/${P}-empty-path-components.patch
+}