summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-p2p/ed2k_hash
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-p2p/ed2k_hash')
-rw-r--r--net-p2p/ed2k_hash/Manifest1
-rw-r--r--net-p2p/ed2k_hash/ed2k_hash-0.4.0-r1.ebuild36
-rw-r--r--net-p2p/ed2k_hash/files/ed2k_64bit.patch12
-rw-r--r--net-p2p/ed2k_hash/metadata.xml8
4 files changed, 57 insertions, 0 deletions
diff --git a/net-p2p/ed2k_hash/Manifest b/net-p2p/ed2k_hash/Manifest
new file mode 100644
index 000000000000..e52f53d1715c
--- /dev/null
+++ b/net-p2p/ed2k_hash/Manifest
@@ -0,0 +1 @@
+DIST ed2k_hash-0.4.0.tar.gz 113158 SHA256 554b2d9fb3ce668312341f43bafc95cf985059d83bf5e82f92547610c7f2bf18 SHA512 f924c6b39bf82fe0d4e68decb5ae9fb5ce2999e8b1d3083ba97c178f3f716634603982962947cecb2ef20de56672b10e833d104bae9627ae180ba629c9e1b4c6 WHIRLPOOL e65036d632a6dfed746c851c76727fe43ae3fbb7818a0ec2d26d0190279b9a119c2854158124c5bc493ada9421acc0bfcf9229ab3f016e291ac9f8f0c7264481
diff --git a/net-p2p/ed2k_hash/ed2k_hash-0.4.0-r1.ebuild b/net-p2p/ed2k_hash/ed2k_hash-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..666a7b1de820
--- /dev/null
+++ b/net-p2p/ed2k_hash/ed2k_hash-0.4.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit flag-o-matic eutils
+
+DESCRIPTION="Tool for generating eDonkey2000 links"
+HOMEPAGE="http://ed2k-tools.sourceforge.net/ed2k_hash.shtml"
+RESTRICT="mirror"
+SRC_URI="mirror://sourceforge/ed2k-tools/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE="fltk"
+DEPEND="fltk? ( x11-libs/fltk:1 )"
+
+src_prepare() {
+ epatch "${FILESDIR}/ed2k_64bit.patch"
+}
+
+src_configure() {
+ if use fltk; then
+ append-ldflags "$(fltk-config --ldflags)"
+ export CPPFLAGS="$(fltk-config --cxxflags)"
+ else
+ export ac_cv_lib_fltk_main='no'
+ fi
+
+ econf --disable-dependency-tracking
+}
+
+src_install() {
+ emake install DESTDIR="${D}" mydocdir=/usr/share/doc/${PF}/html
+ dodoc AUTHORS INSTALL README TODO
+}
diff --git a/net-p2p/ed2k_hash/files/ed2k_64bit.patch b/net-p2p/ed2k_hash/files/ed2k_64bit.patch
new file mode 100644
index 000000000000..7425bb0c03fc
--- /dev/null
+++ b/net-p2p/ed2k_hash/files/ed2k_64bit.patch
@@ -0,0 +1,12 @@
+--- ed2k_hash-0.4.0/work/ed2k_hash-0.4.0/ed2k_hash/md4.h 2002-09-04 18:24:37.000000000 +0100
++++ ed2k_hash-0.4.0_orig/work/ed2k_hash-0.4.0/ed2k_hash/md4.h 2004-09-02 21:13:49.900613616 +0100
+@@ -66,7 +66,8 @@
+ typedef unsigned short int UINT2;
+
+ /* UINT4 defines a four byte word */
+-typedef unsigned long int UINT4;
++/* unsigned long int on 64bit is 8 bits */
++typedef unsigned int UINT4;
+
+ /* PROTO_LIST is defined depending on how PROTOTYPES is defined above.
+ If using PROTOTYPES, then PROTO_LIST returns the list, otherwise it
diff --git a/net-p2p/ed2k_hash/metadata.xml b/net-p2p/ed2k_hash/metadata.xml
new file mode 100644
index 000000000000..d3e5908971f1
--- /dev/null
+++ b/net-p2p/ed2k_hash/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-p2p</herd>
+ <upstream>
+ <remote-id type="sourceforge">ed2k-tools</remote-id>
+ </upstream>
+</pkgmetadata>